Announcement

Collapse
No announcement yet.

ICMP broadcast and multicast requests

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ICMP broadcast and multicast requests

    My system is configured in such a way to respond for ICMP broadcast and multicast requests from outside our network. Below command will give the details:
    server1:~# ndd -get /dev/ip ip_respond_to_echo_multicast -> 1
    server1:~# ndd -get /dev/ip ip_respond_to_echo_broadcast -> 1
    server1:~# ndd -get /dev/ip ip6_respond_to_echo_multicast -> 1

    It means currently it is enabled to respond to ICMP broadcast and multicast requests.
    Command to get system interface broadcast address is ifconfig a and command to get system interface multicast address is arp a.
    server:~# ifconfig -a
    lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv 4,VIRTUAL> mtu 8232 index 1
    inet 127.0.0.1 netmask ff000000
    ce3: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 3
    inet 10.0.1.1 netmask ffffff00 broadcast 10.191.2.255

    server:~# arp -a
    Net to Media Table: IPv4
    Device IP Address Mask Flags Phys Addr
    ce3 server1 255.255.255.255
    ce3 server2 255.255.255.255 SPLA
    ce5 server3 255.255.255.255 SPLA
    ce4 server4 255.255.255.255 SPLA
    ce5 224.0.0.0 240.0.0.0 SM
    ce4 224.0.0.0 240.0.0.0 SM
    ce3 224.0.0.0 240.0.0.0 SM

    Note: M indicates it is the multicast address used by that interface.

    Queries:
    > If I tried sending ICMP request to multicast address by following command: ping 224.0.0.0 from my laptop, I didnt get response from server1. (as the above parameters are enabled, I need to get response)
    > If I tried sending ICMP request to broadcast address by following command: ping 10.191.2.255 from my laptop, I didnt get response from server1. (as the above parameters are enabled, I need to get response)

    Rgrds,
    Ram.

  • #2
    > server:~# ifconfig -a
    > lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv 4,VIRTUAL> mtu 8232 index 1 inet 127.0.0.1 netmask ff000000
    > ce3: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 3 inet 10.0.1.1 netmask ffffff00 broadcast 10.191.2.255

    just out of interest do you really have ce3 set to 10.0.1.1 with a netmask of 255.255.255.0?

    if so then your broadcast should be 10.0.1.255 ...

    Comment

    Working...
    X