Announcement

Collapse
No announcement yet.

Hacking Express gate (Asus Splashtop)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • brings up a black screen
    Means you did something wrong. I can't help you there, as I don't know how to change resolution myself. Try asking linux-guru somewhere on irc or jabber-conferences, as there are just X.org and configuration is the same as in normal linux.

    Comment


    • I tried to use Terminal to edit xorg.conf inside Express Gate, but I can't seem to do so. After I cd into /etc, I tried to sudo nano xorg.conf, but it doesn't work. I've tried sudo gedit too, but it's not working! Can anyone help?

      Does anyone know how I can add resolution modes so that I can switch to 1920x1080?

      Comment


      • I tried to use Terminal to edit xorg.conf inside Express Gate
        You cant edit anything inside EG. The content of / is located at RAM disk and is temporarily. The only method to do so is unsquash -> edit -> re-squash packages in asus.sys folder.

        Comment


        • Then can I know how to add resolution modes?

          Comment


          • Then can I know how to add resolution modes?
            As I said - I don't know how to do it.

            If you manage to find information about that - please post it here, or at least your modified bs-tinyx.sqx or bs-xorg.sqx or whatever you might change.

            Comment


            • I don't have a file named bs-tinyx.sqx for some reason!

              Comment


              • I've been trying for the past week to change the resolution. I've tried using the terminal with the command xrandr -s "1920x1080x32" but it says "1920x1080" is an unsupported mode. I then tried to xrandr --addmode <output> "1920x1080x32" but I don't know what to put for output. I've tried VGA-0, VGA-1, and nothing works. What the hell is the output supposed to be? I'm just one step away from adding a resolution mode and getting Express Gate to work at 1080p!

                Comment


                • Okay, well I've managed to get my SplashTop running at 1680x1050 (native) if only temporarily (I broke it soon afterwards trying to update Pidgin) but if you are looking for a bit of help with it (and a script and some apps to make your life easier) I have started hosting a section on my website dedicated to hacking ExpressGate...

                  If anyone is interested here it is:
                  http://www.sierrasoftworks.com/expressgate

                  Also, if anyone is interested in expanding on the info that appears there just contact me (prefferably via e-mail at contact@sierrasoftworks.com)

                  Regards,
                  SPARTAN

                  Comment


                  • xrandr --verbose
                    - prints (among other things) available and connected outputs

                    Comment


                    • @SPARTAN

                      Maybe you should check the links.

                      Comment


                      • Sorry about that, links are fixed now

                        Comment


                        • Maybe in your dreams, try to click on every link...

                          Comment


                          • Asus Eee Pc 1001P netbook with EG

                            Not sure if my situation directly applies, as it's not about an on-board solution, but worth asking anyway.

                            My Asus eeepc 1001p has Express Gate installed on a partition on the hard drive. I installed Ubuntu 10.04 and have read-write access to the files. Dropped va-term.sqx into file system and now have a working "Term" launcer on panel. I have spent some time searching and experimenting, feeling kinda stuck now.

                            Problem is screen resolution. It only does 800x600, screen native is 1024x600.

                            echo $DVM_MODEL gives "default"
                            dmidecode -s system-product-name reveals "1001P"
                            There is no dir /etc/models.d/1001P

                            I can change the variables with:
                            export DI_HAVE_RES_DDC='yes'
                            export DI_HAVE_RES_LIST='640x480x24x60,800x600x24x60,1024 x600x24x60'
                            .. but after doing so,
                            xrandr still only shows 640x480 and 800x600,
                            and a message "Xlib: extension "Generic Event Extension" missing on display :0.0"

                            Any suggestions welcome.

                            Comment


                            • I dunno if its just a typo here but it looks like you put a space between "1024" and "x600x24x60".
                              Also you may find that XRandr doesn't support non-standard screen ratios (1024x600 for example).

                              I'll take a look just now and see if I can get it to work with that res on my machine and let you know, I assume you have followed my tutorial?
                              If so just redo the following steps:
                              • Open Term
                              • type: export DI_HAVE_RES_DDC='yes'
                              • type: export DI_HAVE_RES_LIST='640x480x24x60,800x600x24x60,1024 x600x24x60'
                              • type: python /usr/lib/dvm-config/RunRes.py
                              • Select 1024x600 from the res list
                              • Restart

                              Good luck

                              Comment


                              • Thank you for you speedy reply.

                                Yes, the extra space in the entry seems to be a forum formatting issue.

                                I did use commands from your guide, but have not "hacked" any files besides adding the terminal. I first wanted to see if the resolution could be changed manually.

                                Running your commands brings up the "Screen Settings" window,
                                with only one tab "Select Theme" (only one option), an "OK" button and one "Cancel".
                                In the background I see two messages about the missing "Generic Event Extension", some more about Clearlooks configuration options not supported and will be ignored.

                                I'm guessing a restart is necessary to activate any changes, but changes in the live environment do not save back to the hard drive. In that case, editing files in the /ASUS.SYS directory would be necessary. Some posts talk about changing "bs-xorg-1.6.0.sqx" to add those export options. I like your guide about adding a "va-customres" file better. Since it's a hard drive installation, I don't need to worry about create a DFI image, right?

                                Downloading and installing squashfs-3.4 right now.

                                Comment

                                Working...
                                X