Announcement

Collapse
No announcement yet.

ASPM Linux Kernel Fix To Land Finally In 3.2 Series

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ASPM Linux Kernel Fix To Land Finally In 3.2 Series

    Phoronix: ASPM Linux Kernel Fix To Land Finally In 3.2 Series

    The proper solution to the Linux kernel ASPM power regression will finally be landing in the stable Linux 3.2 kernel series...

    http://www.phoronix.com/vr.php?view=MTA1MzY

  • #2
    Linux kernel 3.2.5 is out now: https://www.kernel.org/pub/linux/ker...hangeLog-3.2.5

    Comment


    • #3
      according to the German heise.de this patch helps to decrease the power consumption on several systems to 1-3 Watt less power.

      a issue which affects probably more systems related to the sandy bridge power safe features still exist According to heise this feature helps to reduce the power consumption with 3-5 Watt. But it doesn't work on Linux.

      Comment


      • #4
        No sooner has it landed than it's a problem. It makes this guy's Soundblaster Live go silent:
        https://lkml.org/lkml/2012/2/7/68

        Comment


        • #5
          Well it does not fix this error however:

          [ 0.191543] ACPI _OSC control for PCIe not granted, disabling ASPM

          Not sure what the dmesg would look like that is fixed by this commit.

          Comment


          • #6
            Yeah I also get these messages on my notebook and desktop, not sure if the patch works or if Matthew just didn't patch the output messages so they're wrong or something.

            Comment


            • #7
              Originally posted by asdx
              I'm running Linux 3.2.5 which has this patch for ASPM but I get this on my ThinkPad T510:

              Code:
              [diego@myhost ~]$ dmesg | grep -i aspm
              [    0.615965] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
              [    0.914598] ACPI _OSC control for PCIe not granted, disabling ASPM
              [    0.931980] ACPI _OSC control for PCIe not granted, disabling ASPM
              [diego@myhost ~]$
              Any ideas?
              That looks a lot like the issue brought up in the mailing list linked above. Try the patch here https://lkml.org/lkml/2012/2/7/284 and see if it fixes it for you - it was reported to work in that thread.

              Comment


              • #8
                “ACPI _OSC control for PCIe not granted, disabling ASPM”

                Dont you have some ACPI error before like on my lenovog470 :

                Linux lap 3.2.6+ #11 SMP Sat Feb 18 15:22:19 CET 2012 x86_64 GNU/Linux

                [ 0.759929] pci 0000:00:1c.1: bridge window [mem 0xd0400000-0xd04fffff]
                [ 0.759948] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
                [ 0.760158] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP01._PRT]
                [ 0.760212] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP02._PRT]
                [ 0.760387] \_SB_.PCI0:_OSC invalid UUID
                [ 0.760389] _OSC request data:1 1f 1f
                [ 0.760392] pci0000:00: Requesting ACPI _OSC control (0x1d)
                [ 0.760507] \_SB_.PCI0:_OSC invalid UUID
                [ 0.760508] _OSC request data:1 0 1d
                [ 0.760511] pci0000:00: ACPI _OSC request failed (AE_ERROR), returned control mask: 0x1d
                [ 0.760565] ACPI _OSC control for PCIe not granted, disabling ASPM
                [ 0.765015] ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 *4 5 6 10 11 12 14 15)

                --
                http://rzr.online.fr/q/aspm#

                Comment

                Working...
                X