Announcement

Collapse
No announcement yet.

The Leading Cause Of The Recent Linux Kernel Power Problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    More complaining to MoBo vendors needed

    Maybe we GNU/Linux users should start to complain more to motherboad manufacturers when there is a problem in GNU/Linux because of badly coded BIOS. If they don't see demand from GNU/Linux users they obviously don't think it is worth supporting it properly. But if there was much more pressure, especially in this case when there are so many people affected, we could become a visible group of users.

    Comment


    • #12
      Thank you for bisecting this

      Credit where it's due - thank you for bisecting this Michael (yes I'm one of the ones who was asking you for this). However what to do about this? The majority usually prefer stability to features.

      Also fun to see in some tiny way I contributed to the workaround...

      Comment


      • #13
        Originally posted by kokoko3k View Post
        On my system i've:
        Code:
        Gozer ~ # dmesg|grep -i aspm
        [    0.216012] pci 0000:01:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
        [    0.216360] pci 0000:03:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
        [    0.216630] pci 0000:02:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
        [    0.217299] Unable to assume _OSC PCIe control. Disabling ASPM
        Should i still try "pcie_aspm=force"?
        Mine is a desktop system, but if i could save some power i would be happy and i have no way to measure it.
        Please read your dmesg-output another time. ASPM is disabled for your system because it it does not support PCIe 1.1 or higher. You can try to force-enable ASPM but your system will likely not support it.

        Comment


        • #14
          Originally posted by glasen View Post
          Please read your dmesg-output another time. ASPM is disabled for your system because it it does not support PCIe 1.1 or higher. You can try to force-enable ASPM but your system will likely not support it.
          Thanks, i was aware about it in the first two lines, but what about:
          Code:
          Gozer ~ # dmesg|grep -2 "_OSC"
          [    0.217190] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P9._PRT]
          [    0.217235] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
          [    0.217262]  pci0000:00: Requesting ACPI _OSC control (0x1d)
          [    0.217299] Unable to assume _OSC PCIe control. Disabling ASPM
          [    0.223823] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *10 11 12 14 15)
          [    0.224180] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 *11 12 14 15)

          Comment


          • #15
            Originally posted by glasen View Post
            Please read your dmesg-output another time. ASPM is disabled for your system because it it does not support PCIe 1.1 or higher. You can try to force-enable ASPM but your system will likely not support it.
            Thanks, but what about the last line:
            Code:
            Gozer ~ # dmesg|grep -2 "_OSC"
            [    0.217190] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P9._PRT]
            [    0.217235] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
            [    0.217262]  pci0000:00: Requesting ACPI _OSC control (0x1d)
            [    0.217299] Unable to assume _OSC PCIe control. Disabling ASPM
            [    0.223823] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *10 11 12 14 15)
            [    0.224180] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 *11 12 14 15)

            Comment


            • #16
              In my case I had:
              ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

              With pcie_aspm=force I have:
              PCIe ASPM is forcedly enabled
              ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

              I wonder if it's enabled now or not...

              # cat /sys/module/pcie_aspm/parameters/policy
              [default] performance powersave

              And if the "default" is powersave or performance? I changed it to "powersave" for now.

              Hardware: HP laptop, Core i5-450M, kernel 3.0-rc4
              Last edited by ahlaht; 06-27-2011, 04:46 AM.

              Comment


              • #17
                So pre-PCIe hardware is unaffected - that's also good to know.

                3 of my machines don't have PCIe, so at least they cannot be affected by this.

                Is there a specific line in dmesg that shows that a machine is affected? E.g. "ASPM disabled in BIOS - ASPM ignored.", or similar?

                Comment


                • #18
                  Originally posted by chrisr View Post
                  3 of my machines don't have PCIe, so at least they cannot be affected by this.

                  Is there a specific line in dmesg that shows that a machine is affected? E.g. "ASPM disabled in BIOS - ASPM ignored.", or similar?
                  Check some posts up, the answer is in a question.

                  Comment


                  • #19
                    Yep:
                    Code:
                    [    0.504383] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

                    Comment


                    • #20
                      Originally posted by ahlaht View Post
                      In my case I had:
                      ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

                      With pcie_aspm=force I have:
                      PCIe ASPM is forcedly enabled
                      ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

                      I wonder if it's enabled now or not...

                      # cat /sys/module/pcie_aspm/parameters/policy
                      [default] performance powersave

                      And if the "default" is powersave or performance? I changed it to "powersave" for now.

                      Hardware: HP laptop, Core i5-450M, kernel 3.0-rc4
                      I am having exactly the same output - also an HP w Core i5 but w kernel 2.6.38-8

                      Comment

                      Working...
                      X