Announcement

Collapse
No announcement yet.

The Leading Cause Of The Recent Linux Kernel Power Problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LOL

    Comment


    • Aaaaaaanyway, just to get back onto power usage & whatnot, I'm going to say that frequency scaling issues definitely have affected a htpc system I use (intel atom). Using on-demand vs conservative, the on-demand uses less. This is based on the ever-so-accurate hearing fan spin higher, and putting hand next to the system air outflow. Best guess - on demand jumped things up and got them done quicker, and so overall more time was spent in low frequency mode.
      I'm also a fan of comparing distros - same machine with a fresh ubuntu install ran slower, and raised temperatures considerably higher than a fresh gentoo install. This isn't a matter of "oh no, 2% difference!", it was a case of the main fan spinning louder than the movie or not.
      There, now go argue the reasons for that one.

      Comment


      • Originally posted by deanjo View Post
        (BTW the sun will eventually engulf earth, that is pretty much known fact made by observations of supernova).
        The Sun does not have enough mass to go supernova. It will engulf the Earth (probably) for different reasons. A supernova would not actually "engulf" the earth; it would blow it to smithereens instead.
        Last edited by RealNC; 07-05-2011, 05:59 PM.

        Comment


        • FWIW, for me, workaround is working around.

          Comment


          • It seems that the Arch Linux people found a solution to this problem before Michael:

            https://bbs.archlinux.org/viewtopic.php?id=120640

            Comment


            • It seems that the Arch Linux people found a solution to this problem before Michael:
              They should get some of the advertising revenue

              For me, a BIOS update actually made things worse on my laptop (HP dv6-3210us, RadeonHD42x0). Now, even with the force flag, I get the dreaded:
              Code:
              [    0.142500] Unable to assume _OSC PCIe control. Disabling ASPM
              sigh..

              Comment


              • Do you still get a writable policy file?

                Originally posted by DanL View Post
                Now, even with the force flag, I get the dreaded:
                Code:
                [    0.142500] Unable to assume _OSC PCIe control. Disabling ASPM
                sigh..
                I get the above message about _OSC PCIe control too, but I am still able to set the following:

                Code:
                $ cat /sys/module/pcie_aspm/parameters/policy
                default performance [powersave]
                Doesn't the /sys filesystem have the final say in whether Linux has activated something or not?

                Comment


                • The Windows way according to a comment on heise.de

                  http://www.heise.de/open/news/foren/...20449341/read/

                  Translated:
                  Normally Windows activates ASPM, when Root Complex (Chipset) and Endpoint (PCIe-card) in ConfigSpace indicate that they support the L0s and L1 energy saving mode. Windows Vista/7 is obligatory.

                  There are several switches that control the behaviour including Windows INF and registry keys. The feature is not enabled with an older PCIe-version. Also windows checks, according to the PCIe-Spec recommendations, how much time a mode switch takes and if it can involve a buffer overflow.

                  The ASPM setting in the FADT, initially set by the BIOS, can be overwritten by Windows. See also http://download.microsoft.com/downlo...pa070_wh06.ppt.

                  Comment


                  • The Windows way according to a comment on heise.de

                    Maybe also a good way to implement it on Linux:

                    http://www.heise.de/open/news/foren/...20449341/read/

                    Translated:
                    Normally Windows activates ASPM, when Root Complex (Chipset) and Endpoint (PCIe-card) in ConfigSpace indicate that they support the L0s and L1 energy saving mode. Windows Vista/7 is obligatory.

                    There are several switches that control the behaviour including Windows INF and registry keys. The feature is not enabled with an older PCIe-version. Also windows checks, according to the PCIe-Spec recommendations, how much time a mode switch takes and if it can involve a buffer overflow.

                    The ASPM setting in the FADT, initially set by the BIOS, can be overwritten by Windows. See also http://download.microsoft.com/downlo...pa070_wh06.ppt.

                    Comment


                    • Originally posted by RoyD View Post
                      Maybe also a good way to implement it on Linux:

                      http://www.heise.de/open/news/foren/...20449341/read/

                      Translated:
                      Normally Windows activates ASPM, when Root Complex (Chipset) and Endpoint (PCIe-card) in ConfigSpace indicate that they support the L0s and L1 energy saving mode. Windows Vista/7 is obligatory.

                      There are several switches that control the behaviour including Windows INF and registry keys. The feature is not enabled with an older PCIe-version. Also windows checks, according to the PCIe-Spec recommendations, how much time a mode switch takes and if it can involve a buffer overflow.

                      The ASPM setting in the FADT, initially set by the BIOS, can be overwritten by Windows. See also http://download.microsoft.com/downlo...pa070_wh06.ppt.
                      Maybe if you'd mail that to the Linux Kernel Mailing List, you'd get some desicionmaking eyeballs (programmer eyeballs) to fix the issue

                      Comment

                      Working...
                      X