Announcement

Collapse
No announcement yet.

The Linux Kernel Power Problems On Older Desktop Hardware

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Originally posted by sLinkAge View Post
    Well just installed gentoo on my brand new laptop
    ( i7-2630QM, 8gb of ram, 7200rpm 640 gb, amd 6770m 1gb gddr5 )

    with every power management option I can think of, on idle I get 2.6 wakeups pre second in intervals of 45 seconds.

    kernel is 2.6.39-pf2.

    I really can't see the problem ( at least not on my system ).
    what power management options do you use? can you list them for us?

    I have an nvidia chip and the driver itself causes more wakeups than your entire system (even with the on-demand vblank)

    Comment


    • #52
      Originally posted by ioannis View Post
      what power management options do you use? can you list them for us?

      I have an nvidia chip and the driver itself causes more wakeups than your entire system (even with the on-demand vblank)
      Well,

      first of all, on boot I call acpi_call and turn off the radeon card , on linux the intel 3000 is more than I need.

      also on startup I have this script which I run :

      Code:
      for x in $(ls /sys/class/scsi_host/ )
       do
      	echo min_power > /sys/class/scsi_host/${x}/link_power_management_policy
       done
      echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
      echo 1 > /sys/devices/system/cpu/sched_smt_power_savings
      after that I use a script I found on the net ( this mimics the powertop behavior )

      Code:
      cd /sys/devices
      find pci* -name "control" -exec /etc/local.d/help_script.sh {} \;
      When the help_script.sh is this :
      Code:
      #!/bin/bash
      
      file=$1
      
      if [[ "$file" =~ 'power' ]]
      then
        echo "$file"
        echo "auto" > "$file"
        echo "Done."
      fi
      The thing is, after this script runs, everything works fine except my lan card, so I set it back to on with this command :

      Code:
      echo on > /sys/devices/pci0000\:00/0000\:00\:1c.0/power/control
      If you want I can post my .config file so you can see how I've built the kernel.

      Comment


      • #53
        2.6.38 reg: http://www.phoronix.com/vr.php?view=16181
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #54
          Originally posted by sLinkAge View Post
          Well,

          first of all, on boot I call acpi_call and turn off the radeon card , on linux the intel 3000 is more than I need.

          also on startup I have this script which I run :

          Code:
          for x in $(ls /sys/class/scsi_host/ )
           do
          	echo min_power > /sys/class/scsi_host/${x}/link_power_management_policy
           done
          echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
          echo 1 > /sys/devices/system/cpu/sched_smt_power_savings
          after that I use a script I found on the net ( this mimics the powertop behavior )

          Code:
          cd /sys/devices
          find pci* -name "control" -exec /etc/local.d/help_script.sh {} \;
          When the help_script.sh is this :
          Code:
          #!/bin/bash
          
          file=$1
          
          if [[ "$file" =~ 'power' ]]
          then
            echo "$file"
            echo "auto" > "$file"
            echo "Done."
          fi
          The thing is, after this script runs, everything works fine except my lan card, so I set it back to on with this command :

          Code:
          echo on > /sys/devices/pci0000\:00/0000\:00\:1c.0/power/control
          If you want I can post my .config file so you can see how I've built the kernel.

          Thanks sLinkAge. I'll give those a try

          Comment

          Working...
          X