Announcement

Collapse
No announcement yet.

Ralink Adds RT5390 Support To Open WiFi Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I want to get a usb stick (wireless n) for my desktop so I took note of this thread.

    I think all the wifi drivers for wireless n devices are in a current state of development and I wonder if any are of decent quality in Linux. Maybe Atheros? Note, I am talking about WIRELESS N USB devices. Ralink's recent drivers and chipset for wireless n usb devices are via the Ralink firmware, at least it is for Debian-based distos. Probably the others as well.

    http://linuxwireless.org/en/users/Drivers/rt2800usb

    Looks like WIP to me.

    I was considering a realtek device but it also sounds really sketchy and WIP if not worse than Ralink although there's firmware to be installed as well. They're trying to isolate and use certain drivers and it sounds like it's moving along better as before you had to blacklist certain drivers.

    I wanted a realtek wireless usb adapter (n) because there's a lot of choices, cheap on ebay, including the nano kind which would be pretty useful I thought (if the antenna doesn't suck too bad).

    But, this is getting a bit off topic? I think ralink is okay but it sounds like the quality of the drivers aren't the best. I think there's also more work needed to use these devices in other distros like OpenSUSE and Fedora but maybe users of those distros could comment if they have tried wireless n usb devices?

    I think Atheros sounds like the easiest to use but I researched it and there's not a lot of choices for hardware that have that chipset if you want to use wireless n usb adapters. Also, no nano type choices for that chipset so far.

    It depends what you want - which chipset, what kind of hardware, price, ease of use etc. etc. ???

    Comment


    • #17
      I have experience with RT2500 devices only. One in a Toshiba Laptop I have, and previous to that I remember buying a couple of PCMCIA cards that sported that chipset. The one on my laptop is USB based, and with Fedora (since Fedora 8) it has worked delightfully. Sure enough, there are the signal problems that seem to plague these devices, and the occasional drop-out, which re-establishes itself either by turning off and then back on the device via the front-panel toggle slider or disconnecting from NM and then connecting back again. Other than that I've not had problems with these devices.

      Granted these are older chips and I ignore what have Fedora and Red Hat developers done to the kernel and modules in order to get them to work so well (comparatively speaking). I have two other USB dongles (one from Marvell Semiconductor under the Zonet Brand), the other got it from a friend, but been unable to get it working, since I had not had time to mess with it... Just plugged it and seems to have an RT2810, no modules were loaded, so I think the system simply doesn't recognize the thing. Over the weekend I'll toy with the thing a bit.

      Comment

      Working...
      X