No announcement yet.

Minimalistic Splashtop on eeeBox?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Minimalistic Splashtop on eeeBox?

    Hello all,

    after receiving my eeeBox B202 (received w/ BIOS 0802, flashed to 0901 today) I am trying to rid myself of the large XP partition (it is my understanding that the eeeBox keeps ExpressGAte on the HDD, not in some mystericak SSD on the mainboard?!) whilst keeping the (frankly quite nice!) splashtop thingy.

    Now, I have re-partitioned my HDD into three partitions:
    /dev/sda1 is ntfs @5GB
    /dev/sda2 is ext3 @158GB
    /dev/sda3 is swap @2GB.

    The NTFS partition contains the original ASUS.SYS subdirectory - which, to my understanding, should contain all the necessary files for splashtop.

    But - at startup I get the nasty error message telling me that "EXPRESSGATE IS NOT INSTALLED ON YOUR SYSTEM (...)". Which makes me incredibly sad

    Any ideas from anyone which (apparently other) files are missing on my NTFS-partition?

    Just to let you know, I have made an Acronis TrueImage backup of the original system so I could go back at any time and restore any necessary files.

    Thanks in advance,

  • #2
    The dir itself is not directly searched, but a file called splash.idx, maybe you removed that too. It can be recreated however and you don't need to use ntfs, it should work on fat too.

    ntfs-3g /dev/sda1 /mnt
    cd /mnt

    cat > splash.idx <<EOT
    root=UUID=$(/lib/udev/vol_id -u /dev/sda1)

    That example writes ASUS.000 too, thats not required, but that would be the default dir for user data.
    Last edited by Kano; 11-19-2008, 01:20 PM.


    • #3
      That didn't work....

      Here's my splash.idx as of now:

      root@eeeboxix:~# cat /mnt/ntfs/splash.idx
      root=UUID 4FC021301CC0C4F8

      Any suggestions what I might have done wrong?

      Thanks in advance,


      • #4
        Well I missed the = behind UUID in the first example. Try it again then.


        • #5
          That didn't do it either... and I have double-checked the vol_id -u output. Darn... What else could they check for at startup? I've even included the "version"-file...



          • #6

            Why don't you try the usb installer script? Best join IRC Freenode and look for my nick.