Announcement

Collapse
No announcement yet.

Darksiders 2 Is Coming To Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Darksiders 2 Is Coming To Linux

    Phoronix: Darksiders 2 Is Coming To Linux

    Leszek Godlewski, the developer that presented this week at GDC Europe on advanced Linux game programming, just shared that Darksiders 2 will be coming to Linux...

    http://www.phoronix.com/vr.php?view=MTc2Mjk

  • #2
    The first Darksiders was already ported to Linux, correct? I've yet to see the Linux version on Steam, though. It's still listed as Windows only. Is there an ETA on when the Linux version will be available on Steam? Is it already available as a beta and they don't list it? What's the deal with that?

    Comment


    • #3
      I can't talk specific dates, but it's literally days until Darksiders 1 Linux hits Steam. Please bear with me just a little longer!

      Comment


      • #4
        Originally posted by IneQuation View Post
        I can't talk specific dates, but it's literally days until Darksiders 1 Linux hits Steam. Please bear with me just a little longer!
        Awesome. Thanks!

        Comment


        • #5
          Originally posted by IneQuation View Post
          I can't talk specific dates, but it's literally days until Darksiders 1 Linux hits Steam. Please bear with me just a little longer!
          as anxious as I am for that game... THAT IS WHOLE LOT OF SECONDS!!!!!!!

          Comment


          • #6
            Originally posted by IneQuation View Post
            I can't talk specific dates, but it's literally days until Darksiders 1 Linux hits Steam. Please bear with me just a little longer!
            This is making my wallet nervous!

            Comment


            • #7
              Originally posted by IneQuation View Post
              I can't talk specific dates, but it's literally days until Darksiders 1 Linux hits Steam. Please bear with me just a little longer!
              What about support for Mesa?
              What OGL version will be required?

              Comment


              • #8
                Originally posted by IneQuation View Post
                I can't talk specific dates, but it's literally days until Darksiders 1 Linux hits Steam. Please bear with me just a little longer!
                What I like about the Phoronix forums is that you often get the actual developers to reply Thanks for the update.

                Comment


                • #9
                  Sadly because it's one of the very few sites that provide Linux news.

                  Comment


                  • #10
                    Originally posted by przemoli View Post
                    What about support for Mesa?
                    What OGL version will be required?
                    It's OpenGL 2.1 plus a couple of generic extensions:
                    Code:
                    	CHECK_EXT(ARB_color_buffer_float)
                    	CHECK_EXT(ARB_draw_elements_base_vertex)
                    	CHECK_EXT(ARB_map_buffer_range)
                    	CHECK_EXT(ARB_sampler_objects)
                    	CHECK_EXT(ARB_texture_rg)
                    	CHECK_EXT(EXT_packed_pixels)
                    	CHECK_EXT(EXT_texture_compression_s3tc)
                    	CHECK_EXT(EXT_texture_filter_anisotropic)
                    	CHECK_EXT(EXT_texture_integer)
                    I wanted to make sure it'll run on the same hardware that would run the Windows version, i.e. similar D3D9-class hardware and drivers.

                    Comment

                    Working...
                    X