Announcement

Collapse
No announcement yet.

Counter-Strike: GO Might Soon Be Out On Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by DDF420 View Post
    If you want max_fps to work, turn off sync to Vblank in Nvidia settings and also turn off gl_vsync in game then try setting max_fps

    gl_vsync 1 = capped at monitor refresh rate, gl_vsync 0 = capped at fps_max.

    SEt fps_max at 60 have things improved ?
    I already said that without vsync I get tearing. So disabling it is NOT an option.

    Comment


    • #32
      Originally posted by RealNC View Post
      I already said that without vsync I get tearing. So disabling it is NOT an option.
      Yes i know but vsync is known to cause the mouse lag which was your original issue

      You also said capping fps didn't work when vsync is on, and it wont, thus turning off vsync. If you have a 60Hz monitor cap maxfps at 59/60/61 play around see what's better and although you may get a little tearing with no vsync buffering it wont be as bad as not capping fps with vsync off.
      Im using a 120Hz monitor have vsync off and fps capped at 121 and get no noticeable tearing at all.

      So whats worse mouse lag or a little tearing ?

      I do believe the mouse lag with vsync is worse on linux than windows. lets hope fixes are on the way
      Last edited by DDF420; 04-17-2013, 09:50 AM.

      Comment


      • #33
        Originally posted by DDF420 View Post
        Yes i know but vsync is known to cause the mouse lag which was your original issue

        You also said capping fps didn't work when vsync is on, and it wont, thus turning off vsync.
        It does work in Windows though. Using vsync and capping to 60 removes all mouse lag there. It's weird why this won't work on Linux.

        If you have a 60Hz monitor cap maxfps at 59/60/61 play around see what's better and although you may get a little tearing with no vsync buffering it wont be as bad as not capping fps with vsync off.
        Im using a 120Hz monitor have vsync off and fps capped at 121 and get no noticeable tearing at all.

        So whats worse mouse lag or a little tearing ?
        I can't decide. Both are bad. I don't want either of them :-/ This turns out to be a big show stopper for me. I didn't play CS in Linux for over a month now. It appears that the Linux ports of those games aren't really that great after all.

        Comment


        • #34
          To those getting mouse lag in native Linux Source games - I had crippling mouse lag with multicore rendering enabled, but absolutely none with it disabled. Toggling vsync made no difference.

          Comment


          • #35
            Originally posted by RealNC View Post
            It does work in Windows though. Using vsync and capping to 60 removes all mouse lag there. It's weird why this won't work on Linux.

            I can't decide. Both are bad. I don't want either of them :-/ This turns out to be a big show stopper for me. I didn't play CS in Linux for over a month now. It appears that the Linux ports of those games aren't really that great after all.
            I've done some searching. It looks like this is at least this is a common issue in the source engine, and there is someone at Valve assigned to it at the moment. There's plenty of bugs filed in github regarding this, but the active issues at the moment are:
            https://github.com/ValveSoftware/Sou...Games/issues/9
            https://github.com/ValveSoftware/Sou...mes/issues/112

            The common workaround that people in those bug reports recommend is the fps_max setting, but as mentioned earlier you'll still get a little tearing. You could just wait for Valve to come up with a fix - it's still early days really. Don't give up hope just yet RealNC

            BTW curaga - thanks for the info on the slow xquerypointer.

            Comment


            • #36
              Originally posted by l_bratch View Post
              To those getting mouse lag in native Linux Source games - I had crippling mouse lag with multicore rendering enabled, but absolutely none with it disabled. Toggling vsync made no difference.
              If you're certain you didn't change anything else and re-enabling multicore rendering definitely reproduces the issue, you might want to consider adding a comment and your system info to the issue reports I pasted before. It might help Valve diagnose the issue.

              Comment


              • #37
                I hope they'll finally run out of Counter-Strike titles, so that they can port Portal 1/2.

                Comment


                • #38
                  Originally posted by Matt607 View Post
                  I hope they'll finally run out of Counter-Strike titles, so that they can port Portal 1/2.
                  Same here; I'm really looking foward to playing them both. I got the first as a freebie for being in the beta and have since picked up the second in anticipation of it being ported. Besides them my next most anticipated ports are the HL2 games. After them the only other Source based title I am really excited about is GMod which I've been wanting to try out for a few years now. The L4D titles and DotA2 look to be fun too, though a bit lower on my list than the others.

                  Comment


                  • #39
                    Originally posted by IanS View Post
                    Same here
                    You're replying to a spam bot that copy&pastes text from early posts.

                    Comment

                    Working...
                    X