Announcement

Collapse
No announcement yet.

Counter-Strike: GO Might Soon Be Out On Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by F i L View Post
    What is your mouse (brand, class) and what is your mouse polling rate on Linux? If you have a high-frequency mouse (like a gaming mouse), then you'll want to set the value to mach your mouse's mhz (something usually higher than default). Just look how to set your 'mouse polling rate' on your Linux distro. Let us know if that helps with gaming.

    In CS and CSZ (don't know about CSS), if I use the "Raw Mouse Input" option, then sometimes the controls 'lock up' for a click or so (annoying when you pop around a corner to fire at a guy and your trigger doesn't work), so I don't play with Raw Input. I use a high-freq gaming mouse and everything plays well, but I changed my mouse polling rate before I had Steam, so I don't know how much changing that will effect CS.
    I already use a 500hz rate, as mentioned in an earlier post. And it works (evhz.c confirms it.) My mouse is a Logitech G400.

    I also tried disabling triple buffering in my xorg configuration (Option "TripleBuffer" "False"), as I have that enabled normally, but it doesn't change anything.

    I cannot use non-raw mouse input, as that makes the mouse in the game simply awful (lots of frame skips while looking around and there's some very weird accelaration going on; it's very much unplayable.)

    I also play at the monitor's native resolution, in case someone things that the lag is introduced by the upscaling.

    [s]Setting "fps_max 59" instead of 60 doesn't help either. With values over 60, the mouse lag is more severe though, so it does help somewhat, but not as much as under Windows.[/s] Nope, ignore that. Actually fps_max doesn't do anything.
    Last edited by RealNC; 04-13-2013, 04:36 PM.

    Comment


    • #17
      Originally posted by RealNC View Post
      Raw input is enabled. Without raw input, the game is totally unplayable for me (the mouse feels completely weird.)
      Hello Mr. Gamer!

      Anyway, TIL about fps_max, no need to use V-Sync to limit FPS (what I'm currently doing on TF2)...

      Comment


      • #18
        Originally posted by Calinou View Post
        Hello Mr. Gamer!

        Anyway, TIL about fps_max, no need to use V-Sync to limit FPS (what I'm currently doing on TF2)...
        Without vsync I get heavy tearing, which I can't stand at all.

        Btw, ignore my previous info about fps_max. It turns out that the lag is the same, regardless of whether I use 59, 60, or 200. It has zero effect. I can set it to 40 or even 30 or 20, but the game still runs at 60. So I suppose that under Linux, when vsync is enabled, fps_max does absolutely nothing. At least for me.

        I can't really play CS like that. For now, I'm playing under Windows, which is very sad :-(

        Comment


        • #19
          Originally posted by Sonadow View Post
          Don't care for any western games.

          What i really want are more visual novels for Linux. Which, unfortunately, is not happening at all.
          http://www.lgdb.org/category/subgenr...t_based?page=4

          Comment


          • #20
            @RealNC

            What happens when you use kernel 3.9 rc6+ without any tuning options and nvidia 313/319 with defaults (i mean vsync off)? I don't have got your mouse but a MX518 with dpi setting that works with any os. Basically i had no huge problems with the mouse but i mainly played KF. I don't like TF2 and with HL2DM i die to early I hope L4D2 is available soon...

            Comment


            • #21
              I avoid development kernels. And NVidia's 319 driver is buggy. It spams dmesg to death with error messages. I'm on 313.30.

              But I doubt it's a kernel or driver issue. To me it looks like a Source engine issue (because fps_max seems to be ignored with vsync on.)

              Comment


              • #22
                Originally posted by RealNC View Post
                I avoid development kernels. And NVidia's 319 driver is buggy. It spams dmesg to death with error messages. I'm on 313.30.

                But I doubt it's a kernel or driver issue. To me it looks like a Source engine issue (because fps_max seems to be ignored with vsync on.)
                I'm curious what setup (hardware + distro) you have? I've gathered that you've got an NVIDIA card obviously, but know little else. Do you have input lag in any other games? Have you tried running a non-compositing desktop just to see if it makes a difference?

                I probably can't really help much but it would be useful to know to compare with other people I know running games in Linux. I do know at least one workmate who runs ubuntu w/unity and plays UT2004 in it, and I've heard him complain about tearing without v-sync or no-tearing but too much input lag...

                Just as a side note - I did a little bit of experimenting in UT2004 (which is always my "go to" game to test performance and also input lag in Linux), and I just realised that with V-Sync enabled in the nvidia-settings I also get a _tiny_ bit of input lag. I wasn't sure, until I'd disabled it and re-ran the game. I then noticed it felt so much easier to steady a cursor on a target. I'm lucky though, since with my setup (GTX580M on driver 313.30 in ArchLinux w/Cinnamon) I don't seem to get any noticeable tearing when I disable V-Sync and go full screen. I'll have to test it on my PC at work with a GT240 though and see if it's the same.

                Comment


                • #23
                  It could be the traditional Xorg issue. Do you still have lag when run under its own X server? No WM, no DE, no other X clients.

                  Comment


                  • #24
                    Originally posted by curaga View Post
                    It could be the traditional Xorg issue. Do you still have lag when run under its own X server? No WM, no DE, no other X clients.
                    Traditional Xorg issue? Are you referring to standard X rendering lag? e.g. Daniel Stone's presentation where they measured rtt for rendering elements in X. If so, I didn't think that would that still apply when using direct rendering?

                    Comment


                    • #25
                      No, I refer to X's input lag, where it can ignore the game for some ms, in favor of some other X client. This can't happen if the game is the only X client.

                      This has been known ever since the Q3 days, for my recent-ish meeting with it google "slow xquerypointer".

                      Comment


                      • #26
                        How do I run the game in this mode?

                        Comment


                        • #27
                          Ask your distro

                          Me, being the old-fashioned grumpy luddite, would do something like "startx game -- :1".

                          Comment


                          • #28
                            Originally posted by curaga View Post
                            Ask your distro

                            Me, being the old-fashioned grumpy luddite, would do something like "startx game -- :1".
                            Just tried that. I've shut down current X server first to be sure there's no conflicts. Then:

                            startx /usr/bin/steam

                            Sure enough, Steam came up on an otherwise totally black screen. I started CSCZ and it came up, but it doesn't work. I get a small window at the center of the screen and can't select anything with the mouse.

                            Edit:
                            Anyway, since there's 0 mouse lag with vsync disabled, I doubt it's the issue you're talking about, since if that were true, disabling vsync wouldn't help.
                            Last edited by RealNC; 04-15-2013, 02:24 PM.

                            Comment


                            • #29
                              Originally posted by Kamikaze View Post
                              I'm curious what setup (hardware + distro) you have? I've gathered that you've got an NVIDIA card obviously, but know little else.
                              I'm on Gentoo ~amd64 with KDE 4.10.2. CPU is an i5 2500K, with a GTX 560 Ti GPU and 16GB RAM. Pretty typical mid-range gaming machine.

                              Do you have input lag in any other games?
                              Don't know if World of Goo qualifies, given that it's not an FPS, but no mouse lag in that one when moving the cursor around.

                              Have you tried running a non-compositing desktop just to see if it makes a difference?
                              Doesn't help.

                              Comment


                              • #30
                                Originally posted by RealNC View Post
                                Without vsync I get heavy tearing, which I can't stand at all.

                                Btw, ignore my previous info about fps_max. It turns out that the lag is the same, regardless of whether I use 59, 60, or 200. It has zero effect. I can set it to 40 or even 30 or 20, but the game still runs at 60. So I suppose that under Linux, when vsync is enabled, fps_max does absolutely nothing. At least for me.

                                I can't really play CS like that. For now, I'm playing under Windows, which is very sad :-(
                                If you want max_fps to work, turn off sync to Vblank in Nvidia settings and also turn off gl_vsync in game then try setting max_fps

                                gl_vsync 1 = capped at monitor refresh rate, gl_vsync 0 = capped at fps_max.

                                SEt fps_max at 60 have things improved ?
                                Last edited by DDF420; 04-16-2013, 03:34 AM.

                                Comment

                                Working...
                                X