Announcement

Collapse
No announcement yet.

Ubuntu 12.04 Needs New Drivers For Valve's Source

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 12.04 Needs New Drivers For Valve's Source

    Phoronix: Ubuntu 12.04 Needs New Drivers For Valve's Source

    Experimental graphics driver updates will be needed on Ubuntu 12.04 LTS for properly running Valve's Source Engine games through the forthcoming Linux Steam client...

    http://www.phoronix.com/vr.php?view=MTIyMjE

  • #2
    For those using Intel graphics but not Ubuntu...you'll need Mesa 9.0 to play Valve games.
    Free Software Developer .:. Mesa and Xorg
    Opinions expressed in these forum posts are my own.

    Comment


    • #3
      Will those fglrx-experimental-9 drivers still support the hd 4xxx series?

      edit: they're "12.11 beta".. so I guess not. :/
      Last edited by Kibou; 11-06-2012, 12:10 AM.

      Comment


      • #4
        so...what you are telling me is, that AMD will actually do something to the driver aside from entering a new version number for X.Org/X11? *suspiciously look's at calendar* it's not April 1., isn't it?

        Comment


        • #5
          Since same day it was launched that i have the NVIDIA 310.14....but i'm uncertain if they select non-UBUNTU beta testers

          Comment


          • #6
            Originally posted by Kibou View Post
            Will those fglrx-experimental-9 drivers still support the hd 4xxx series?

            edit: they're "12.11 beta".. so I guess not. :/
            i don't think so unfortunately. But one thing is sure, next time i will buy an Nvidia graphics card. AMD really sucks, not Nvidia as Linus told us(well, honestly Linus told: "Nvidia fuck off!"). Nvidia compared to AMD is good!!!I damned the day i bought a notebook based on AMD and Radeon! Only problems, problems, problems! (HP G62 340US......read: a shitting notebook)
            Last edited by tacco; 11-06-2012, 05:56 AM.

            Comment


            • #7
              Originally posted by tacco View Post
              i don't think so unfortunately. But one thing is sure, next time i will buy an Nvidia graphics card. AMD really sucks, not Nvidia as Linus told us(well, honestly Linus told: "Nvidia fuck off!". Nvidia compared to AMD is good!!!I damned the day i bought a notebook based on AMD and Radeon! Only problems, problems, problems! (HP G62 340US......read: a shitting notebook)
              +1

              I bought an expensive Radeon 7870 GHz edition because of the promisse for good open source drivers. Almost one year later, my card is still not supported from either open source driver or catalyst (!). So fuck you AMD. I am going back to nvidia next time.

              Comment


              • #8
                Originally posted by zoomblab View Post
                +1

                I bought an expensive Radeon 7870 GHz edition because of the promisse for good open source drivers. Almost one year later, my card is still not supported from either open source driver or catalyst (!). So fuck you AMD. I am going back to nvidia next time.

                Funny how that goes. I have the same card (minus the ghz edition, but that's mostly just clockspeeds) And it works like a charm on catalyst.

                Maybe you should stop blaming your own Incompetence on other people.

                I'm sorry if that sounded rude, but I had to say it, since I see stuff like this way to often. If you need some help with your drivers, just ask before assuming it's not working.

                Comment


                • #9
                  Originally posted by zoomblab View Post
                  I bought an expensive Radeon 7870 GHz edition because of the promisse for good open source drivers. Almost one year later, my card is still not supported from either open source driver or catalyst (!).
                  Seriously? There is no Catalyst officially supporting your card?

                  Edit: Just read Ragas' post.

                  Comment


                  • #10
                    I see two options in zoomblab case:
                    1. He is just a troll or NV fanboy and he haven't any Radeon card in PC.
                    2. His knowledge about software is really low, he broken Your OS and now say that this is AMD fault...

                    The bad thing is that probably we will not see updated drivers for HD2k-HD4k...

                    Comment

                    Working...
                    X