Announcement

Collapse
No announcement yet.

Hurrican SDL Port

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by Pickle View Post
    It should be pretty straight forward to build it if the development system and dependencies are installed properly. What build errors are you seeing?
    well i dont remember since it was last week but the last thing was something about "E unable to locate directory" or something like that.
    And compiling is too hard for me anyway.

    Comment


    • #62
      Can anyone help me out then?

      Comment


      • #63
        Originally posted by verik2kk View Post
        Can anyone help me out then?
        I offered, but you blew it off. It is not hard to compile now days. You install the needed packages and type make. Maybe theres an issue with the project itself and by seeing the problem I can improve it.
        I can walk you through the process based on the errors you see and get through it, and you might actually learn something so you become more independent.
        If you dont want to spend some effort on your end, why do you expect others to cater to your every need? You would spend the time to reinstall an OS to run it, but cant copy-paste an error? Maybe this doesnt matter as much you say it does.

        Comment


        • #64
          Originally posted by Pickle View Post
          I offered, but you blew it off. It is not hard to compile now days. You install the needed packages and type make. Maybe theres an issue with the project itself and by seeing the problem I can improve it.
          I can walk you through the process based on the errors you see and get through it, and you might actually learn something so you become more independent.
          If you dont want to spend some effort on your end, why do you expect others to cater to your every need? You would spend the time to reinstall an OS to run it, but cant copy-paste an error? Maybe this doesnt matter as much you say it does.
          ok ill try again and paste everything here.

          Comment


          • #65
            martin@arvuti:~$ cd hurrican-code/Hurrican/src/
            martin@arvuti:~/hurrican-code/Hurrican/src$ make
            g++ -g -Wall -O0 -c -I. -I./SDLPort -Icml -I./unrarlib040/unrarlib -ISDL_port -I/usr/include/SDL/ -I/usr/include/libmodplug -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/GLES2 -I/opt/vc/include/EGL -DPLATFORM_SDL -DENABLE_CONSOLE_COMMANDS -DUSE_MODPLUG -DDEBUG -DRPI -DUSE_GL2 -DUSE_GLES2 -DUSE_EGL_RPI -DRGBA_5551 Boss_BigFish.cpp -o Boss_BigFish.o
            In file included from ./SDLPort/SDL_port.h:40:0,
            from DX8Joystick.h:28,
            from DX8Input.h:22,
            from Console.h:18,
            from stdafx.h:6,
            from Boss_BigFish.cpp:8:
            ./SDLPort/opengl.h:21:17: fatal error: gl2.h: No such file or directory
            compilation terminated.
            make: *** [Boss_BigFish.o] Error 1
            martin@arvuti:~/hurrican-code/Hurrican/src$

            Comment


            • #66
              ok got past of the last error by coping some files into sdlport folder. but now it says this.

              gcc -g -Wall -O0 -c -I. -I./SDLPort -Icml -I./unrarlib040/unrarlib -ISDL_port -I/usr/include/SDL/ -I/usr/include/libmodplug -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/GLES2 -I/opt/vc/include/EGL -DPLATFORM_SDL -DENABLE_CONSOLE_COMMANDS -DUSE_MODPLUG -DDEBUG -DRPI -DUSE_GL2 -DUSE_GLES2 -DUSE_EGL_RPI -DRGBA_5551 SDLPort/eglport.c -o SDLPort/eglport.o
              SDLPort/eglport.c:49:22: fatal error: bcm_host.h: No such file or directory
              compilation terminated.
              make: *** [SDLPort/eglport.o] Error 1

              Comment


              • #67
                got it compiled but there are some graphical glitches and it doesnt run as smooth as windows version

                Comment


                • #68
                  Originally posted by verik2kk View Post
                  got it compiled but there are some graphical glitches and it doesnt run as smooth as windows version
                  Well congrats on getting working on your own, sorry i didnt respond quicker I was occupied this last week every night.

                  Where you intending to run the raspberry pi version? I dont think you were since you mentioned going back to windows.
                  I think the main issue was this line in the makefile:

                  Code:
                  TARGET = rpi
                  It happened to be set to that the last time i committed some code. Set it to linux and the build should go better, at least without any hacks.

                  What gfx hw are you using? What kind of errors?

                  It is possible to try other version of openGL by using the correct defines:

                  USE_GL1 : Use the OpenGL 1.X code (fixed pipline)
                  USE_GLES1 : Use the OpenGL 1.X code with ES compatible (requires USE_GL1)
                  USE_GL2 : Use the OpenGL 2.0 code (programable pipline)
                  USE_GLES2 : Use the OpenGL 2.0 code with ES compatible (requires USE_GL2)

                  Comment


                  • #69
                    Originally posted by Pickle View Post
                    Well congrats on getting working on your own, sorry i didnt respond quicker I was occupied this last week every night.

                    Where you intending to run the raspberry pi version? I dont think you were since you mentioned going back to windows.
                    I think the main issue was this line in the makefile:

                    Code:
                    TARGET = rpi
                    It happened to be set to that the last time i committed some code. Set it to linux and the build should go better, at least without any hacks.

                    What gfx hw are you using? What kind of errors?

                    It is possible to try other version of openGL by using the correct defines:

                    USE_GL1 : Use the OpenGL 1.X code (fixed pipline)
                    USE_GLES1 : Use the OpenGL 1.X code with ES compatible (requires USE_GL1)
                    USE_GL2 : Use the OpenGL 2.0 code (programable pipline)
                    USE_GLES2 : Use the OpenGL 2.0 code with ES compatible (requires USE_GL2)

                    Thanks and its ok.
                    I chnged the line "TARGET = rpi" to "TARGET = linux" it was only way i got it to compile.
                    Nvidia GeForce 8500GT..backround layers were like shaking when moving and lines appeared...idk my english sucks too much ..so im not able to explain..ill take a screenshot in the morning its too late at the moment.and it kinda like skips when moving resulting...not like low framerate but it kinda skips like every second.

                    Comment


                    • #70
                      ok recompiled with some targets found on this thread and everything is perfect...smooth framerate.particle effects...but there are still these transparent lines in textures
                      not something serious i can live with that.

                      Comment


                      • #71
                        Originally posted by verik2kk View Post
                        ok recompiled with some targets found on this thread and everything is perfect...smooth framerate.particle effects...but there are still these transparent lines in textures
                        not something serious i can live with that.
                        Ive heard of lines showing up previously but ive never seen it on my hardware. Is it on all sides or one side of the texture? Which render configuration did you end up with?

                        Comment


                        • #72
                          Originally posted by Pickle View Post
                          Ive heard of lines showing up previously but ive never seen it on my hardware. Is it on all sides or one side of the texture? Which render configuration did you end up with?
                          on first layer..cave floors walls and sealings for example...and these lines are transparent you can see backround layers like trees and stuff thru those...

                          ifeq ($(TARGET),linux)

                          EXE := ../hurricanlinux
                          CCP := gcc
                          CC := gcc
                          LD := g++
                          RM := rm -f

                          USE_EGL := no
                          USE_GL2 := yes

                          DEFINES += -DLINUX -DUSE_GL2

                          INCLUDES_OS := -I/usr/include -I/usr/include/SDL -I/usr/include/GL -I/usr/include/libmodplug

                          LDFLAGS := -g -lSDL -lGL -lSDL_mixer -lSDL_image -lmodplug -lX11

                          endif

                          and this is what i used...

                          Comment


                          • #73
                            He's complaining about visual errors yet doesn't post a screenshot. *cough*

                            Comment


                            • #74
                              Originally posted by curaga View Post
                              He's complaining about visual errors yet doesn't post a screenshot. *cough*
                              I wasnt complaining just saying..and if you read carefully you might find part where i say "i can live with that"
                              And another thing is that i dont how how to take screenshots of fullscreen apps under linux.
                              I have been on linux like month or so and i dont know everything about linux right off the bat.
                              It takes time to learn everything.

                              Comment


                              • #75
                                Hi all
                                *
                                I Compile the game and works very well.

                                Can I change or resize the display screen so that it is in full screen
                                without those black bars left and right?

                                Comment

                                Working...
                                X