Announcement

Collapse
No announcement yet.

Unigine OilRush Officially Ships Today For Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by smitty3268 View Post
    Not to belabor the point, but 49/36 = 36%, which means 13fps => 18fps.

    I know someone else has reported 17-23fps on the open drivers, but i don't recall what hardware they had.
    i already play the game with 20-25fps but only at low resolutions.

    and no 18fps in fact don't fix the problem. i think a hd7950 can handle this.

    Comment


    • #62
      A beta build 1.08 is out that includes the global lobby for games.

      Comment


      • #63
        Just a heads up for those running the Free drivers and thinking about buying the game:

        On my system (Ubuntu 11.10 with Gnome-Shell, using Oibaf's PPA), it currently runs at 30fps 95% of the time, with occasional drops down to ~26fps during heavy action scenes. My card is an HD5770 at 1920x1080, with all settings low except for texture quality (which doesn't seem to have much affect on the fps).


        The strange thing is that it never goes above 30fps. It stays at exactly 30, which points to some limiting factor. Turning vsync on or off makes no difference, so something else is causing it. Any ideas? It's no big deal though since this type of game doesn't really require a higher frame rate..

        Comment


        • #64
          Originally posted by benmoran View Post
          Just a heads up for those running the Free drivers and thinking about buying the game:

          On my system (Ubuntu 11.10 with Gnome-Shell, using Oibaf's PPA), it currently runs at 30fps 95% of the time, with occasional drops down to ~26fps during heavy action scenes. My card is an HD5770 at 1920x1080, with all settings low except for texture quality (which doesn't seem to have much affect on the fps).


          The strange thing is that it never goes above 30fps. It stays at exactly 30, which points to some limiting factor. Turning vsync on or off makes no difference, so something else is causing it. Any ideas? It's no big deal though since this type of game doesn't really require a higher frame rate..
          The Radon driver does v-sync constantly, despite other program's settings, If I get it right. That is all Phoronix benchmarks on this driver are done with swap_buffer_wait=off, or whatever the variable for v-sync is called there. Concluding, if v-sync is constantly on, then the driver looses frames over 30 per second.

          Comment


          • #65
            Is there a demo available for the game yet?

            Comment


            • #66
              Originally posted by benmoran View Post
              Just a heads up for those running the Free drivers and thinking about buying the game:

              On my system (Ubuntu 11.10 with Gnome-Shell, using Oibaf's PPA), it currently runs at 30fps 95% of the time, with occasional drops down to ~26fps during heavy action scenes. My card is an HD5770 at 1920x1080, with all settings low except for texture quality (which doesn't seem to have much affect on the fps).


              The strange thing is that it never goes above 30fps. It stays at exactly 30, which points to some limiting factor. Turning vsync on or off makes no difference, so something else is causing it. Any ideas? It's no big deal though since this type of game doesn't really require a higher frame rate..
              You can add Option "SwapbuffersWait" "off" in your xorg.conf to completely disable any form of vsync. From the radeon man page:
              Option "SwapbuffersWait" "boolean"
              This option controls the behavior of glXSwapBuffers and glXCopySubBufferMESA calls by GL applications. If enabled, the calls will avoid tearing by making sure the display scanline is outside of the area to be copied before the copy occurs. If disabled, no scanline synchronization is performed, meaning tearing will likely occur. Note that when enabled, this option can adversely affect the framerate of applications that render frames at less than refresh rate.
              The default value is on.

              Comment

              Working...
              X