Announcement

Collapse
No announcement yet.

Here's The First Screenshot Of The Linux Steam Client

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by aliendude5300 View Post
    Yay! I got it working on another machine... on my main machine, it wouldn't start because I was using a Radeon X1950 GT 256MB card, and the radeon R300 open-source driver. When I tried it on another machine, also running Ubuntu 10.04 LTS, except in 32-bit instead of 64-bit like on my other machine. Anyways, here are some screenshots of it working:

    *snip*

    I assure you, these aren't fake...
    Sigh... I really hate the time limit to edit your posts here, sorry for the extremely large images. Here's what it should look like:



    If an admin here could edit my first post, replacing the old image code, it would be appreciated. Sorry about that! I tried to fix it...

    Comment


    • #12
      Originally posted by aliendude5300 View Post
      Yay! I got it working on another machine... on my main machine, it wouldn't start because I was using a Radeon X1950 GT 256MB card, and the radeon R300 open-source driver. When I tried it on another machine, also running Ubuntu 10.04 LTS, except in 32-bit instead of 64-bit like on my other machine. Anyways, here are some screenshots of it working:




      I assure you, these aren't fake...
      This is what I got, too. Too bad it's not as impressive as that fake. :P

      Comment


      • #13
        Here's another one with the "-install x" argument:


        Note that it has the stripes, but no Steam logo or Valve logo.

        Comment


        • #14
          Is it requiring a specific video driver? I'm on the open source intel driver right now and it still shuts down, granted much later on in the process... any more troubleshooting i can do?

          Comment


          • #15
            ...and this is steam (splash screen?) in kubuntu lucid 64bit:

            Comment


            • #16
              Originally posted by Sir_Brizz View Post
              Is it requiring a specific video driver? I'm on the open source intel driver right now and it still shuts down, granted much later on in the process... any more troubleshooting i can do?
              Did you install bsdiff?

              Comment


              • #17
                ...and this is steam (splash screen?) on my kubuntu lucid 64bit:

                Comment


                • #18
                  Originally posted by Remco View Post
                  Did you install bsdiff?
                  Yes, although, from further dissecting it, it seems like it has a problem with my 64-bit OS. It says something about 32 bit mode in the strace...

                  Still, it shuts down after it tries to connect to some servers instead of before, which is further than it was getting. Is there something better than strace to figure out what is going on?

                  Comment


                  • #19
                    It currently only shows the splash when you use nvidia or ati binary drivers - be sure that 32 bit libs are installed for those.

                    Comment


                    • #20
                      So when can we get Valve to officially announce this? I'm just as excited as everyone else but theres really no good in just getting the splash screen. I'm hoping phoronix is probing people at valve for an official answer.

                      I'm also hoping this is out before HL2E3 and Portal 2 are out, I don't want to play it in wine.

                      Comment

                      Working...
                      X