Announcement

Collapse
No announcement yet.

There Is No Doubt, Steam Is Coming To Linux!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by ace102 View Post
    The xserver is making a login box for steam but there must be some missing function calls to dependencies to create the actual login dialog. It has nothing to do with compiz.

    Can't wait for PacSteamLinux.
    Makes sense, I didn't look into it too much as my curiosity ended with it runs but it doesn't work. Deleted it and moving on, I too cannot wait until official release. I own most of the half-life 2 series and portal, playing them natively would be great but they still work almost flawlessly under wine for now.

    Comment


    • #92
      Originally posted by GNU/Blind View Post
      they still work almost flawlessly under wine for now.
      I've always had this thought that some enterprising sod has already created a Steam (for Linux) interface through his own handywork but has yet to unveil it.

      Now if BlackSourceMesa would only get it done already.

      Comment


      • #93
        Originally posted by ace102 View Post
        Can't wait for PacSteamLinux.
        Unrelated sore spot with me. Pacman didn't do anything but make a fancy package. Try cs.rin.ru if you want to find the real steam scene.

        Comment


        • #94
          has anybody managed to get any further running the client now? I tried copying over some of my wine config files for windows steam, but still no success.

          Comment


          • #95
            Originally posted by IsSuE View Post
            has anybody managed to get any further running the client now? I tried copying over some of my wine config files for windows steam, but still no success.
            I realised the steam_client_linux URL was available again earlier today and actually managed to get the client to update through some trickery. I now have a bunch of TGA images of UI components and other random files sitting under my steam directory on my linux partition. No matter what I try now though, it seems to stall on 'Update complete, launching...'

            Anyone have any ideas?

            Comment


            • #96
              Originally posted by Kamikaze View Post
              I realised the steam_client_linux URL was available again earlier today and actually managed to get the client to update through some trickery. I now have a bunch of TGA images of UI components and other random files sitting under my steam directory on my linux partition. No matter what I try now though, it seems to stall on 'Update complete, launching...'

              Anyone have any ideas?
              How did you get that far? Did you find the steam.cfg file? I'm still stuck on:
              Code:
              !!! Fatal Error: Failed to determine download location for universe 0

              Comment


              • #97
                Originally posted by Compholio View Post
                How did you get that far? Did you find the steam.cfg file? I'm still stuck on:
                Code:
                !!! Fatal Error: Failed to determine download location for universe 0
                Create steam.cfg with:

                In the same folder as steam.sh and then it will update but then crash (for right now, working on a workaround) when trying to load the UI library.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #98
                  Hi,
                  I have uploaded a new version of my Steam install script. It's much simpler now, as it lets the steam binary do all the work.

                  http://pastie.org/939641

                  Comment


                  • #99
                    Originally posted by Michael View Post
                    Create steam.cfg with:



                    In the same folder as steam.sh and then it will update but then crash (for right now, working on a workaround) when trying to load the UI library.
                    That sounds like a much easier solution than mine, which was editing the steam binary with a hex editor and changing store.internal.steampowered.com to store.steampowered.com + a NULL terminator, and then following a post I found on reddit by delroth (see link) to force it to jump to a certain point in the app - presumably past some of it's checks.

                    I'm going to try the steam.cfg solution now.

                    Comment


                    • I've come as far as this:
                      Code:
                      LD_PRELOAD="linux32/steamui.so" ./steam.sh
                      CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
                      CAsyncIOManager: 0 single object sleeps, 0 multi object sleeps
                      CAsyncIOManager: 0 single object alertable sleeps, 0 multi object alertable sleeps
                      [  0%] Checking for available update...
                      Need new HTTP connection for 63.228.223.104:80
                      Sending request for http://store.steampowered.com/public/client/steam_client_linux?date=706980
                      HTTP client connect completed
                      Success! http://store.steampowered.com/public/client/steam_client_linux?date=706980
                      Removing now closed connection for 63.228.223.104:80
                      Removing in-use connection for 63.228.223.104:80, 0 left open, 0 requests waiting, 0 requests still in-flight
                      [  0%] Update Complete.
                      [----] Verifying installation...
                      unlinked 0 orphaned pipes
                      CellID: Fetching server list from CSDS. . .
                      Shutting down. . .
                      CellID: CSDS returned 166 servers.
                      CellID: Connecting to 208.111.140.4:27031. . .
                      CellID: Connect to 208.111.140.4:27031 took 276 MS
                      CellID: New Best!
                      CellID: Connecting to 203.66.135.26:27031. . .
                      CellID: exiting!
                      unlinked 2 orphaned pipes
                      CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
                      CAsyncIOManager: 786 single object sleeps, 0 multi object sleeps
                      CAsyncIOManager: 0 single object alertable sleeps, 1 multi object alertable sleeps
                      CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
                      CAsyncIOManager: 0 single object sleeps, 0 multi object sleeps
                      CAsyncIOManager: 0 single object alertable sleeps, 0 multi object alertable sleeps
                      And then steam terminates because it's probably missing Info.plist file:
                      Code:
                      stat64("Info.plist", 0xbfa2a838)        = -1 ENOENT (No such file or directory)
                      read(255, "exit $STATUS\n", 1805)       = 13

                      Comment

                      Working...
                      X