Announcement

Collapse
No announcement yet.

Caster has gone Gold!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    After looking at your problem description that reminded me of an error that lead to 100% cpu usage with a dbase app compiled with xHarbour. Basically they used busy waiting without any sleeps, that caused the extreme cpu usage. It was not that extreme with older kernels but new ones showed it. I usually do not fix compiler bugs, but it was relatively easy to locate this one. I do not write dbase apps, just somebody showed me that problem and i found a hack around it.

    Comment


    • #62
      @Svartalf

      So found the demo 1.1 update. Seems to run really smooth now. Can you tell us how to enable a framecounter?

      Btw. it does not seem that there is a ingame editor in the demo, did you enable it for the full version?

      https://docs.google.com/Doc?docid=dd...gxfnrxgb&hl=en

      Comment


      • #63
        Originally posted by Kano View Post
        @Svartalf

        So found the demo 1.1 update. Seems to run really smooth now. Can you tell us how to enable a framecounter?
        Currently only in the developer version of the binary. I'll forward a request to Mike on that one.

        Btw. it does not seem that there is a ingame editor in the demo, did you enable it for the full version?

        https://docs.google.com/Doc?docid=dd...gxfnrxgb&hl=en
        The Google doc mentions the in-game, but unfortunately Mike's only enabled it in the developer edition. That may change over time, but for now...

        Comment


        • #64
          Is the Windows binary the developer version? Would be stupid when somebody already bought the Linux one...

          Comment


          • #65
            Originally posted by Kano View Post
            Is the Windows binary the developer version? Would be stupid when somebody already bought the Linux one...
            No... It's one built for debug right at the moment...

            Comment


            • #66
              From the Win demo:

              strings caster.exe |grep FPS
              >"Caster". FPS: %.2f FPS (perf): %.2f Swap Time: %.2f

              So it is build for debug then? How to enable it there?

              Comment


              • #67
                Originally posted by Kano View Post
                >"Caster". FPS: %.2f FPS (perf): %.2f Swap Time: %.2f

                So it is build for debug then? How to enable it there?
                I was referring to the editor. I'm not wholly sure how to turn on perf counting from the Windows or Linux side (Didn't need to- used BuGLe to get framecounts, etc. as I was verifying GL code, etc...); I'll check into it when I get home and get back with you on that one.

                Comment


                • #68
                  I just picked this up. Do i still need to update the game using the demo, or is the full game binary up to date by now?

                  Comment


                  • #69
                    Originally posted by Raven3x7 View Post
                    I just picked this up. Do i still need to update the game using the demo, or is the full game binary up to date by now?
                    If you just bought, it should be the version with the performance problem fixes in it. If you encounter slowdowns, you might need to download the update. If so, I can point you in the right direction shortly. Just let me know.

                    Comment


                    • #70
                      Any update for the FPS code?

                      Comment

                      Working...
                      X