Announcement

Collapse
No announcement yet.

FFmpeg 1.1 Brings New Support, Encoders/Decoders

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Nille View Post
    That is to burn in the subtitle. i want only to insert it in the mkv container. so everyone one can choose to use the subtitle or not. if you burn in the sub he is encoded in the videostream and cant be disabled, removed or changed. BUt thanks that you looked for it.
    Ahh, ok. Out of curiosity I tried your command and it worked fine. I could choose subtitle track from vlc. What does command ffmpeg -codecs | grep "^...S" say?

    Comment


    • #12
      Originally posted by tuke81 View Post
      Ahh, ok. Out of curiosity I tried your command and it worked fine. I could choose subtitle track from vlc. What does command ffmpeg -codecs | grep "^...S" say?
      ffmpeg is build with libass and ass is available as codec and filter

      Comment


      • #13
        Originally posted by Nille View Post
        ffmpeg is build with libass and ass is available as codec and filter
        So it has marked DES on it. Hmm can you convert it to srt: ffmpeg -i subtitle.ass subtitle.srt or does it give same error?

        Comment


        • #14
          Originally posted by tuke81 View Post
          So it has marked DES on it. Hmm can you convert it to srt: ffmpeg -i subtitle.ass subtitle.srt or does it give same error?
          srt doesn't support all the required features like animations. its currently not an big problem because i can use mkvtoolnix but it would be cool if i can do everything in one step.

          Comment


          • #15
            Originally posted by Nille View Post
            srt doesn't support all the required features like animations. its currently not an big problem because i can use mkvtoolnix but it would be cool if i can do everything in one step.
            Well yeah I could have been more precise. I did not suggest you to use .srt just try the ffmpeg command if it recognize at all your subtitle file.

            Comment


            • #16
              Originally posted by tuke81 View Post
              Well yeah I could have been more precise. I did not suggest you to use .srt just try the ffmpeg command if it recognize at all your subtitle file.
              No its not Working

              Code:
              subtitle.ass: Invalid data found when processing input
              But the ass filter is happy with this files and aegisub too.

              Comment


              • #17
                Hmm odd. Does any other .ass subtitle work? I.e. this(I can't find a good example file with google):
                http://code.ohloh.net/file?fid=m75vO...ser=Default#L0

                When I convert it to .srt with my comp(well it's .ssa but it's the same with any .ass file):
                Code:
                $ ffmpeg -i subtitle.ssa subtitle.srt
                ffmpeg version 1.1-1.1-0ubuntu0~precise1 Copyright (c) 2000-2013 the FFmpeg developers
                  built on Jan  8 2013 18:46:24 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
                  configuration: --enable-libass --arch=amd64 --enable-pthreads --enable-runtime-cpudetect --extra-version='1.1-0ubuntu0~precise1' --libdir=/usr/lib/x86_64-linux-gnu --disable-stripping --prefix=/usr --enable-bzlib --enable-libdc1394 --enable-libfreetype --enable-frei0r --enable-gnutls --enable-libgsm --enable-libmp3lame --enable-librtmp --enable-libopencv --enable-libopenjpeg --enable-libpulse --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-vaapi --enable-vdpau --enable-libvorbis --enable-libvpx --enable-zlib --enable-gpl --enable-postproc --enable-libcdio --enable-x11grab --enable-libx264 --shlibdir=/usr/lib/x86_64-linux-gnu --enable-shared --disable-static --enable-libxvid
                  libavutil      52. 13.100 / 52. 13.100
                  libavcodec     54. 86.100 / 54. 86.100
                  libavformat    54. 59.106 / 54. 59.106
                  libavdevice    54.  3.102 / 54.  3.102
                  libavfilter     3. 32.100 /  3. 32.100
                  libswscale      2.  1.103 /  2.  1.103
                  libswresample   0. 17.102 /  0. 17.102
                  libpostproc    52.  2.100 / 52.  2.100
                [ass @ 0x793560] Estimating duration from bitrate, this may be inaccurate
                Input #0, ass, from 'subtitle.ssa':
                  Duration: N/A, bitrate: N/A
                    Stream #0:0: Subtitle: ssa
                Output #0, srt, to 'subtitle.srt':
                  Metadata:
                    encoder         : Lavf54.59.106
                    Stream #0:0: Subtitle: subrip
                Stream mapping:
                  Stream #0:0 -> #0:0 (ass -> subrip)
                Press [q] to stop, [?] for help
                size=       0kB time=00:00:01.18 bitrate=   0.8kbits/s    
                video:0kB audio:0kB subtitle:0 global headers:0kB muxing overhead 43.037975%

                Comment


                • #18
                  Mh ok now i found the issue.

                  Aegisub don't write to the first line
                  Code:
                  [Script Info]
                  If i Add this to my sub it work. Without this ffmpeg cant detect it. curious is that the filters work without an problem and don't write any message about this in the log.

                  Thx tuke81


                  EDIT: The new Aegisub Versions.
                  Last edited by Nille; 01-08-2013, 03:06 PM.

                  Comment


                  • #19
                    I find it quite odd too, line [Script Info] should be there by the ssa specs. I'm not familiar with Aegisub, but if filter does not even throw warnings about missing line that spec requires it is bad filter.

                    Comment


                    • #20
                      Originally posted by tuke81 View Post
                      I find it quite odd too, line [Script Info] should be there by the ssa specs. I'm not familiar with Aegisub, but if filter does not even throw warnings about missing line that spec requires it is bad filter.
                      xvfilters and libass say nothing agains this. and i dont know if there is an other library for ass.

                      Comment

                      Working...
                      X