Announcement

Collapse
No announcement yet.

Mobile Users Beware: Linux Has Major Power Regression

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by deanjo View Post
    A "mess" that works > "neat but non-functional". That my friend is what "the real world" is.
    Deanjo stop with this os x bullshit. It loses with Linux badly in many areas, so praising it's doubtful advantages won't help.

    Comment


    • #32
      I think it could be related to that bug:

      https://bugzilla.kernel.org/show_bug.cgi?id=29842

      Comment


      • #33
        similar bug

        https://bugzilla.kernel.org/show_bug.cgi?id=29842

        It could be related to this regression.

        Comment


        • #34
          Originally posted by crumja View Post
          Historically, power consumption has always been a problem with the linux kernel. Developers either aren't in tune with user demands (probably because they sit at desktops all day long or buy extra extended batteries to use with their Thinkpads, which are the only notebook any one of them would even consider) or just don't think of it as high priority (again, reflecting the enterprise slant of development efforts).
          Note that power consumption IS very important to enterprises. Data centers are generally limited by power consumption, not space or money to buy equipment. A 10% decrease in power consumption leads to 10% more CPUs under the same building, which leads to profit.

          Comment


          • #35
            dedicate a couple release cycles to power management

            I seriously believe that Linus should consider dedicating a couple of kernel release cycles to power management alone. Almost entirely accept only patches that tackle directly or indirectly power consumption issues, on all fronts. Make it also fun, with a 'Love mother Earth' or such tag line/theme. And what a better time to do so that this year, celebrating 20 years of Linux!

            It is equally important for distributions to focus on power as well. I think Fedora is now making an active move in that directions with power-test liveCDs and such.

            Comment


            • #36
              Originally posted by kraftman View Post
              Deanjo stop with this os x bullshit. It loses with Linux badly in many areas, so praising it's doubtful advantages won't help.
              Kraftman it isn't BS. It is just plain fact. OS X beats linux in many areas as well and in the case of power management it has had an implementation that has worked properly going back to the original Mac. It took years for even microsoft to come up with decent power management. With Win 7 they have finally worked on it enough that it is finally usable. It is no secret that linux has shitty power management and has been a sore point for a long time. It's to bad that you get so offended by reality.

              Comment


              • #37
                Originally posted by igor1st View Post
                https://bugzilla.kernel.org/show_bug.cgi?id=29842

                It could be related to this regression.
                Mhm not for me. I'm running the nvidia blob, and frequency scaling and temperatures of the GPU seem the same as before. Btw, as Micheal suspects it's on an intel system (Calpella).

                Comment


                • #38
                  Originally posted by not.sure View Post
                  Mhm not for me. I'm running the nvidia blob, and frequency scaling and temperatures of the GPU seem the same as before. Btw, as Micheal suspects it's on an intel system (Calpella).
                  Right, it's not related to that... I think I have it narrowed down to one of two items. Hope to know for sure shortly.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #39
                    Originally posted by kraftman View Post
                    Btw. it doesn't seem Android has some power management problems, so I wonder if os x does pm better.
                    Umm ya ok, thats why many Android devices out there have "wake up" issues.

                    Comment


                    • #40
                      Maybe this is really a real problem...

                      Whoa!
                      After doing a very basic test in my working laptop with powertop, I found I'm having significantly more wakeups-from-idle per second with 2.6.38 (about 230) than with 2.6.35 (about 170). This means my CPU is waking up from idle more 26% than before! It's a significant difference...

                      I did my test only with my computer booted in OpenBox (without any programs loaded).

                      Btw, my laptop doesn't seem hotter with 2.6.38 than with 2.6.35, but more wakeups-from-idle per second means my CPU is spending more power...

                      Cheers

                      p.s.: I hope the kernel devs fix this problem in 2.6.39...

                      Comment


                      • #41
                        Originally posted by evolution View Post
                        Whoa!
                        After doing a very basic test in my working laptop with powertop, I found I'm having significantly more wakeups-from-idle per second with 2.6.38 (about 230) than with 2.6.35 (about 170). This means my CPU is waking up from idle more 26% than before! It's a significant difference...

                        I did my test only with my computer booted in OpenBox (without any programs loaded).

                        Btw, my laptop doesn't seem hotter with 2.6.38 than with 2.6.35, but more wakeups-from-idle per second means my CPU is spending more power...

                        Cheers

                        p.s.: I hope the kernel devs fix this problem in 2.6.39...
                        Please post hardware specs...

                        And if it's what I think it is, it won't be fixed until the 2.6.40 merge window as the soonest as this is a very invasive, core issue.
                        Michael Larabel
                        http://www.michaellarabel.com/

                        Comment


                        • #42
                          NMI

                          echo 0 > /proc/sys/kernel/nmi_watchdog

                          Or install the latest Jupiter (0.0.50) and it will set it for you when you unplug (and change it back when you apply power). As posted on UF, two systems on battery with WELL UNDER 200 wakeups per second.

                          Lenovo T400
                          Fuduntu 14.9 (64bit)
                          Kernel 2.6.38.4
                          Completely idle on battery for ~15 minutes.



                          Asus Eee PC 1015PEM
                          Fuduntu 14.9 (32bit)
                          Kernel 2.6.38.4
                          Completely idle on battery (as before)



                          I don't know that I would call this a kernel regression, as the kernel doesn't dynamically change parameters based on applied power state. That's what you need something like Jupiter for..

                          Comment


                          • #43
                            Originally posted by Michael View Post
                            Please post hardware specs...
                            Oh, I forgot it!

                            Hw Specs:

                            Processor: Core2Duo T7300@2.00GHz
                            Mem: 2GB DDR2 PC6400
                            HD: 200GB 4200RPM sata
                            Laptop: Toshiba A200 PSAE-6
                            Graphics Card: ATI Radeon HD2600

                            Sw Specs:

                            Kernel 1: 2.6.38.4-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default
                            Kernel 2: 2.6.28.5-lts-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default
                            Others: Catalyst 10.7, Xorg Server 1.8.2, OpenBox with Cairo-Compmgr, Dual Boot Arch Linux x86_64 + Windows 7

                            And if it's what I think it is, it won't be fixed until the 2.6.40 merge window as the soonest as this is a very invasive, core issue.
                            Fortunately, ATM I don't need to care very much about this problem, as I'm using my laptop most of the time in AC mode.

                            Furthermore, adding to my last post, it seems both 2.6.35 and 2.6.38 kernel versions make my computer work a bit less hotter than on Windows 7 SP1 (Office/Internet).

                            Cheers

                            Comment


                            • #44
                              interesting.

                              does this hold true for desktop (non-mobile) systems as well?

                              I want to test it out on my narwhal setup as well (Sandy Bridge setup).

                              Also, how do you regress back to the older linux kernel? Do you use apt-get or select it from the grub menu?

                              And here I thought it was an issue with the B3 Sandy Bridge.

                              Comment


                              • #45
                                Originally posted by MoFoQ View Post
                                interesting.

                                does this hold true for desktop (non-mobile) systems as well?

                                I want to test it out on my narwhal setup as well (Sandy Bridge setup).

                                Also, how do you regress back to the older linux kernel? Do you use apt-get or select it from the grub menu?

                                And here I thought it was an issue with the B3 Sandy Bridge.
                                I've heard of desktop users reporting 1. increased power consumption and 2. increased wake-ups per second. Based upon what I think the problem is at this point, it will affect any type of system -- desktops included.

                                Just change it from GRUB2. If you don't see the option screen, add a timeout to your boot confoguration.
                                Michael Larabel
                                http://www.michaellarabel.com/

                                Comment

                                Working...
                                X