Announcement

Collapse
No announcement yet.

Linux 2.6.34-rc1 Kernel Is Out w/ New Features

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux 2.6.34-rc1 Kernel Is Out w/ New Features

    Phoronix: Linux 2.6.34-rc1 Kernel Is Out w/ New Features

    Following a two week merge window following the release of the Linux 2.6.33 kernel, Linus Torvalds has announced the first release candidate for the next kernel, to be known as the Linux 2.6.34 kernel.Of a lot of interest to us (and likely you too) are all of the GPU DRM updates in the Linux 2.6.34 kernel that includes GPU hybrid switching, initial ATI Radeon HD 5000 series KMS support (a.k.a. "Evergreen"), controversial Nouveau changes, ATI Radeon KMS power management support, Intel Sandy Bridge support, and much more.Outside of the graphics fun in this kernel to be officially released next quarter is a new filesystem (Logfs), a hardware driver for Apple's Magic Mouse, virtualization improvements, and other updates particularly to the Linux drivers and architectures.The Linux 2.6.34-rc1 kernel release announcement can be read at LKML.org...

    http://www.phoronix.com/vr.php?view=ODA0OQ

  • #2
    How well is the ATI powermanagement in this kernel?
    Any major bugs in the powermanagement still needs to be fixed?

    Comment


    • #3
      Maybe after the 2.6.34 is done you could include some Logfs tests.

      Comment


      • #4
        Originally posted by tball View Post
        How well is the ATI powermanagement in this kernel?
        Any major bugs in the powermanagement still needs to be fixed?
        I'm stoked - suspend and hibernate are finally both working for me on an rv635!

        Comment


        • #5
          PowerSavings

          Im still geting
          Code:
          (WW) RADEON(0): Option "ForceLowPowerMode" is not used
          (WW) RADEON(0): Option "DynamicPM" is not used
          with this xorg.conf
          Code:
          Section "Device"
          Identifier "Configured Video Device"
          Option "UseFBDev" "true"
          Option "ForceLowPowerMode" "true"
          Option "DynamicPM" "true"
          EndSection
          
          Section "Monitor"
          Identifier "Configured Monitor"
          EndSection
          
          Section "Screen"
          Identifier "Default Screen"
          Monitor "Configured Monitor"
          Device "Configured Video Device"
          EndSection
          on lucid with 2.6.34 rc1. Should I add xorg edgers ppa to? or should I somehow change my xorg.conf?

          Comment


          • #6
            ok I have found
            Code:
            [    8.916802] [drm] Clocks initialized !
            [    8.916806] [drm] 4 Power State(s)
            [    8.916808] [drm] State 0 Default (default)
            [    8.916810] [drm] 	1 Clock Mode(s)
            [    8.916812] [drm] 		0 engine: 
            [    8.916814] [drm] State 1 Performance 
            [    8.916816] [drm] 	1 Clock Mode(s)
            [    8.916818] [drm] 		0 engine: 500000
            [    8.916820] [drm] State 2 Battery 
            [    8.916821] [drm] 	1 Clock Mode(s)
            [    8.916823] [drm] 		0 engine: 200000
            [    8.916825] [drm] State 3 Default 
            [    8.916827] [drm] 	1 Clock Mode(s)
            [    8.916829] [drm] 		0 engine: 500000
            [    8.916836] [drm] radeon: power management initialized
            in dmesg but Im not sure whether this is actually doing something

            Comment


            • #7
              todays last post :-)
              I put radeon.dynpm=1 in /etc/modprobe.d/radeon.conf
              but cat /sys/kernel/debug/dri/0/radeon_pm_info prints
              Code:
              state: PM_STATE_DISABLED
              default engine clock: 500000 kHz
              current engine clock: 494040 kHz
              default memory clock: 333000 kHz
              PCIE lanes: 0
              so i guess pm is not working for me...

              Comment


              • #8
                Originally posted by icek View Post
                ok I have found
                Code:
                [    8.916802] [drm] Clocks initialized !
                [    8.916806] [drm] 4 Power State(s)
                [    8.916808] [drm] State 0 Default (default)
                [    8.916810] [drm] 	1 Clock Mode(s)
                [    8.916812] [drm] 		0 engine: 
                [    8.916814] [drm] State 1 Performance 
                [    8.916816] [drm] 	1 Clock Mode(s)
                [    8.916818] [drm] 		0 engine: 500000
                [    8.916820] [drm] State 2 Battery 
                [    8.916821] [drm] 	1 Clock Mode(s)
                [    8.916823] [drm] 		0 engine: 200000
                [    8.916825] [drm] State 3 Default 
                [    8.916827] [drm] 	1 Clock Mode(s)
                [    8.916829] [drm] 		0 engine: 500000
                [    8.916836] [drm] radeon: power management initialized
                in dmesg but Im not sure whether this is actually doing something
                I'll explain ya.

                The options you wrote about in the previous post are picked up by the Xorg DDX driver, making it manage some aspects of the GPU power management, in userspace.

                The New(r) Improved(tm) All-Round Better(?) way is DRM power management. This permits a centralized management of the GPU and video memory current, voltages, and what else lies inbetween, whereas the temporary userspace solution would have had to synchronize its Power Management decisions with the other DRM/GPU clients, if it ever did it at all. This Better(stop it!) solution has the advantage to provide Power Management during the whole Linux(tm, not a joke)-Experience(this is), and permits a closer control of the video GPU/memory status.

                So, it is way better.

                What you need? Enable KMS, as that's a completely new DRM module, in which the developers are implementing all the good things you're reading here on Phoronix.

                Next? Edit your Linux kernel command line to include this options:

                radeon.modeset=1 radeon.dynpm=1

                Then, pray whathever ancient god of luck and good and fortune you could know of. Then, and only then, boot into your operating system.

                And say thank you to the devs.
                They actually are those gods I was talking about.

                Comment


                • #9
                  With my HD4850, I can see the 4 powerstates being listed. Each one has (or should) 3 modes. This I learned before from messing around with Radeon Bios Editor. In the kernel log, state 0 and 3 each have three modes, and modes 1 and 2 show only two. Looking at the listed frequencies, it seems that the actual "3D" frequencies are missing. I see the low "2D" clocks in there, but not the high power ones. Is this a current limitation, or a problem with my particular setup?
                  Also, this rc causes a weird kernel panic on my laptop (Presario V2000) and I'm unable to go past the grub2 menu.

                  Comment


                  • #10
                    As far as PM, it does seem to work. The core is downclocking fine as far as I can tell, which is making things slower than usual; KMS makes 2D slow as is, so the downclocking is making things worse .

                    Comment


                    • #11
                      Originally posted by Melcar View Post
                      As far as PM, it does seem to work. The core is downclocking fine as far as I can tell, which is making things slower than usual; KMS makes 2D slow as is, so the downclocking is making things worse .
                      Mobility 3470 here. The first DRM power management patches did just that, slowing 2D to unacceptable levels. Since 2.6.33 + patches, it's become very good, with no noticeable slowness at all. Now, it seems to change core and memory frequencies very fast.

                      And my notebook stopped hanging with a black screen due to overheating, as well.

                      Now, I'm just hoping the current power management, or the future advancements, will be enough to cope with the summer's heat.

                      Thank you developers.

                      Comment


                      • #12
                        On my laptop (200M) it works a bit better, in that it's not unbearably slow. Thing is that when the core downclocks, response becomes "jumpy"; the mouse cursor seems to get "stuck" as I move it across the screen, and window animations sometimes leave a noticeable trace behind them. This again, is due to KMS making things slow and the slower frequencies only worsening the problem. Should be better once I move to a newer xserver.

                        Comment


                        • #13
                          Melcar: how did you enable PM ? I tried everything but I'm still on default clocks...

                          I have integrated 3200 HD, may this be the problem? Is PM supposed to work with integrated cards?

                          Comment


                          • #14
                            From the grub2 menu, I just added:

                            Code:
                            radeon.dynpm=1
                            ... to the kernel parameter line. It works on both my HD4850 and my laptop's integrated 200M.

                            Comment


                            • #15
                              hm, with this I have
                              Code:
                              state: PM_STATE_ACTIVE
                              , but engine clock is always on default value...

                              Comment

                              Working...
                              X