Announcement

Collapse
No announcement yet.

openSUSE 13.1 M4 Brings Ruby-Based YaST

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • openSUSE 13.1 M4 Brings Ruby-Based YaST

    Phoronix: openSUSE 13.1 M4 Brings Ruby-Based YaST

    The fourth and final development milestone of openSUSE 13.1 is now available. This development release ahead of the official openSUSE 13.1 debut in November is the first to integrate the new version of SUSE's YaST that is written in Ruby...

    http://www.phoronix.com/vr.php?view=MTQzMzg

  • #2
    Is there going to be any difference to the end-user for the new YaST or is it all back-end stuff?

    I have my Uncle's family computer running openSUSE 12.1 so looking forward to update in November. With everyone just using Skype, playing video and browsing the Internet they barely noticed the different OS. You know, except the insane speed increase.

    Comment


    • #3
      No, it's backend work, just so it's easier to maintain it. Hopefully this work can also help with integrating YaST with polkit in the long run, too.

      Comment


      • #4
        Has anybody tried M4 yet? Ruby Yast was described as very slow back then.

        Comment


        • #5
          Ruby is one of those languages that is easy to write code in, but hard to maintain. But unlike PERL (also hard to maintain) I don't think I have ever come across a language with worse documentation ethics.

          Comment


          • #6
            I've tried both M3 and M4 and I've found them to be both surprisingly stable. I haven't tinkered with YaST yet but it will be interesting to see if there are any significant user-facing changes.

            Comment

            Working...
            X