Announcement

Collapse
No announcement yet.

Debian Wheezy Now Has Less Than 100 Critical Bugs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by uid313 View Post
    No /usr/ merge?

    Boring that new fresh Wheezy will use old GNOME 3.4, KDE 4.8, and Xfce 4.8.
    If you want KDE 4.9, it's in experimental-snapshots (qt-kde.debian.net). KDE 4.10 SC is currently being packaged at git.debian.org and will probably be in wheezy-backports. Also I think phoronix missed the news article about debian backports being merged into the official main repos.. Which means Debian *is* going to try to get something close to a rolling release going by backporting bleeding edge versions of software into Debian stable for people that want bleeding-edge versions of specific packages without having to pull in a ton of unstable libs to go with it.
    Last edited by Sidicas; 03-22-2013, 08:02 AM.

    Comment


    • #12
      Originally posted by Sonadow View Post
      For certain packages it does matter.

      Debian's testing, unstable and experimental repositories only carry Mesa 8 while virtually all other distributions are already on Mesa 9, and Mesa 9 is not even available in their backports. And that is just 1 example.
      Yea, I know.. Apparently the devs who work on X and Mesa also are on the Debian release team... When I contacted the Debian Mesa team because I had Mesa 9 compiling and was looking for suggestions on getting it packaged, they basically told me to wait until after Wheezy is released because they're all working on squashing Release Critical bugs in other software.

      I think all the big Debian packages are collectively maintained, so it should be possible to join the team and push Mesa 9 packaging to the Debian's git repos, which are used as staging areas for packaging, in order to get it ready for wheezy-backports.. I'm still waiting for the approval to join the collab-maint team though , I guess the people who handle that are also busy squashing RC bugs in other software or working on other release related things..

      Mesa 9 is absolutely critical if you're running Steam on open source drivers . It's also a PITA to compile for steam because you need a 32-bit Mesa 9 to go with the 32-bit Steam which means if you're amd64, you need to set up multi-arch and installing a lot of i386 dev packages just to get it compiled.. At least when you're done, you can run Steam with Mesa 9 and all your other apps can keep using Mesa 8.0.5 with the proven stability .
      Last edited by Sidicas; 03-22-2013, 08:14 AM.

      Comment


      • #13
        Debian's testing, unstable and experimental repositories only carry Mesa 8 while virtually all other distributions are already on Mesa 9, and Mesa 9 is not even available in their backports. And that is just 1 example.
        Yes, you're right when it comes to drivers.

        Comment


        • #14
          Originally posted by CthuIhux View Post
          [...] it's draining tonnes of precious resources from the project.[...]
          Would you elaborate that?

          Comment


          • #15
            Originally posted by oleid View Post
            Yes, you're right when it comes to drivers.
            The Mesa issue is the one issue that is really annoying for me at the moment (I run unstable at home).

            For everything else, I don't see the big deal really. Debian stable is supposed to be stable, and it is. I use Squeeze (current stable) at work, and I haven't had a crash in over 2 years. With the exception of the Network Manager plasmoid for KDE which is flaky, no single app has crashed, nothing broke after an update, everything has been rock solid.

            That's what I need on a work machine. It still has KDE 4.4, but it does the job, and it's stable stable stable. Latest Firefox is available through backports, most of the other stuff like GCC does not really need updating every month. I see what Debian are doing and I really appreciate it. I don't think that there is a more stable platform for serious work out there. Perhaps RHEL or SUSE EL, but I wouldn't bet on that either!

            Comment


            • #16
              Originally posted by Sidicas View Post
              Mesa 9 is absolutely critical if you're running Steam on open source drivers
              Mesa 8 and Intel have me running Half Life, HL2: deathmatch, Killing Floor, Trine 2, etc

              Comment


              • #17
                Originally posted by CthuIhux View Post
                That is a simple way to speed up the coming release for Debian, forget about the useless kFreeBSD port. No one will use it and it's draining tonnes of precious resources from the project.

                Also, kick those how suggested, starting and work on the kFreeBSD port from Debian. The project will run much better without them. Seriously.
                If you don't like it, try another distro, and don't let the door hit your ass on the way out.

                Comment


                • #18
                  Originally posted by CthuIhux View Post
                  That is a simple way to speed up the coming release for Debian, forget about the useless kFreeBSD port. No one will use it and it's draining tonnes of precious resources from the project.

                  Also, kick those how suggested, starting and work on the kFreeBSD port from Debian. The project will run much better without them. Seriously.
                  Debian has a kFreeBSD port?! I gotta look into that! THX!!

                  Comment


                  • #19
                    Originally posted by TestingTe View Post
                    Debian has a kFreeBSD port?! I gotta look into that! THX!!
                    It's just the FreeBSD kernel (hence the "k"). Debian also has a GNU/Hurd "port". These "ports" are treated like CPU architecture ports from a package maintenance perspective. In other words, the packages available with kFreeBSD and Hurd are the same as those available on any other "architecture" that Debian supports, provided the packages in question have been "ported" to this architecture.

                    So it's not FreeBSD at all. Just the kernel.

                    Comment


                    • #20
                      Originally posted by uid313 View Post
                      No /usr/ merge?

                      Boring that new fresh Wheezy will use old GNOME 3.4, KDE 4.8, and Xfce 4.8.
                      It is new stable. You are not supposed to be running stable unless you are on a server or something that simply can not be updated. The actual sad part is that unstable is been restricted to these old versions while wheezy is being readied for release.

                      Comment

                      Working...
                      X