Announcement

Collapse
No announcement yet.

Debian / Ubuntu with Gnome 3.x

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Debian / Ubuntu with Gnome 3.x

    Hi all,

    Here is my problem. I used Debian from Potato to the beta of Ubuntu 4.10. I've used Ubuntu from 4.10 to 10.10, then I swithed back to Debian with Gnome Shell.

    I've left Ubuntu because of the invading canonical software, and the bad integration of Gnome 3.0 (in release 10.10).

    Now I play a bit using wine or natively, and using the radeon open source driver. The problem is that Debian is moving too slowly with mesa and the drivers...

    So now is my question, how is Ubuntu 12.10 or (13.04 to come) going with Gnome Shell ? Is it possible to use Ubuntu without all canonical integrated software ?

    Thanks a lot for your advice !

  • #2
    I have got a repo for wheezy with latest mesa code but as it is build from mesa git experimental and there was never a package released in experimental it has got a bug that you can not switch to binary drivers as long as you use the new mesa code. Last night i at least figured out why building opengl apps did not work with it, i only applied a hotfix for that. So basically you can get latest mesa code... You find instructions in irc://irc.freenode.net/#kanotix when you ask the bot for !mesa . With it Team Fortress 2 runs fine with Ivy Bridge even at 1920x1200. Trine 2 is a bit slow but you can play it (faster as with mesa 8). Killing Floor works (but worked with mesa 8.0.5 as well). Serious Sam 3 does NOT work. No idea what would happen with Radeon drivers, did not test em lately. Maybe i test a r500 card sooner or later.

    Comment


    • #3
      I've check for how to update mesa to a 9.x version on wheezy, but I've never found a tutorial compatible with multi-arch
      cause of course, I run a amd64 distro and use wine.

      Comment


      • #4
        Thanks

        I have to say your repository works !
        I first tried while you were updating it, so I found it broken, but a few minutes later it was correct !

        So now I have Mesa 9.1 git on wheezy !

        Comment

        Working...
        X