Announcement

Collapse
No announcement yet.

The Steam Linux Client Is Now Available To Everyone

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    I posted about the sound on the opensuse forums.

    I know of a few opensuse users who do have sound.

    At the moment I can only guess what's wrong.

    Maybe LMMS ?
    Or the installer having a problem with my 5750 (hdmi which I dont use)
    and the onboard sound chip.

    I wish everybody stopped using flash.

    Comment


    • #22
      Originally posted by Gps4l View Post
      I posted about the sound on the opensuse forums.

      I know of a few opensuse users who do have sound.

      At the moment I can only guess what's wrong.

      Maybe LMMS ?
      Or the installer having a problem with my 5750 (hdmi which I dont use)
      and the onboard sound chip.

      I wish everybody stopped using flash.
      Is there anywhere that the executables log their stdout/stderr to? I know you can run them by hand by browsing to ~/.local/share/steam/common/SteamApps/ (or something like that)... You may need to play with the LD_LIBRARY_PATH in order to get it to find all the right libraries, but maybe it'll give you some insight.

      Comment


      • #23
        Steam ( system overview ) says this:

        Recent Failure Reports:
        Thu Dec 20 18:28:23 2012 GMT: file ''/tmp/dumps/crash_20121220192817_1.dmp'', upload yes: ''CrashID=bp-38238b30-6ac7-41b3-8f50-8c1962121220''

        On git hub I have an reply , he ? tells me:
        crashes in libcef.so

        Tomorrow I will try what you sugested.
        I remember something about being able to see what goes wrong.
        Maybe start steam from the command line.
        If I remember right you could add something to the start command.

        Comment


        • #24
          If you have no sound try to run:
          SDL_AUDIODRIVER=alsa steam

          Comment


          • #25
            Originally posted by Pitmairen View Post
            If you have no sound try to run:
            SDL_AUDIODRIVER=alsa steam
            for me this does the trick with pulseaudio to get sound on openSUSE 12.2 (64bit):
            Code:
            SDL_AUDIODRIVER=pulse steam

            Comment


            • #26
              Originally posted by droste View Post
              for me this does the trick with pulseaudio to get sound on openSUSE 12.2 (64bit):
              Code:
              SDL_AUDIODRIVER=pulse steam
              it's actually: SDL_AUDIODRIVER=pulseaudio steam

              Comment


              • #27
                kernel 3.6.8
                mesa 9.0
                xorg-server 1.13.0
                xf86-video-ati 7.0.0

                Hey guys, got steam installed correctly. But I seem to be having corruption in the gui. It is all garbled and messed up.... So I ran from the command line and got this message

                Code:
                radeon: The kernel rejected CS, see dmesg for more information.
                OK, checked dmesg and this is what it had to say....

                Code:
                [43006.708381] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43006.708384] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43006.708386] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43006.721341] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43006.721344] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43006.721346] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43006.738022] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                4300638025] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43006.738027] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43006.755002] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43006.755006] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43006.755007] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43006.771554] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43006.771558] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43006.771559] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43006.838297] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43006.838301] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43006.838302] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43007.909628] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43007.909631] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 1148
                [43007.909633] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
                [43010.946440] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
                [43010.946444] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
                [43010.946446] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !

                Comment


                • #28
                  You have to report it here: http://bugs.freedesktop.org/enter_bug.cgi?product=Mesa.

                  Comment


                  • #29
                    I have less CPU consumption using steam with wine lol. TF2 is a mess all over but cogs works great!

                    Comment


                    • #30
                      I am running Kubuntu 12.10 with the 3.5.0-21-generic kernel and the 310.14 driver and it works great. The only problems I have had in steam so far is for the game unwritten tales, it wouldn't start but if you turn off the overlay it works fine, and some steam console menus you can't click on with the mouse but if you highlight the first item you can use your arrow keys to scroll down to the item you want. Yes I have filed bug reports on both.

                      Comment

                      Working...
                      X