Announcement

Collapse
No announcement yet.

No OpenGL for Flash/Stage3D on Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No OpenGL for Flash/Stage3D on Linux

    Unlike written in the news, Flash doesn't support OpenGL with Linux Stage 3D, but software rendering only.
    Please prove me wrong, but I found the following message in an Adobe forum:

    http://forums.adobe.com/message/3818085#3818085
    > This is not a bug. We disabled GPU acceleration with StageVideo and Stage3D on Linux because of drivers issues on the Linux platform.
    ...
    > Agreed, this should be stated in the release notes and will be fixed.

    Thibault Imbert is the (main?) developer, so I hope he changes mind.

    Many Linux users don't really like Flash - but one of the major reasons not to use Linux on the desktop is surely the non-existance of current (blockbuster) games.

    In case that Stage3D gets accepted by the major publishers for their new games, and Adobe finally provides proper 32- and 64bit plugins for Linux, that could be the breakthrough for games on Linux (just have a look at Epic's Stage3D demo).

    Btw, a standalone player would not be needed. Using the plugin, I just created one myself for 64bit. It's been pretty simple, actually. So all I'd need from Adobe is OpenGL support...
Working...
X