Announcement

Collapse
No announcement yet.

NetworkManager 0.9 Release Brings Networking Fun

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NetworkManager 0.9 Release Brings Networking Fun

    Phoronix: NetworkManager 0.9 Release Brings Networking Fun

    NetworkManager 0.8 was released at the beginning of the year and then NetworkManager 0.9 was planned for release in March, but its release didn't finally take place until yesterday. NetworkManager 0.9 is a huge release that breaks both the API and ABI compared to the previous NetworkManager release...

    http://www.phoronix.com/vr.php?view=OTgzMA

  • #2
    this is a major new release that "hugely" simplifies the configuration model of network devices
    I bet this means that they have removed all configuration options, similar to the rest of GNOME's inconfigurability regime.

    Comment


    • #3
      The NEWS file has been updated: http://cgit.freedesktop.org/NetworkM...5b6c79fd976737

      Comment


      • #4
        My only question is this.
        Have they made it so that when you turn on your laptop, will it connect to the strongest/closest WiFi point on the auto-connect list, or does it still connect to them in alphabetical order. That is the only reason I still deal with wicd is because of that.

        Comment


        • #5
          Note that if you're on Fedora 15 you're already using 0.9, it shipped with a pre-release, as 0.9 is required for GNOME 3 NM integration. The same may well be true of OpenSUSE, but I haven't checked.

          Comment


          • #6
            I see the long-awaited bonding support is still MIA.
            Anyone taking bets on how long before either KNetworkManager or Network-management plasma widget is fixed to work with the new API?

            Comment


            • #7
              Originally posted by myxal View Post
              I see the long-awaited bonding support is still MIA.
              Anyone taking bets on how long before either KNetworkManager or Network-management plasma widget is fixed to work with the new API?
              For Fedora 15, we had NM 0.9 ship with the NM 0.8 API available as well as the NM 0.9 API, for KDE to use.

              I don't know if that's upstream in the official NM 0.9 release, or if KDE is ported now, or what.

              Comment


              • #8
                Originally posted by Vegar View Post
                I bet this means that they have removed all configuration options, similar to the rest of GNOME's inconfigurability regime.
                Spoken like a True Believer

                Comment


                • #9
                  Originally posted by myxal View Post
                  I see the long-awaited bonding support is still MIA.
                  Anyone taking bets on how long before either KNetworkManager or Network-management plasma widget is fixed to work with the new API?
                  It works for me on Gentoo. I have been using it for a week or two.

                  Comment


                  • #10
                    "If you switch and the new active user doesnít have permissions for a connection, itís terminated."

                    So if I'm downloading something and I fast user switch the download could be cancelled?

                    Comment

                    Working...
                    X