Announcement

Collapse
No announcement yet.

MPlayer2 Is Still Alive & Kicking

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by curaga
    Are m2ts containers found anywhere else but blurays?
    Yes, some Sony cameras record HD video as .MTS. They even have subtitles -- an incrementing timestamp. Highly incompatible, though.

    Comment


    • #17
      Originally posted by RealNC View Post
      I'm using smplayer with it and pausing works just fine.
      Yes, it seems to working now for me too. I think I had a buggy xvideo driver which was fixed on update.

      Comment


      • #18
        mplayer2 has support for ordered chapters in mkv, nuff said.

        Comment


        • #19
          - OSS4 volume control support
          They really need to look at ALSA and Pulseaudio/jack integration instead.

          We shouldn't let these projects depend on organizations that want to capitalize on it while screwing everyone.
          http://en.wikipedia.org/wiki/Open_So...ietary.2C_free
          Seriously, don't let them do this AGAIN!
          They have already done it once.

          Comment


          • #20
            Originally posted by plonoma View Post
            They really need to look at ALSA and Pulseaudio/jack integration instead.

            We shouldn't let these projects depend on organizations that want to capitalize on it while screwing everyone.
            http://en.wikipedia.org/wiki/Open_So...ietary.2C_free
            Seriously, don't let them do this AGAIN!
            They have already done it once.
            What are you talking about. OSS was in the kernel. Nobody could take it away or make it closed source. It's not 4Front's fault if the kernel devs decided to abandon it and create ALSA instead of bettering the existing OSS.

            Comment


            • #21
              Originally posted by plonoma View Post
              We shouldn't let these projects depend on organizations that want to capitalize on it while screwing everyone.
              It doesn't depend on it, it supports it. I hope you can see the difference... It should be obvious that it is the choise of the user what audio server they want to use and the developers which they develope.

              Comment


              • #22
                The should rename their media player. It's confusing to have two different media players with almost identical names. Many people will think they are the same except mplayer2 is the newer version. If somebody forked Firefox and released it under the name "Firefox 12", I'm sure the Mozilla lawyers would be on to them for trademark violation. I don't know about the trademark status of mplayer, but even if it's not it's not the right thing to do.

                I can't wait for a fork called mplayer3.

                Comment


                • #23
                  Originally posted by Kano View Post
                  First try:

                  -demuxer lavf
                  It did not do any better.

                  I am guessing it may be because Mplayer and mplayer2 were compiled with different ffmpeg version (using Arch Linux)

                  Thanks.

                  Comment


                  • #24
                    Originally posted by curaga View Post
                    Are m2ts subs found anywhere else but blurays?
                    HD capture devices like hauppauges HD-PVR and Colossus also can record in m2ts and is also commonly supported by video editing suites.

                    Comment


                    • #25
                      @AnonymousCoward

                      Why dont you ask in the mplayer2 irc channel where to put a sample?

                      Comment


                      • #26
                        Sure thing.

                        Comment


                        • #27
                          unable to play VCD in mplayer2 while works in mplayer1.

                          Hi all,
                          Apologies as posting on quite an oldish thread.

                          I am on Debian sid and use the debian-multimedia repo to keep my multimedia stuff together. I came to know about mplayer2 just a day back and then saw the whole article and thread at phoronix. I tried posting my issue at the mailing list but for some reason it seems it does not work.

                          Anyway this is the current version of mplayer2 I have :-

                          Code:
                          $ dpkg -l mplayer2
                          Desired=Unknown/Install/Remove/Purge/Hold
                          | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
                          |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
                          ||/ Name                    Version                 Description
                          +++-=======================-=======================-==============================================================
                          ii  mplayer2                1:2.0~git20111203-0.2   Advanced general-purpose video player.
                          Some info. about the VCD in question :-

                          Code:
                           /media/NEW$ ls
                              cdi  ext  mpegav  segment  vcd
                          
                              /media/NEW$ du -shc
                              562M   .
                              562M   total
                          
                              /media/NEW/mpegav$ ll -h
                              total 560M
                              -r-------- 1 shirish shirish 2.8M Sep 18  2004 avseq01.dat
                              -r-------- 1 shirish shirish 557M Sep 18  2004 avseq02.dat
                          attempt to play the VCD through mplayer2 :-

                          Code:
                          $ mplayer2 vcd://3
                          MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
                          mplayer: could not connect to socket
                          mplayer: No such file or directory
                          Failed to open LIRC support. You will not be able to use your remote control.
                          
                          Playing vcd://3.
                          track 01:  adr=1  ctrl=4  format=2  00:02:00  mode: 1
                          track 02:  adr=1  ctrl=4  format=2  00:18:59  mode: 1
                          track 03:  adr=1  ctrl=4  format=2  00:40:13  mode: 1
                          
                          
                          MPlayer interrupted by signal 6 in module: open_stream
                          - MPlayer crashed. This shouldn't happen.
                            It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
                            gcc version. If you think it's MPlayer's fault, please read
                            DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
                            won't help unless you provide this information when reporting a possible bug.
                          Now trying to play the VCD, now through mplayer :-

                          Code:
                          $ mplayer vcd://3 /media/NEW/
                          Failed to read /etc/mplayer/mplayer.conf.local: No such file or directory
                          Warning unknown option include at line 171
                          MPlayer SVN-r34531 (C) 2000-2010 MPlayer Team
                          Can't open joystick device /dev/input/js0: No such file or directory
                          Can't init input joystick
                          mplayer: could not connect to socket
                          mplayer: No such file or directory
                          Failed to open LIRC support. You will not be able to use your remote control.
                          
                          Playing vcd://3.
                          track 01:  adr=1  ctrl=4  format=2  00:02:00  mode: 1
                          track 02:  adr=1  ctrl=4  format=2  00:18:59  mode: 1
                          track 03:  adr=1  ctrl=4  format=2  00:40:13  mode: 1
                          MPEG-PS file format detected.
                          VIDEO:  MPEG1  352x288  (aspect 1)  25.000 fps  1150.0 kbps (143.8 kbyte/s)
                          track 01:  adr=1  ctrl=4  format=2  00:02:00  mode: 1
                          track 02:  adr=1  ctrl=4  format=2  00:18:59  mode: 1
                          track 03:  adr=1  ctrl=4  format=2  00:40:13  mode: 1
                          open: No such file or directory
                          [MGA] Couldn't open: /dev/mga_vid
                          open: No such file or directory
                          [MGA] Couldn't open: /dev/mga_vid
                          [VO_TDFXFB] This driver only supports the 3Dfx Banshee, Voodoo3 and Voodoo 5.
                          s3fb: Couldn't map S3 registers: Operation not permitted
                          Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared
                          object file: No such file or directory
                          [vdpau] Error when calling vdp_device_create_x11: 1
                          ==========================================================================
                          Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
                          libavcodec version 53.54.100 (internal)
                          Selected video codec: [ffmpeg1] vfm: ffmpeg (FFmpeg MPEG-1)
                          ==========================================================================
                          ==========================================================================
                          Requested audio codec family [mpg123] (afm=mpg123) not available.
                          Enable it at compilation.
                          Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
                          AUDIO: 44100 Hz, 2 ch, floatle, 224.0 kbit/7.94% (ratio: 28000->352800)
                          Selected audio codec: [ffmp2float] afm: ffmpeg (FFmpeg MPEG layer-1
                          and layer-2 audio)
                          ==========================================================================
                          AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
                          Starting playback...
                          [VD_FFMPEG] Trying pixfmt=0.
                          Could not find matching colorspace - retrying with -vf scale...
                          Opening video filter: [scale]
                          The selected video_out device is incompatible with this codec.
                          Try appending the scale filter to your filter list,
                          e.g. -vf spp,scale instead of -vf spp.
                          [VD_FFMPEG] Trying pixfmt=1.
                          Could not find matching colorspace - retrying with -vf scale...
                          Opening video filter: [scale]
                          The selected video_out device is incompatible with this codec.
                          Try appending the scale filter to your filter list,
                          e.g. -vf spp,scale instead of -vf spp.
                          [VD_FFMPEG] Trying pixfmt=2.
                          Could not find matching colorspace - retrying with -vf scale...
                          Opening video filter: [scale]
                          The selected video_out device is incompatible with this codec.
                          Try appending the scale filter to your filter list,
                          e.g. -vf spp,scale instead of -vf spp.
                          Movie-Aspect is 1.22:1 - prescaling to correct movie aspect.
                          VO: [xv] 352x288 => 352x288 Planar YV12
                          A:   8.1 V:   7.8 A-V:  0.285 ct:  0.090 190/190  2%  0% 10.0% 0 0
                          Warning! FPS changed 25.000 -> 29.970  (-4.970030) [4]
                          [VD_FFMPEG] Trying pixfmt=0.
                          Could not find matching colorspace - retrying with -vf scale...
                          Opening video filter: [scale]
                          The selected video_out device is incompatible with this codec.
                          Try appending the scale filter to your filter list,
                          e.g. -vf spp,scale instead of -vf spp.
                          [VD_FFMPEG] Trying pixfmt=1.
                          Could not find matching colorspace - retrying with -vf scale...
                          Opening video filter: [scale]
                          The selected video_out device is incompatible with this codec.
                          Try appending the scale filter to your filter list,
                          e.g. -vf spp,scale instead of -vf spp.
                          [VD_FFMPEG] Trying pixfmt=2.
                          Could not find matching colorspace - retrying with -vf scale...
                          Opening video filter: [scale]
                          The selected video_out device is incompatible with this codec.
                          Try appending the scale filter to your filter list,
                          e.g. -vf spp,scale instead of -vf spp.
                          Movie-Aspect is 1.34:1 - prescaling to correct movie aspect.
                          VO: [xv] 352x240 => 352x262 Planar YV12
                          A: 733.7 V: 733.7 A-V:  0.000 ct:  0.675 21941/21941  2%  0%  9.2% 0 0
                          A: 760.8 V: 760.8 A-V:  0.000 ct:  0.675 22755/22755  2%  0%  9.2% 0 0
                          A:2017.8 V:2017.8 A-V: -0.000 ct:  0.675 60427/60427  2%  0%  9.2% 0 0
                            =====  PAUSE  =====
                          [mp2float @ 0xef4480]Header missing
                          [mpeg1video @ 0xef4480]warning: first frame is no keyframe
                          [VD_FFMPEG] DRI failure.
                          A:2029.2 V:2029.1 A-V:  0.136 ct:  0.014 60429/60429 ??% ??% ??,?% 0 0
                          [mpeg1video @ 0xef4480]warning: first frame is no keyframe
                          A:2029.3 V:2029.1 A-V:  0.175 ct:  0.017 60430/60430 ??% ??% ??,?% 0 0
                          [mpeg1video @ 0xef4480]warning: first frame is no keyframe
                          A:2030.2 V:2030.1 A-V:  0.078 ct:  0.114 60459/60459  2%  0% 12.7% 0 0
                          [mp2float @ 0xef4480]Header missing
                          [mpeg1video @ 0xef4480]warning: first frame is no keyframe
                          A:2024.1 V:2024.1 A-V:  0.000 ct:  0.163 60543/60543  2%  0% 10.4% 0 0
                          [mp2float @ 0xef4480]Header missing
                          [mpeg1video @ 0xef4480]warning: first frame is no keyframe
                          A:2039.2 V:2039.2 A-V: -0.000 ct:  0.212 60671/60671  2%  0%  9.6% 0 0
                          
                          Exiting... (Quit)
                          As can be seen it does play with mplayer (with filtering some decoders and finding whatever it needed to find) and played it.

                          Now trying to find some info. mediainfo :-

                          Code:
                          /media/NEW/mpegav$ mediainfo -f avesq02.dat
                          
                          $ dpkg -l mediainfo
                          Desired=Unknown/Install/Remove/Purge/Hold
                          | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
                          |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
                          ||/ Name                    Version                 Description
                          +++-=======================-=======================-==============================================================
                          ii  mediainfo               0.7.52-0.0              Supplies information about a video or audio file.
                          As can be seen even mediainfo is not able to give any info. Any help would be useful.

                          Comment


                          • #28
                            Mplayer2 is dead. Nothing new for 11 months now. And
                            http://lists.mplayer2.org/pipermail/...ry/000039.html


                            MPEG-1 fail.

                            Comment


                            • #29
                              I never looked mpeg1 content for ages, where did you find those But you could install package vcdimager (for vcdxrip) to get the mpg files correctly out of it and try those. Maybe the vcd parser has got problems.

                              Comment


                              • #30
                                Originally posted by jltyper View Post
                                Mplayer2 is dead. Nothing new for 11 months now.
                                Come on...
                                Only because there were no new releases, it does not mean it is dead. Not every project wants to do such quick updates as kde or firefox (or kernel, recently).
                                Just enjoy the commit log of mplayer2:
                                http://git.mplayer2.org/mplayer2/log/
                                I don't think, a dead project could produce such a log...

                                Comment

                                Working...
                                X