Announcement

Collapse
No announcement yet.

Fixed: The Linux Desktop Responsiveness Problem?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    wherever you find the patch files just
    patch -p0 < whereverthepatchwas.txt

    Comment


    • #47
      This may sound stupid, but if the I/O gets in the way with the execution of the rest of the kernel then can't the specific I/O be in another thread?

      Comment


      • #48
        Originally posted by V!NCENT View Post
        This may sound stupid, but if the I/O gets in the way with the execution of the rest of the kernel then can't the specific I/O be in another thread?
        Reading through the messages posted, it looks like that was exactly one of the problems that got fixed - it was already in another thread, but other threads were needlessly blocking on it whenever they hit a page fault.

        disclaimer - i only half understood most of what was going on, so the above is nothing more than an educated guess and could be wrong.

        p.s. - i think the logic of blocking at all has to do with performance and running out of memory. if you're low on memory it makes sense to page blocks of memory out to disk at a time rather than constantly doing 4K over and over again, and i think there was just a bug in the way it was implemented.

        Comment


        • #49
          for those still having problem with this merged 2-part patch use the one from the zen-kernel devs:

          git.zen-kernel.org diff

          Comment


          • #50
            Originally posted by smitty3268 View Post
            p.s. - i think the logic of blocking at all has to do with performance and running out of memory.
            In other words: When you're writing a shitload of bytes to the storage device and you use that same storage device for swapping everything slows down.

            Seems pretty obvious, actually

            Also sounds like: You use too more mem then you have, so enlarge your RAM capacity
            PS: should be cheaper than a new HDD once it fails due to constant writes...

            Comment


            • #51
              I haven't really noticed this problem since I stopped using swap. I also use the -ck patchset.

              Would I benefit from this patch at all or should I not bother?

              (I'm willing to test this if no one knows.)

              Comment


              • #52
                If it ain't broken...tweak it.

                Comment


                • #53
                  I have 6GB RAM, so it's not a RAM issue.

                  Comment


                  • #54
                    Maybe there should be a swap priority setting that will tell the kernel to disfavor swapping out UI processes, since LRU (or whatever the current algorithm is) isn't working. All-or-nothing mlock is probably not sufficient for this. Maybe setting higher ionice levels for UI-related processes in the startup scripts would help, too.

                    Comment


                    • #55
                      I've got rid of this problem on my laptop after some realtime patches got merged and I set my scheduler to preemptible.
                      but it persists on my desktop ... I thought it was a bad working raid driver.

                      Originally posted by movieman View Post
                      Yeah, I used to love the way that XP would swap out the web browser I was actively using when I was copying a 2GB file from one drive to another in the background.
                      Try Windows7 it's the same all the way.

                      Comment


                      • #56
                        Originally posted by Ragas View Post
                        I've got rid of this problem on my laptop after some realtime patches got merged and I set my scheduler to preemptible.
                        but it persists on my desktop ... I thought it was a bad working raid driver.


                        Try Windows7 it's the same all the way.
                        Yup same deal on Win 7 Pro

                        Comment


                        • #57
                          Here, Windows 7 does not freeze when copying big files.

                          Comment


                          • #58
                            Originally posted by RealNC View Post
                            Here, Windows 7 does not freeze when copying big files.
                            It does for some people including me

                            Comment


                            • #59
                              You also need to clarify what "freeze" means to you :P If you mean that the GUI gets skippy and lags a bit, yes I have that too. If you mean that the GUI is unusable for half a minute, then no, I only have that on Linux.

                              Comment


                              • #60
                                Originally posted by DeepDayze View Post
                                It does for some people including me
                                Do you have an SSD? Windows is notoriously know for locking up explorer (that's also the GUI) when devices are not responsive.

                                A lot of SSD's out there, especialy older SSD models, are know for being unresponsive when writing, because that usualy blocks reading.

                                Comment

                                Working...
                                X