Announcement

Collapse
No announcement yet.

Wine 1.2 Release Candidate 2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Henri View Post
    Yeah, that's a hard bug to fix, even with X Input 2 being available these days. I'm pretty sure that bug isn't supposed to be on the 1.2 milestone though.
    Oh, that's very sad... This bug effectively renders every single Unreal Engine game useless on Wine, and I'm mostly developing mods on that platform, so needless to say I can't switch to Linux permanently because of this... Ah well, the bug will be solved sooner or later, I guess.

    Comment


    • #12
      Originally posted by bugmenot2 View Post
      Another borked release, getting access violation errors while trying to launch my apps. Downgraded back to the WINE 1.2 version that is in the lucid repos and everything is working fine now.
      Sounds like an excellent opportunity to get acquainted with git bisect.

      Comment


      • #13
        Originally posted by Henri View Post
        Works for me on squeeze. Do you actually have those headers?
        O RLY ?
        i'd just git pulled all WINE as i do every once in a while to test this and i delete it every time because of this

        ./configure --prefix=/usr/local
        checking for -lfreetype... not found
        configure: error: FreeType 32-bit development files not found. Fonts will not be built.
        Use the --without-freetype option if you really want this.
        dpkg --get-selections | grep libfreetype
        libfreetype6 install
        libfreetype6-dev install
        so then i thought that since this is a 64bit system maybe i'm lacking the 32bit libs, right, so i compared the files libfreetype6-dev for amd64 and i386 and the only differences were the libfreetype.la and freetype2.pc files so i put them in the /usr/lib32 and /usr/lib32/pkgconfig and run ldconfig to no use

        any other ideas ?

        BTW, the Ubuntu-wine-ppa was updated on the day...eh...

        Comment


        • #14
          32-bit libfreetype should be in ia32-libs on Debian.

          Comment


          • #15
            Originally posted by Henri View Post
            32-bit libfreetype should be in ia32-libs on Debian.
            libfreetype.so is but not libfreetype.a or .la

            dpkg --get-selections | grep ia32
            ia32-libs install
            ia32-libs-gtk install
            ll /usr/lib32/libfreetype*
            Code:
            -rw-r--r-- 1 root root 564040 oct 15  2009 /usr/lib32/libfreetype.a ( i put it here from the 32bit -dev package just in case )
            -rw-r--r-- 1 root root    947 oct 15  2009 /usr/lib32/libfreetype.la ( i put it here from the 32bit -dev package just in case )
            lrwxrwxrwx 1 root root     16 apr 30 19:14 /usr/lib32/libfreetype.so -> libfreetype.so.6
            lrwxrwxrwx 1 root root     21 apr 30 19:14 /usr/lib32/libfreetype.so.6 -> libfreetype.so.6.3.20
            -rw-r--r-- 1 root root 483556 iun  1  2009 /usr/lib32/libfreetype.so.6.3.20

            Comment


            • #16
              Originally posted by Licaon View Post
              O RLY ?
              i'd just git pulled all WINE as i do every once in a while to test this and i delete it every time because of this

              ./configure --prefix=/usr/local
              checking for -lfreetype... not found
              configure: error: FreeType 32-bit development files not found. Fonts will not be built.
              Use the --without-freetype option if you really want this.
              any other ideas ?
              sudo apt-get install lib32z1-dev

              Worked for me Next time when configure fails and you're stuck better check config.log. The console output from configure can sometimes be misleading

              Comment


              • #17
                Originally posted by monraaf View Post
                sudo apt-get install lib32z1-dev

                Worked for me Next time when configure fails and you're stuck better check config.log. The console output from configure can sometimes be misleading
                10q m8 that was it, forgot about config.log

                now let me get these fixed:
                configure: libhal/libdbus 32-bit development files not found, no dynamic device support.
                configure: libsane 32-bit development files not found, scanners won't be supported.
                configure: libv4l 32-bit development files not found.
                configure: libcapi20 32-bit development files not found, ISDN won't be supported.
                configure: libgsm 32-bit development files not found, gsm 06.10 codec won't be supported.
                configure: libmpg123 32-bit development files not found (or too old), mp3 codec won't be supported.
                configure: libopenal 32-bit development files not found (or too old), OpenAL won't be supported.

                Comment


                • #18
                  fixed only these
                  configure: libhal/libdbus 32-bit development files not found, no dynamic device support.
                  configure: libmpg123 32-bit development files not found (or too old), mp3 codec won't be supported.
                  configure: libopenal 32-bit development files not found (or too old), OpenAL won't be supported.
                  as i don't need the others and it build ok

                  10x

                  Comment


                  • #19
                    Originally posted by bugmenot2 View Post
                    Downgraded back to the WINE 1.2 version that is in the lucid repos and everything is working fine now.
                    Actually, not everything. Thanks to the bug:
                    http://bugs.winehq.org/show_bug.cgi?id=20380
                    I couldn't play HoMM3 in Lucid. I downgraded to Karmic wine version and it works again. As kernels aren't backported, I'll have to wait till Maverick for a real fix.

                    Comment


                    • #20
                      Originally posted by m_gol View Post
                      Actually, not everything. Thanks to the bug:
                      http://bugs.winehq.org/show_bug.cgi?id=20380
                      I couldn't play HoMM3 in Lucid. I downgraded to Karmic wine version and it works again. As kernels aren't backported, I'll have to wait till Maverick for a real fix.
                      HoMM3 has a native Linux version BTW

                      Comment

                      Working...
                      X