Announcement

Collapse
No announcement yet.

KWin Can Cause A Performance Hit Too

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Is Ubuntu really messing up anything it touches ?

    Debian Sid / KDE 4.4.3 / 64bit
    Binary: Linux 64bit GCC 4.3.2 Release Mar 21 2010
    Operating system: Linux 2.6.34-0.slh.4-sidux-amd64 x86_64
    CPU model: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
    CPU flags: 3000MHz MMX+ 3DNow!+ SSE SSE2 SSE3 HTT
    GPU model: GeForce GTS 250 PCI Express 256.25 1024Mb ( it's the same for 196.36.15 or 196.36.24 BTW)

    Render: opengl
    Mode: 1680x1050 4xAA fullscreen
    Shaders: high
    Textures: high
    Filter: trilinear
    Anisotropy: 16x
    Occlusion: enabled
    Refraction: enabled
    Volumetric: enabled
    Replication: disabled
    Tessellation: disabled

    KWin/OpenGL: 590 / 12.5 / 23.4 / 47.5
    KWin/XRENDER: 598 / 12.8 / 23.7 / 47.5
    KWin/NoComp: 599 / 12.8 / 23.8 / 47.7

    NoComp/XRENDER/OpenGL: 100% / 99.8331% / 98.4975%

    Does 1.5% really matter?

    ( BTW Unigine Heaven 2.1 is out with Stereo 3D: http://unigine.com/products/heaven/ and i'll retest as fast as i can )

    Comment


    • #17
      Thanks for running these tests, Michael. I really wanted to know that

      Comment


      • #18
        Originally posted by kbios View Post
        As I posted under the compiz thread, unredirect of fullscreen windows has to be manually enabled in ~/.kde/share/config/kwinrc in kde4. For me (nvidia proprietary driver) it solves choppiness issues when running Unigine.
        May I ask you what's your distro?
        Here kwin suspends compositing just fine without tinkering with config files (Fedora12).
        Maybe that's another Ubuntu thing?

        Just done quick test with Glaxium on i915 no difference between composite and no-composite ~38 fps

        Comment


        • #19
          Unigine Heaven 2.1

          Binary: Linux 64bit GCC 4.3.2 Release May 20 2010
          Operating system: Linux 2.6.34-0.slh.4-sidux-amd64 x86_64
          CPU model: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
          CPU flags: 3000MHz MMX+ 3DNow!+ SSE SSE2 SSE3 HTT
          GPU model: GeForce GTS 250 PCI Express 256.25 1024Mb

          Render: opengl
          Mode: 1680x1050 4xAA fullscreen
          Shaders: high
          Textures: high
          Filter: trilinear
          Anisotropy: 16x
          Occlusion: enabled
          Refraction: enabled
          Volumetric: enabled
          Replication: disabled
          Tessellation: disabled

          KWin/OpenGL: 613 / 12.8 / 24.3 / 49.9
          KWin/NoComp: 614 / 12.8 / 24.4 / 50.0


          So yeah looks like Ubuntu does make Linux look bad

          Comment


          • #20
            You can check if KWin is compositing with a simple test. Install BeClock, http://kde-apps.org/content/show.php...content=117542 . After that, enable it (get a clock) run your demos.

            If you get a clock running Unigine, KWin is compositing. Almost all the time it does unredirect windows, but sometimes it fails.

            Comment


            • #21
              Originally posted by mat69 View Post
              [...] most people probably don't have the knowledge to know that, since compositing is an additional pass, it cannot make things faster in general.

              That conflicts with some of the benchmarks Michael did.
              that's not generally true, though.

              IIRC, the framebuffer that drives your displays must have a linear memory layout, because the output needs to read it in a linear fashion. Otherwise the output would wildly jump between different memory locations and eat too much memory bandwidth.

              An offscreen buffer can be in any memory layout the driver desires, i.e. swizzled. Rendering to a swizzled buffer is faster.
              For applications that render a lot, it may well be more efficient to render to a swizzled buffer all the way, then do a single additional copy to the linear buffer.

              Comment


              • #22
                Just found that [1] blog entry by one of the compiz devs, not sure if it was posted in the comiz-benchmark-thread but either way I post it here.

                Especially interesting is the So how does this affect benchmarks? part.

                [1] http://smspillaz.wordpress.com/2010/...he-benchmarks/

                Comment


                • #23
                  Originally posted by Xeno View Post
                  May I ask you what's your distro?
                  Here kwin suspends compositing just fine without tinkering with config files (Fedora12).
                  Maybe that's another Ubuntu thing?

                  Just done quick test with Glaxium on i915 no difference between composite and no-composite ~38 fps
                  Yes it's kubuntu, it has always worked this way. Maybe there is some patching that it is applied to the original sources.

                  Comment


                  • #24
                    Originally posted by Licaon View Post
                    Is Ubuntu really messing up anything it touches ?
                    What is UnredirectFullscreen= set to in ~/.kde/share/config/kwinrc for Debian Sid's KDE 4.4.3 / 64bit?

                    If it's set to true then there's your reason for a performance difference.

                    It would be nice for the KDE guys to make a user facing setting for this in their GUI at some stage.

                    Comment


                    • #25
                      Originally posted by mugginz View Post
                      What is UnredirectFullscreen= set to in ~/.kde/share/config/kwinrc for Debian Sid's KDE 4.4.3 / 64bit?
                      there was no UnredirectFullscreen= in kwinrc by default.

                      KWin/OpenGL/UnredirectFullscreen=true: 613 / 12.8 / 24.3 / 49.9
                      KWin/Composition disabled in xorg.conf: 614 / 12.8 / 24.4 / 50.0

                      Comment


                      • #26
                        Originally posted by Licaon View Post
                        there was no UnredirectFullscreen= in kwinrc by default.

                        KWin/OpenGL/UnredirectFullscreen=true: 613 / 12.8 / 24.3 / 49.9
                        KWin/Composition disabled in xorg.conf: 614 / 12.8 / 24.4 / 50.0
                        The KDE default is to unredirect full screen gl apps so I guess it makes sense to do it if there's no explicit setting made.

                        The Ubuntu behavior for unredirect=false is because of screen corruption issues some people were having and is the more reliable default, just not the fastest. I'd say they made the right decision as well. It's better to have slower but working as apposed to faster but broken for the majority of their users.

                        Comment


                        • #27
                          Originally posted by mugginz View Post
                          The KDE default is to unredirect full screen gl apps so I guess it makes sense to do it if there's no explicit setting made.
                          i don't know, there's little info on the web about this setting mostly bug reports that say one needs to enable this, so maybe it's not actually enabled by default

                          i'll retest w/ & w/o unredirect and w/o composition as soon as possible in all 3 Unigine benches

                          Comment


                          • #28
                            ...and color me surprised

                            Looks like not having UnredirectFullscreen set in kwinrc means that is enabled by default at least in Debian Sid KDE 4

                            KWin/OpenGL/UnredirectFullscreen=false: 555 / 11.0 / 22.0 / 46.1
                            KWin/OpenGL/UnredirectFullscreen=true: 613 / 12.8 / 24.3 / 49.9
                            KWin/Composition disabled in xorg.conf: 614 / 12.8 / 24.4 / 50.0

                            NoCompos/Unredirect/NoUnredirect: 100% / 99.837% / 90.391%

                            So that's about 9.609% performance difference and while this might not be a big deal looking at the numbers it is a big deal when running Unigine Heaven 2.1 'cause IT STUTTERS LIKE HELL every 2 seconds... simply horrible

                            Now, about unredirectfullscreen i've read why is set to false in Kubuntu yet using it unknowingly set to true all this time i find it hard to remember how many times i've seen any corruption with composition, but i don't use all the bells&whistles like the cube and such and only have some animations and some transparency set up.

                            Comment


                            • #29
                              Originally posted by Licaon View Post
                              Now, about unredirectfullscreen i've read why is set to false in Kubuntu yet using it unknowingly set to true all this time i find it hard to remember how many times i've seen any corruption with composition, but i don't use all the bells&whistles like the cube and such and only have some animations and some transparency set up.
                              Sadly, while doing my own tests in regards to this I had kwin completely bork after exiting Heaven with unredirectfullscreen=true so it would seen there's still some issues with it. I had to logout and back in again to get back to a usable desktop.

                              Comment


                              • #30
                                Originally posted by mugginz View Post
                                Sadly, while doing my own tests in regards to this I had kwin completely bork after exiting Heaven with unredirectfullscreen=true so it would seen there's still some issues with it. I had to logout and back in again to get back to a usable desktop.
                                what distro?
                                what KDE 4 version?
                                what composition backend OpenGL or XRender?
                                if OpenGL, with Texture from Pixmap or Shared Memory?
                                what video card?
                                did you change the resolution while inside the Heaven bench ?

                                Comment

                                Working...
                                X