Announcement

Collapse
No announcement yet.

KWin Can Cause A Performance Hit Too

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I am not sure but I think that all theses tests are mood.

    When you do compositing the window manager decides what to paint when, so the fps outputed by a game do not have to match the fps the user sees then. [1] indicates something similiar.

    [1] http://www.kdedevelopers.org/node/3365

    Comment


    • #12
      Originally posted by Pfanne View Post
      for me kwin effects are really slow and choppy with fglrx.
      compiz on the other hand runs smooth
      (im using the backclear patch)
      Same here, kwin is also really bad for me with the open source drivers too :/

      Comment


      • #13
        Does the performance hit occur if the desktop effects are disabled too? Or is it linked to the effects?
        It has to do with compositing, not any effects you switch on.

        KWin can easily suspend compositing (there is a shortcut), but like others have said, it should turn off compositing automatically for fullscreen GL apps. I have certainly never edited any rc files to achieve that.

        I seem to remember a GUI option too, but I can't find it now.

        Comment


        • #14
          Originally posted by mat69 View Post
          I am not sure but I think that all theses tests are mood.

          When you do compositing the window manager decides what to paint when, so the fps outputed by a game do not have to match the fps the user sees then. [1] indicates something similiar.

          [1] http://www.kdedevelopers.org/node/3365
          You probably did notice the guying say a multitude of times that the video he linked was a fake, right?

          Comment


          • #15
            Originally posted by nanonyme View Post
            You probably did notice the guying say a multitude of times that the video he linked was a fake, right?
            You probably did notice the updates right?

            [...] most people probably don't have the knowledge to know that, since compositing is an additional pass, it cannot make things faster in general.

            That conflicts with some of the benchmarks Michael did.

            Comment


            • #16
              Is Ubuntu really messing up anything it touches ?

              Debian Sid / KDE 4.4.3 / 64bit
              Binary: Linux 64bit GCC 4.3.2 Release Mar 21 2010
              Operating system: Linux 2.6.34-0.slh.4-sidux-amd64 x86_64
              CPU model: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
              CPU flags: 3000MHz MMX+ 3DNow!+ SSE SSE2 SSE3 HTT
              GPU model: GeForce GTS 250 PCI Express 256.25 1024Mb ( it's the same for 196.36.15 or 196.36.24 BTW)

              Render: opengl
              Mode: 1680x1050 4xAA fullscreen
              Shaders: high
              Textures: high
              Filter: trilinear
              Anisotropy: 16x
              Occlusion: enabled
              Refraction: enabled
              Volumetric: enabled
              Replication: disabled
              Tessellation: disabled

              KWin/OpenGL: 590 / 12.5 / 23.4 / 47.5
              KWin/XRENDER: 598 / 12.8 / 23.7 / 47.5
              KWin/NoComp: 599 / 12.8 / 23.8 / 47.7

              NoComp/XRENDER/OpenGL: 100% / 99.8331% / 98.4975%

              Does 1.5% really matter?

              ( BTW Unigine Heaven 2.1 is out with Stereo 3D: http://unigine.com/products/heaven/ and i'll retest as fast as i can )

              Comment


              • #17
                Thanks for running these tests, Michael. I really wanted to know that

                Comment


                • #18
                  Originally posted by kbios View Post
                  As I posted under the compiz thread, unredirect of fullscreen windows has to be manually enabled in ~/.kde/share/config/kwinrc in kde4. For me (nvidia proprietary driver) it solves choppiness issues when running Unigine.
                  May I ask you what's your distro?
                  Here kwin suspends compositing just fine without tinkering with config files (Fedora12).
                  Maybe that's another Ubuntu thing?

                  Just done quick test with Glaxium on i915 no difference between composite and no-composite ~38 fps

                  Comment


                  • #19
                    Unigine Heaven 2.1

                    Binary: Linux 64bit GCC 4.3.2 Release May 20 2010
                    Operating system: Linux 2.6.34-0.slh.4-sidux-amd64 x86_64
                    CPU model: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
                    CPU flags: 3000MHz MMX+ 3DNow!+ SSE SSE2 SSE3 HTT
                    GPU model: GeForce GTS 250 PCI Express 256.25 1024Mb

                    Render: opengl
                    Mode: 1680x1050 4xAA fullscreen
                    Shaders: high
                    Textures: high
                    Filter: trilinear
                    Anisotropy: 16x
                    Occlusion: enabled
                    Refraction: enabled
                    Volumetric: enabled
                    Replication: disabled
                    Tessellation: disabled

                    KWin/OpenGL: 613 / 12.8 / 24.3 / 49.9
                    KWin/NoComp: 614 / 12.8 / 24.4 / 50.0


                    So yeah looks like Ubuntu does make Linux look bad

                    Comment


                    • #20
                      You can check if KWin is compositing with a simple test. Install BeClock, http://kde-apps.org/content/show.php...content=117542 . After that, enable it (get a clock) run your demos.

                      If you get a clock running Unigine, KWin is compositing. Almost all the time it does unredirect windows, but sometimes it fails.

                      Comment

                      Working...
                      X