Announcement

Collapse
No announcement yet.

KDE Puts Out Software Compilation 4.4 Beta 1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Originally posted by Apopas View Post
    One thing I miss in KDE is an easy switch user plugin. My 60 years old father has real problem when need to go to menu and then hit the switch user button to find himself before a list of half a dozen users (that thing shows the command line logged users as well and that sucks) and when finally he hits the correct button (prey he didn't hit the console user by mistake) he finds himself before a locked session and needs to unlock it (even if his acount is passwordless). Why the hell the locked sessions are enabled by default and where is the option to change it? With Gnome I had a nice face/button on his panel and with a click he got just the graphically logged users, without stupid locked screens.
    Have you reported that bug? It might very well be that this has been overlooked.

    Comment


    • #42
      Originally posted by mat69 View Post
      Have you reported that bug? It might very well be that this has been overlooked.
      It has been reported by others. I didn't listen a word though that it's going to change.

      Originally posted by RealNC View Post
      I have disabled this "semantic desktop" thingy though ("-semantic-desktop" in make.conf). Might have something to do with it.
      I compiled 4.3.4 without semantic-desktop as well. Same shit
      Last edited by Apopas; 12-07-2009, 11:38 AM.

      Comment


      • #43
        Originally posted by Apopas View Post
        It has been reported by others. I didn't listen a word though that it's going to change.
        Could you please post the Bug number? I cannot promise anything but if I find the time and if it is not too hard to fix I can at least try.

        Comment


        • #44
          Originally posted by mat69 View Post
          Could you please post the Bug number? I cannot promise anything but if I find the time and if it is not too hard to fix I can at least try.
          It's the
          217738
          one.
          And thanks a lot mat69. The fact that you are willing to help, it's greatly appreciated.

          Comment


          • #45
            Originally posted by Apopas View Post
            I switched to KDE after 9 years of continual use of Gnome. Just for fun. I had free time and wanted to use something different.
            Overall, KDE is impressive, especially Dolphin's preview abilities (I won't run a comparison between KDE and Gnome, no worthy reason) but this slowness in log-out time is atrocious
            I think I know what's going on. You updated to Qt 4.6, didn't you? Don't do that. I did that today (just to test), and this resulted in the exact same thing, along with more bugs that aren't there with Qt 4.5 (like Amarok taking a long time to start while usually it pops-up almost instantly, font sizes and shapes are a bit messed up in places, text in buttons doesn't look centered correctly, stuff like that.)

            Bottom line: Don't use Qt 4.6 with KDE 4.3.x. It's not recommended to do so. Use the Qt version that KDE 4.3 has been designed for, which is Qt 4.5.x.

            Since you're on Gentoo, this is solved by putting this into /etc/portage/package.mask:

            Code:
            # KDE 4.3.x needs Qt 4.5
            >=x11-libs/qt-core-4.6.0
            >=x11-libs/qt-sql-4.6.0
            >=x11-libs/qt-test-4.6.0
            >=x11-libs/qt-script-4.6.0
            >=x11-libs/qt-dbus-4.6.0
            >=x11-libs/qt-xmlpatterns-4.6.0
            >=x11-libs/qt-gui-4.6.0
            >=x11-libs/qt-qt3support-4.6.0
            >=x11-libs/qt-svg-4.6.0
            >=x11-libs/qt-opengl-4.6.0
            >=x11-libs/qt-webkit-4.6.0
            >=x11-libs/qt-assistant-4.6.0
            >=dev-util/qt-creator-1.3.0
            Now do a world update (emerge -auDNl --with-bdeps=y world) and it will downgrade to Qt 4.5.3 (portage will resolve all blockers automatically.) You might need to re-emerge all packages depending on Qt (which of course includes KDE itself.) To get the list of packages depending on Qt, run this command:

            Code:
            for s in x11-libs/qt-core x11-libs/qt-sql x11-libs/qt-test x11-libs/qt-script x11-libs/qt-dbus x11-libs/qt-xmlpatterns x11-libs/qt-gui x11-libs/qt-qt3support x11-libs/qt-svg x11-libs/qt-opengl x11-libs/qt-webkit x11-libs/qt-assistant dev-util/qt-creator; do equery -q depends $s >> list.temp; done
            This produces a file "list.temp". Sort this list and clean-up duplicates:

            Code:
            sort list.temp -o list.temp
            uniq list.temp > list
            rm list.temp
            Now edit the resulting "list" file to remove the Qt packages (since you've already rebuilt those) along with any other packages you don't want to rebuild right now. Finally, emerge the packages:

            Code:
            emerge -a1 $(for s in $(cat list); do echo "=$s"; done)
            Do not omit the "1" option from emerge (or else you'll end up with dependencies being recorded in your world file).

            When KDE 4.4 comes out (which is designed with Qt 4.6 in mind), you will get blocker messages from emerge, so you'll know it's time to remove the package.mask entries again.
            Last edited by RealNC; 12-15-2009, 06:41 AM.

            Comment


            • #46
              Originally posted by RealNC View Post
              I think I know what's going on...
              Thanks a lot for your time friend, but I already have qt-4.5.3-r2 installed
              Something else is the problem... something but what?

              Comment


              • #47
                Too bad.

                Maybe something to do with PAM or ConsoleKit (they do manage logins/passwords/rights and stuff). I also don't have either of those installed as I consider them useless for me :P (Being able to get rid of bloat like that is pretty much the reason I use Gentoo.) That would be "-pam -consolekit" in make.conf.
                Last edited by RealNC; 12-15-2009, 10:37 AM.

                Comment


                • #48
                  Consolekit was required for KDM to work properly. I couldn't even run it without it at first place.

                  Comment


                  • #49
                    Runs fine here without consolekit. Consolekit isn't even installed.

                    You just need to make sure everything depending on Consolekit is rebuild after putting "-consolekit" in make.conf. Portage will take care of it automatically if you do "emerge -auDN world". Also, check /etc/portage/package.use; you might have explicitly enabled the USE flag there for some package and forgot about it.

                    Same goes for PAM too, btw.

                    Comment


                    • #50
                      I had installed just the core KDE and KDM, to try it a bit before install everything. I couldn't start KDM though till I intalled consolekit and rebuilt again the core KDE with the consolekit flag enabled.
                      I don't even have a /etc/portage/package.use file at all

                      Comment

                      Working...
                      X