Announcement

Collapse
No announcement yet.

Kwin effects forces card into 3D mode

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kwin effects forces card into 3D mode

    I'm starting to use KDE more now and I noticed something odd. Whenever I enable Kwin effects (openGL) my video card (HD4850) goes into 3D mode 24/7. It does not switch back until I turn the effects off. Bug in the drivers? A strange interaction between Kwin and the drivers perhaps?

  • #2
    Maybe the drivers have no way to distinguish between a game doing 3D opengl vs Kwin doing 3D opengl.

    Comment


    • #3
      Compiz does not do this, so I find it odd. I also find it interesting that even a simple thing like opening a menu forces the card to 3D clocks, even if no effects are being used. No wonder my poor laptop's battery suffered when I had Kubuntu on the little thing.

      Comment


      • #4
        Originally posted by Melcar View Post
        I'm starting to use KDE more now and I noticed something odd. Whenever I enable Kwin effects (openGL) my video card (HD4850) goes into 3D mode 24/7. It does not switch back until I turn the effects off. Bug in the drivers? A strange interaction between Kwin and the drivers perhaps?
        This does not happen here. I'm on KDE 4.3.3 and Catalyst 9.11 (Radeon HD4870), but it was also working fine with much older versions:

        Code:
        aticonfig --adapter=0 --od-getclocks
        Adapter 0 - ATI Radeon HD 4800 Series
                                    Core (MHz)    Memory (MHz)
                   Current Clocks :    500           900
                     Current Peak :    750           900
          Configurable Peak Range : [500-790]     [900-1100]
                         GPU load :    1%

        Comment

        Working...
        X