Announcement

Collapse
No announcement yet.

Why does seeking MP3s suck so much in GNU/Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why does seeking MP3s suck so much in GNU/Linux

    Little things like this make me sad , luckily there are few that work, xmms or exaile and they resemble the workings of foobar2000 for example. Other than you get tons of crackles, weird noises, and unexpected behavior, most of the seeking bar implementations / buffering are just retarded, try it on your own.

  • #2
    Originally posted by hax0r View Post
    Little things like this make me sad , luckily there are few that work, xmms or exaile and they resemble the workings of foobar2000 for example. Other than you get tons of crackles, weird noises, and unexpected behavior, most of the seeking bar implementations / buffering are just retarded, try it on your own.
    A lot of that is due to crap like pulseaudio. less then ideal kernel tuning, and choice of engine.

    Comment


    • #3
      Originally posted by hax0r View Post
      Little things like this make me sad , luckily there are few that work, xmms or exaile and they resemble the workings of foobar2000 for example. Other than you get tons of crackles, weird noises, and unexpected behavior, most of the seeking bar implementations / buffering are just retarded, try it on your own.
      Just try Amarok or Amarok 2.

      Comment


      • #4
        Originally posted by hax0r View Post
        ...xmms or exaile and they resemble the workings of foobar2000 for example. Other than you get tons of crackles, weird noises, and unexpected behavior, most of the seeking bar implementations / buffering are just retarded, try it on your own.
        Wow, people still use XMMS? I figured there were better winamp clones at this point... In any case, there are so many audio players in Linux space that I would recommend just googling for "good linux audio players" or something and try what comes up. I personally use Amarok and love that it blows peoples' minds when I show them how powerful it is.

        And yeah, I haven't had problems like crackling and popping since that time I accidentally used ESD.

        Comment


        • #5
          I've never heard (of) these problems. Amarok (1&2), Juk, kaffeine, etc all work fine here. Well, they all use xine (either directly or through phonon), so that might be the culprit. So maybe you should try a xine-based player. And xmms is deprecated, I'm surprised you even got it to work.
          Also you'll want to avoid any sound-server. Just using alsa directly usually is the most sane thing to do in my experience.

          Comment


          • #6
            No issues here with mplayer and mpg123.

            Comment


            • #7
              Force amarok to use alsa instead of auto mode and all will be fine.

              Comment


              • #8
                Originally posted by Kano View Post
                Force amarok to use alsa instead of auto mode and all will be fine.
                Well one point with the xine engine too is it's inability to do true gapless playback.

                Comment


                • #9
                  Never had this issue with Amarok 1.4.x.

                  Comment


                  • #10
                    Originally posted by Kano View Post
                    Never had this issue with Amarok 1.4.x.
                    It's very noticeable on OGG's. You can cover it up somewhat with crossfade but a wav dump will show different checksums. It's a known bug in the xine engine and everytime they try to fix it, it just comes back.

                    Comment

                    Working...
                    X