Announcement

Collapse
No announcement yet.

Posting PTS Benchmark Results to PTS Global Non-anonymously?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Posting PTS Benchmark Results to PTS Global Non-anonymously?

    Greetings!

    First - I would like to thank Michael for the Phoronix Test Suite. I recently put a Linux box together - the PTS looks like it may be very helpful for benchmarking.

    Second - I have only been able to post my PTS benchmark results to PTS Global anonymously, despite having registered at the http://global.phoronix-test-suite.com/ site. I am referring specifically to the column titled "Uploaded By" at the PTS Global Recent Benchmarks web page: instead of "Archestratus," all I can insert there is the appellation "Anonymous."

    No option pops up during or at the end of benchmarking to post on the PTS Global site non-anonymously.

    Further, working from the command line in PTS, when I try the command << phoronix-test-suite login >>, I get the following:

    phoronix-test-suite login

    If you haven't already registered for your free PTS Global account, you can do so at http://global.phoronix-test-suite.com/

    Once you have registered your account and clicked the link within the verification email, enter your log-in information below.

    User-Name: Archestratus
    Password: *******

    PTS Global Account Not Found.
    "Not found," eh?

    I wonder where PTS Global put it?


    Would someone please help me figure out what I am doing wrong?


    Thank you,

    Archestratus
    __________________________________________________ ____

    An example of one of my unintentionally "Anonymous" post attempts to PTS Global:

    http://global.phoronix-test-suite.co...0666-9674-3609

  • #2
    What distribution are you using? Some had a weird issue the other day with the curl configuration with your php.ini file.

    Also, did you activate your account? You would have received an email where you click the link?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      What distribution are you using? Some had a weird issue the other day with the curl configuration with your php.ini file.
      Ubuntu "Gutsy" 7.10. Mozilla Firefox 2.0.0.14.

      I just did a << Places -> Search for files >> of the << php.ini >> file. Five locations:

      /usr/share/doc/php5-common/examples/php.ini-recommended
      /usr/share/doc/php5-common/examples/php.ini-dist
      /usr/share/doc/php5-common/examples/php.ini-paranoid
      /usr/share/php5/php.ini-dist
      /etc/php5/cli/php.ini

      I could not find anything about << curl >> in any of the files that I could open. I could not open any of the three <<
      /usr/share/doc/php5-common/examples/php.ini- >> files, possibly because I did not try as << sudo >>.


      Also, did you activate your account? You would have received an email where you click the link?
      Yup - just like activating this forum account. Fill in the blanks, click, and then click on the email. All seemed to go routinely.

      I did use the same name and password for the PTS Global account as I had for the Phoronix forum account, as I was not sure if they were the same account or two separate accounts - minor sense of confusion there.

      What next?


      Thank you,

      Archestratus

      __________________________________________________ ____________________________________

      *Edit* - added information from << phoronix-test-suite diagnostics >>, below:

      Environmental Variables (accessible via test scripts):
      PTS_TYPE = DESKTOP
      PTS_VERSION = 0.7.0
      PTS_CODENAME = TRONDHEIM
      PTS_DIR = /usr/share/phoronix-test-suite/
      FONT_DIR = /usr/share/phoronix-test-suite/pts-core/pts-results-viewer/fonts/
      PHP_BIN = php5
      NUM_CPU_CORES = 2
      NUM_CPU_JOBS = 3
      SYS_MEMORY = 3281
      VIDEO_MEMORY = 128
      VIDEO_WIDTH = 1280
      VIDEO_HEIGHT = 1024
      OS = Ubuntu
      OS_VERSION = 7.10
      OS_ARCH = i686
      THIS_RUN_TIME = 1211161639
      Last edited by Archestratus; 05-18-2008, 09:51 PM.

      Comment


      • #4
        I Might have just solved the case

        I watch too much monk!

        Anyway Michael gave me enough hints above. I did not really see anything about curl in my php.ini (Gentoo user) I have been have this same issue.

        I had enabled the curl flag and tried recompling php with curlwrappers. Still
        did not see anything except something about windows dlls and curls but just above
        that I found

        ;;;;;;;;;;;;;;;;
        ; File Uploads ;
        ;;;;;;;;;;;;;;;;

        ; Whether to allow HTTP file uploads.
        file_uploads = On

        ; Temporary directory for HTTP uploaded files (will use system default if not
        ; specified).
        ;upload_tmp_dir =

        ; Maximum allowed size for uploaded files.
        upload_max_filesize = 2M


        ;;;;;;;;;;;;;;;;;;
        ; Fopen wrappers ;
        ;;;;;;;;;;;;;;;;;;

        ; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
        allow_url_fopen = On

        ; Whether to allow include/require to open URLs (like http:// or ftp://) as files.
        allow_url_include = On
        The file upload stuff was On but not Fopen wrappers, I turned them on and can now upload my benchmarks as my pts global user.

        Ok i didn't solve the case but they are some clues that might help the few of us with this issue.

        Comment

        Working...
        X