Announcement

Collapse
No announcement yet.

Problem running test suite

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem running test suite

    Hi !

    I downloaded the phoronox test suite 0.3.1. When I try to start it, this happens:

    Code:
    $ ./phoronix-test-suite list-tests
    PHP Warning:  mime_magic: type search/400       \\input         text/x-tex invalid in Unknown on line 0
    PHP Warning:  mime_magic: type search/400       \\section       text/x-tex invalid in Unknown on line 0
    PHP Warning:  mime_magic: type search/400       \\setlength     text/x-tex invalid in Unknown on line 0
    PHP Warning:  mime_magic: type search/400       \\documentstyle text/x-tex invalid in Unknown on line 0
    PHP Warning:  mime_magic: type search/400       \\chapter       text/x-tex invalid in Unknown on line 0
    PHP Warning:  mime_magic: type search/400       \\documentclass text/x-tex invalid in Unknown on line 0
    PHP Warning:  mime_magic: type regex            [Cc]onstant[[:space:]]+[Ss]tory text/x-inform invalid in Unknown on line 0
    
    Fatal error: Cannot instantiate non-existent class:  tandem_xmlreader in /data/sys/tmp/phoronix-test-suite/pts-core/functions/pts-functions_config.php on line 14

    I've tried looking at the source, but couldn't figure out what's going wrong. Any idea ?

  • #2
    What version of PHP are you running?

    Anyways, try pulling from git http://phorogit.com/index.php?p=phor...e.git&dl=targz to see if that copy works
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Checking the version was a good hint. It wasn't only the test suite that was broken, it was the whole php-installation. An update solved the problem.

      Thanks !

      Comment

      Working...
      X