Announcement

Collapse
No announcement yet.

Nexuiz fails to launch on x64 systems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nexuiz fails to launch on x64 systems

    Michael,

    You might want to take a look at this thread reguarding nexiuz and x64

    http://alientrap.org/forum/viewtopic.php?t=2776

  • #2
    I actually have no problems on x64 with Nexuiz and I know others have had no problems either with x64. Have you tried running Nexuiz manually to see if it works?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      I actually have no problems on x64 with Nexuiz and I know others have had no problems either with x64. Have you tried running Nexuiz manually to see if it works?
      Yes it's a known issue with various x64 systems.
      Slamd64, openSUSE, some older versions of Fedora, BlueWhite all have the issue.

      Applying the latest patch found here

      http://alientrap.org/forum/viewtopic.php?t=2824

      cures the issue.

      Comment


      • #4
        pre Nexuiz patch

        http://global.phoronix-test-suite.co...190-9792-24916

        Post Nexuiz patch

        http://global.phoronix-test-suite.co...28-14647-16545

        Comment


        • #5
          Nexuiz runs fine on my Gutsy x86_64 system

          Comment


          • #6
            Originally posted by Melcar View Post
            Nexuiz runs fine on my Gutsy x86_64 system
            That's because your probably running libtool 2.2 or libtool 1.5 with code patched.

            Comment


            • #7
              Same here, runs fine on my 64bit 7.10.

              I hope other distros fix that though.

              Comment


              • #8
                Originally posted by Vadi View Post
                Same here, runs fine on my 64bit 7.10.

                I hope other distros fix that though.
                Try it on a non Debian based system. The patch should be made official soon for the game and integrated into a new build.

                Comment


                • #9
                  Well the nexuiz binary does not run with Debian etch, so I have to use a patch to use a locally installed backport. Also it seems to be wise to use -nosound option, because on 64bit sound does not work due to missing alsa in compatiblity libs.
                  Last edited by Kano; 04-03-2008, 10:55 AM.

                  Comment


                  • #10
                    Originally posted by Kano View Post
                    Well the nexuiz binary does not run with Debian etch, so I have to use a patch to use a locally installed backport. Also it seems to be wise to use -nosound option, because on 64bit sound does not work due to missing alsa in compatiblity libs.
                    Did you apply the latest patch? Sound works fine here.

                    Comment


                    • #11
                      Well usually in oss mode if you hear one (or did you install 32 bit libs for alsa?) - thats no good comparision. Also I found out that the Debian sid package of nexuiz was compiled with debug and that was much slower than the "official" one. Saidly this was compiled with a too new glibc 2.4 - other games like sauerbraten would work directly with the official packages. Therefore I disabled now the debug mode for the Kanotix repository - you can expect up to 40% speed improvement when you formerly used the sid package (or an unmodified backport).

                      Comment


                      • #12
                        Originally posted by Kano View Post
                        (or did you install 32 bit libs for alsa?)
                        Nope no 32-bit libs here.

                        Comment

                        Working...
                        X