Announcement

Collapse
No announcement yet.

TF2 fails to run when installed to a non-default library folder

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TF2 fails to run when installed to a non-default library folder

    Code:
    Test Run Command: cd /home/username/.phoronix-test-suite/installed-tests/pts/tf2-1.0.0/ && ./tf2 -fullscreen -novideo -w 1920 -h 1200 2>&1
    
    ./tf2: 2: cd: can't cd to /home/username//.steam/root/SteamApps/common/Team Fortress 2
    ./tf2: 4: ./tf2: ./hl2_linux: not found
    
    Test Result Value: 
    
    The test run did not produce a result.
    I have TF2 installed to a different/non-default library folder which is located on another HDD (Steam -> Settings -> Downloads -> Content Libraries) and it seems that PTS is searching for the game in the default folder which is why the benchmark won't run.

    PTS could read the correct install folder from the ./steam/root/config/config.vdf file in the future but how can I run this test now? Are there any workarounds?

    Thanks!

  • #2
    Just ran into this, seems to affect all steam-based benchmarks.

    Can this please be fixed? Even the error message given "The test run did not produce a result." is extremely vague and confusing. I have an 128gb SSD for OS/home so I can't have all my steam games on it

    Comment


    • #3
      UI suggestion: the first time PTS prints "did not produce a result", it should be followed by "if you want to know why, run phoronix-test-suite debug-foo bar".

      Comment

      Working...
      X