Announcement

Collapse
No announcement yet.

Missing Variables on three tests (PTS 4.8.3)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by harteld View Post
    .. Problem still exists in pts 5.0.....

    any idea??

    Dirk
    Some library is missing from your system.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #17
      Ok,

      I've installed followinig packages to rum pts:

      boost-thread-1.41.0-18.el6.i686 Sat 15 Mar 2014 04:37:02 PM CET
      libvorbis-devel-1.3.4-1.el6.x86_64 Fri 14 Mar 2014 08:58:32 PM CET
      libvorbis-1.3.4-1.el6.x86_64 Fri 14 Mar 2014 06:13:07 PM CET
      libogg-devel-1.1.4-2.1.el6.x86_64 Fri 14 Mar 2014 06:08:17 PM CET
      automake-1.11.1-4.el6.noarch Fri 14 Mar 2014 06:08:13 PM CET
      pcre-devel-7.8-6.el6.x86_64 Fri 14 Mar 2014 03:12:02 PM CET
      blas-devel-3.2.1-4.el6.i686 Fri 14 Mar 2014 02:12:56 PM CET
      blas-3.2.1-4.el6.i686 Fri 14 Mar 2014 02:12:55 PM CET
      libgfortran-4.4.7-4.el6.i686 Fri 14 Mar 2014 02:12:53 PM CET
      glibc-devel-2.12-1.132.el6.i686 Fri 14 Mar 2014 02:05:55 PM CET
      gcc-c++-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 01:29:01 PM CET
      libstdc++-devel-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 01:28:59 PM CET
      yasm-1.2.0-1.el6.x86_64 Fri 14 Mar 2014 01:06:31 PM CET
      numactl-devel-2.0.7-8.el6.x86_64 Fri 14 Mar 2014 01:00:01 PM CET
      bzip2-devel-1.0.5-7.el6_0.x86_64 Fri 14 Mar 2014 01:00:00 PM CET
      libjpeg-turbo-devel-1.2.1-3.el6_5.x86_64 Fri 14 Mar 2014 12:59:59 PM CET
      autoconf-2.63-5.1.el6.noarch Fri 14 Mar 2014 12:59:59 PM CET
      popt-devel-1.13-7.el6.x86_64 Fri 14 Mar 2014 12:59:57 PM CET
      libtiff-devel-3.9.4-10.el6_5.x86_64 Fri 14 Mar 2014 12:59:57 PM CET
      cmake-2.6.4-5.el6.x86_64 Fri 14 Mar 2014 12:59:55 PM CET
      lapack-devel-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:59:50 PM CET
      fftw-devel-3.2.1-3.1.el6.x86_64 Fri 14 Mar 2014 12:59:48 PM CET
      libpng-devel-1.2.49-1.el6_2.x86_64 Fri 14 Mar 2014 12:59:47 PM CET
      boost-devel-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:45 PM CET
      boost-math-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:18 PM CET
      zlib-devel-1.2.3-29.el6.x86_64 Fri 14 Mar 2014 12:59:17 PM CET
      fftw-3.2.1-3.1.el6.x86_64 Fri 14 Mar 2014 12:59:16 PM CET
      blas-devel-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:59:15 PM CET
      gcc-gfortran-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 12:59:14 PM CET
      lapack-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:59:11 PM CET
      boost-python-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:03 PM CET
      boost-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:03 PM CET
      boost-serialization-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:02 PM CET
      boost-test-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:01 PM CET
      boost-signals-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:00 PM CET
      blas-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:58:59 PM CET
      boost-wave-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:57 PM CET
      boost-graph-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:57 PM CET
      boost-regex-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:56 PM CET
      boost-date-time-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:55 PM CET
      libgfortran-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 12:58:53 PM CET
      php-cli-5.3.3-27.el6_5.x86_64 Fri 14 Mar 2014 11:08:55 AM CET
      php-xml-5.3.3-27.el6_5.x86_64 Fri 14 Mar 2014 11:08:54 AM CET
      php-common-5.3.3-27.el6_5.x86_64 Fri 14 Mar 2014 11:08:53 AM CET


      I don't know if a packages is missing, but I am really sure that I've installed all I need.

      The error message during the configuration povray is the same since 4.8.2:

      Libraries
      ---------
      checking whether to link with cygwin DLL... no
      checking whether to enable static linking... no
      checking for the pthreads library -lpthreads... no
      checking whether pthreads work without any flags... no
      checking whether pthreads work with -Kthread... no
      checking whether pthreads work with -kthread... no
      checking for the pthreads library -llthread... no
      checking whether pthreads work with -pthread... yes
      checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
      checking if more special flags are required for pthreads... no
      checking for boostlib >= 1.37... yes
      checking whether the Boost::Thread library is available... yes
      checking for exit in -lboost_thread... no
      checking for exit in -lboost_thread-boost_thread... no
      configure: error: Could not link against boost_thread-boost_thread !
      make: *** No targets specified and no makefile found. Stop.

      The boost-therad libraries are coming from the original RHN Satellite Repository, and are installed in the original Path. It looks like povray expects the lib on a different Path....


      Dirk

      Comment


      • #18
        Fixed?

        Originally posted by harteld View Post
        Ok,

        I've installed followinig packages to rum pts:

        boost-thread-1.41.0-18.el6.i686 Sat 15 Mar 2014 04:37:02 PM CET
        libvorbis-devel-1.3.4-1.el6.x86_64 Fri 14 Mar 2014 08:58:32 PM CET
        libvorbis-1.3.4-1.el6.x86_64 Fri 14 Mar 2014 06:13:07 PM CET
        libogg-devel-1.1.4-2.1.el6.x86_64 Fri 14 Mar 2014 06:08:17 PM CET
        automake-1.11.1-4.el6.noarch Fri 14 Mar 2014 06:08:13 PM CET
        pcre-devel-7.8-6.el6.x86_64 Fri 14 Mar 2014 03:12:02 PM CET
        blas-devel-3.2.1-4.el6.i686 Fri 14 Mar 2014 02:12:56 PM CET
        blas-3.2.1-4.el6.i686 Fri 14 Mar 2014 02:12:55 PM CET
        libgfortran-4.4.7-4.el6.i686 Fri 14 Mar 2014 02:12:53 PM CET
        glibc-devel-2.12-1.132.el6.i686 Fri 14 Mar 2014 02:05:55 PM CET
        gcc-c++-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 01:29:01 PM CET
        libstdc++-devel-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 01:28:59 PM CET
        yasm-1.2.0-1.el6.x86_64 Fri 14 Mar 2014 01:06:31 PM CET
        numactl-devel-2.0.7-8.el6.x86_64 Fri 14 Mar 2014 01:00:01 PM CET
        bzip2-devel-1.0.5-7.el6_0.x86_64 Fri 14 Mar 2014 01:00:00 PM CET
        libjpeg-turbo-devel-1.2.1-3.el6_5.x86_64 Fri 14 Mar 2014 12:59:59 PM CET
        autoconf-2.63-5.1.el6.noarch Fri 14 Mar 2014 12:59:59 PM CET
        popt-devel-1.13-7.el6.x86_64 Fri 14 Mar 2014 12:59:57 PM CET
        libtiff-devel-3.9.4-10.el6_5.x86_64 Fri 14 Mar 2014 12:59:57 PM CET
        cmake-2.6.4-5.el6.x86_64 Fri 14 Mar 2014 12:59:55 PM CET
        lapack-devel-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:59:50 PM CET
        fftw-devel-3.2.1-3.1.el6.x86_64 Fri 14 Mar 2014 12:59:48 PM CET
        libpng-devel-1.2.49-1.el6_2.x86_64 Fri 14 Mar 2014 12:59:47 PM CET
        boost-devel-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:45 PM CET
        boost-math-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:18 PM CET
        zlib-devel-1.2.3-29.el6.x86_64 Fri 14 Mar 2014 12:59:17 PM CET
        fftw-3.2.1-3.1.el6.x86_64 Fri 14 Mar 2014 12:59:16 PM CET
        blas-devel-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:59:15 PM CET
        gcc-gfortran-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 12:59:14 PM CET
        lapack-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:59:11 PM CET
        boost-python-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:03 PM CET
        boost-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:03 PM CET
        boost-serialization-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:02 PM CET
        boost-test-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:01 PM CET
        boost-signals-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:59:00 PM CET
        blas-3.2.1-4.el6.x86_64 Fri 14 Mar 2014 12:58:59 PM CET
        boost-wave-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:57 PM CET
        boost-graph-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:57 PM CET
        boost-regex-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:56 PM CET
        boost-date-time-1.41.0-18.el6.x86_64 Fri 14 Mar 2014 12:58:55 PM CET
        libgfortran-4.4.7-4.el6.x86_64 Fri 14 Mar 2014 12:58:53 PM CET
        php-cli-5.3.3-27.el6_5.x86_64 Fri 14 Mar 2014 11:08:55 AM CET
        php-xml-5.3.3-27.el6_5.x86_64 Fri 14 Mar 2014 11:08:54 AM CET
        php-common-5.3.3-27.el6_5.x86_64 Fri 14 Mar 2014 11:08:53 AM CET


        I don't know if a packages is missing, but I am really sure that I've installed all I need.

        The error message during the configuration povray is the same since 4.8.2:

        Libraries
        ---------
        checking whether to link with cygwin DLL... no
        checking whether to enable static linking... no
        checking for the pthreads library -lpthreads... no
        checking whether pthreads work without any flags... no
        checking whether pthreads work with -Kthread... no
        checking whether pthreads work with -kthread... no
        checking for the pthreads library -llthread... no
        checking whether pthreads work with -pthread... yes
        checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
        checking if more special flags are required for pthreads... no
        checking for boostlib >= 1.37... yes
        checking whether the Boost::Thread library is available... yes
        checking for exit in -lboost_thread... no
        checking for exit in -lboost_thread-boost_thread... no
        configure: error: Could not link against boost_thread-boost_thread !
        make: *** No targets specified and no makefile found. Stop.

        The boost-therad libraries are coming from the original RHN Satellite Repository, and are installed in the original Path. It looks like povray expects the lib on a different Path....


        Dirk
        boost-thread on Scientific Linux 6.3 installs the following:

        me@ip-10-16-151-166 test-profiles]$ rpm -ql boost-thread
        /usr/lib64/libboost_thread-mt.so.5
        /usr/share/doc/boost-thread-1.41.0
        /usr/share/doc/boost-thread-1.41.0/LICENSE_1_0.txt

        so in ~/.phoronix-test-suite/test-profiles/pts/povray-1.1.2/install.sh change line 10 from this:

        LIBS="-lboost_system" ./configure COMPILED_BY="PhoronixTestSuite" --with-boost-thread=boost_thread

        to this:

        LIBS="-lboost_system" ./configure COMPILED_BY="PhoronixTestSuite" --with-boost-thread=boost_thread-mt


        Then remove ~/.phoronix-test-suite/installed-profiles/pts/povray-1.1.2 and reinstall.

        This worked for me.

        Comment


        • #19
          Thanks for the update.


          Dirk

          Comment

          Working...
          X