Announcement

Collapse
No announcement yet.

PTS 4.8.2 behind proxy failed to fetch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PTS 4.8.2 behind proxy failed to fetch

    Hi,

    I'm trying to use PTS 4.8.2 on a RHEL 6 server, installed from the generic package (install-sh).
    On the first glance, it all seems ok:
    Code:
    [root@server ~]# env | grep proxy
    http_proxy=http://10.113.100.215:8080
    https_proxy=http://10.113.100.215:8080
    [root@server ~]# egrep "allow_url_fopen|file_uploads|allow_url_include" /etc/php.ini
    file_uploads = On
    allow_url_fopen = On
    allow_url_include = On
    [root@server ~]# wget http://OpenBenchmarking.org
    --2013-09-13 12:44:21--  http://openbenchmarking.org/
    Connecting to 10.113.100.215:8080... connected.
    Proxy request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: “index.html.1”
    
        [  <=>                                                                                                                                 ] 61,411       128K/s   in 0.5s
    
    2013-09-13 12:44:21 (128 KB/s) - “index.html.1” saved [61411]
    
    [root@server ~]# wget https://OpenBenchmarking.org
    --2013-09-13 12:44:24--  https://openbenchmarking.org/
    Connecting to 10.113.100.215:8080... connected.
    Proxy request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: “index.html.2”
    
        [ <=>                                                                                                                                  ] 6,971       --.-K/s   in 0.02s
    
    2013-09-13 12:44:25 (363 KB/s) - “index.html.2” saved [6971]
    However, this is the result:
    Code:
    [root@server~]# phoronix-test-suite list-available-suites
    [NOTICE] Failed To Fetch OpenBenchmarking.org Repository Data: pts
    
    Phoronix Test Suite v4.8.2
    Available Suites
    
    
    No suites found. Please check that you have Internet connectivity to download test suite data from OpenBenchmarking.org. The Phoronix Test Suite has documentation on configuring the network setup, proxy settings, and PHP network options. Please contact Phoronix Media if you continuing to experience problems.
    I also tried setting it with network-setup:
    Code:
    [root@server~]# grep -i proxy .phoronix-test-suite/user-config.xml
          <ProxyAddress>10.113.100.215</ProxyAddress>
          <ProxyPort>8080</ProxyPort>
    It's the same.

    I see on the proxy that there is traffic to these sites (see below excerpt from squid log and from tcpdump).
    Any idea on how i could further debug this?


    Thanks.


    Code:
    1379069616.537      8 10.12.1.95 TCP_MEM_HIT/200 372 GET http://www.phoronix-test-suite.com/PTS - NONE/- text/plain
    1379069617.319    743 10.12.1.95 TCP_MISS/200 6142 CONNECT openbenchmarking.org:443 - DIRECT/198.178.120.41 -
    1379069618.110    725 10.12.1.95 TCP_MISS/200 6110 CONNECT openbenchmarking.org:443 - DIRECT/198.178.120.41 -
    Code:
    13:54:20.100169 IP 10.113.100.215.8080 > 10.12.1.95.58710: S 2104537379:2104537379(0) ack 3399665023 win 5792 <mss 1460,sackOK,timestamp 120920322 66023462,nop,wscale 0>
    13:54:20.118768 IP 10.113.100.215.8080 > 10.12.1.95.58710: . ack 54 win 5792 <nop,nop,timestamp 120920341 66023481>
    13:54:20.137365 IP 10.113.100.215.8080 > 10.12.1.95.58710: . ack 179 win 5792 <nop,nop,timestamp 120920359 66023499>
    13:54:20.137554 IP 10.113.100.215.8080 > 10.12.1.95.58710: P 1:373(372) ack 179 win 5792 <nop,nop,timestamp 120920359 66023499>
    13:54:20.137623 IP 10.113.100.215.8080 > 10.12.1.95.58710: F 373:373(0) ack 179 win 5792 <nop,nop,timestamp 120920360 66023499>
    13:54:20.156220 IP 10.113.100.215.8080 > 10.12.1.95.58710: . ack 180 win 5792 <nop,nop,timestamp 120920378 66023518>
    13:54:20.158237 IP 10.113.100.215.8080 > 10.12.1.95.58711: S 2113951609:2113951609(0) ack 4281198713 win 5792 <mss 1460,sackOK,timestamp 120920380 66023520,nop,wscale 0>
    13:54:20.176844 IP 10.113.100.215.8080 > 10.12.1.95.58711: . ack 46 win 5792 <nop,nop,timestamp 120920399 66023539>
    13:54:20.177052 IP 10.113.100.213.46768 > 198.178.120.41.443: S 2112320107:2112320107(0) win 5840 <mss 1460,sackOK,timestamp 120920399 0,nop,wscale 0>
    13:54:20.335160 IP 10.113.100.213.46768 > 198.178.120.41.443: . ack 731990991 win 5840 <nop,nop,timestamp 120920557 3448015615>
    13:54:20.335232 IP 10.113.100.215.8080 > 10.12.1.95.58711: P 1:40(39) ack 46 win 5792 <nop,nop,timestamp 120920557 66023539>
    13:54:20.354254 IP 10.113.100.215.8080 > 10.12.1.95.58711: . ack 181 win 6432 <nop,nop,timestamp 120920576 66023716>
    13:54:20.354319 IP 10.113.100.213.46768 > 198.178.120.41.443: P 0:135(135) ack 1 win 5840 <nop,nop,timestamp 120920576 3448015615>
    13:54:20.518700 IP 10.113.100.213.46768 > 198.178.120.41.443: . ack 1449 win 8688 <nop,nop,timestamp 120920741 3448015798>
    13:54:20.518748 IP 10.113.100.213.46768 > 198.178.120.41.443: . ack 2897 win 11584 <nop,nop,timestamp 120920741 3448015798>
    13:54:20.518759 IP 10.113.100.213.46768 > 198.178.120.41.443: . ack 4309 win 14480 <nop,nop,timestamp 120920741 3448015798>
    13:54:20.518837 IP 10.113.100.215.8080 > 10.12.1.95.58711: . 40:1488(1448) ack 181 win 6432 <nop,nop,timestamp 120920741 66023716>
    13:54:20.518846 IP 10.113.100.215.8080 > 10.12.1.95.58711: . 1488:2936(1448) ack 181 win 6432 <nop,nop,timestamp 120920741 66023716>
    13:54:20.518852 IP 10.113.100.215.8080 > 10.12.1.95.58711: P 2936:4348(1412) ack 181 win 6432 <nop,nop,timestamp 120920741 66023716>
    13:54:20.539924 IP 10.113.100.215.8080 > 10.12.1.95.58711: . ack 379 win 7504 <nop,nop,timestamp 120920762 66023902>
    13:54:20.539981 IP 10.113.100.213.46768 > 198.178.120.41.443: P 135:333(198) ack 4309 win 14480 <nop,nop,timestamp 120920762 3448015798>
    13:54:20.699533 IP 10.113.100.215.8080 > 10.12.1.95.58711: P 4348:4630(282) ack 379 win 7504 <nop,nop,timestamp 120920921 66023902>
    13:54:20.718165 IP 10.113.100.215.8080 > 10.12.1.95.58711: . ack 464 win 7504 <nop,nop,timestamp 120920940 66024080>
    13:54:20.718193 IP 10.113.100.213.46768 > 198.178.120.41.443: P 333:418(85) ack 4591 win 14480 <nop,nop,timestamp 120920940 3448015979>
    13:54:20.736813 IP 10.113.100.215.8080 > 10.12.1.95.58711: . ack 952 win 8576 <nop,nop,timestamp 120920959 66024099>
    13:54:20.736873 IP 10.113.100.213.46768 > 198.178.120.41.443: P 418:906(488) ack 4591 win 14480 <nop,nop,timestamp 120920959 3448015979>
    13:54:20.895225 IP 10.113.100.213.46768 > 198.178.120.41.443: . ack 4591 win 14480 <nop,nop,timestamp 120921117 3448016173,nop,nop,sack sack 1 {5161:5198} >
    13:54:20.895236 IP 10.113.100.213.46768 > 198.178.120.41.443: . ack 5198 win 17376 <nop,nop,timestamp 120921117 3448016174>
    13:54:20.895351 IP 10.113.100.215.8080 > 10.12.1.95.58711: P 4630:5237(607) ack 952 win 8576 <nop,nop,timestamp 120921117 66024099>
    13:54:20.895371 IP 10.113.100.213.46768 > 198.178.120.41.443: F 906:906(0) ack 5199 win 17376 <nop,nop,timestamp 120921117 3448016174>
    13:54:20.895441 IP 10.113.100.215.8080 > 10.12.1.95.58711: F 5237:5237(0) ack 952 win 8576 <nop,nop,timestamp 120921117 66024099>
    13:54:20.914092 IP 10.113.100.215.8080 > 10.12.1.95.58711: R 2113956847:2113956847(0) win 0
    13:54:20.943546 IP 10.113.100.215.8080 > 10.12.1.95.58712: S 2109572595:2109572595(0) ack 2459353685 win 5792 <mss 1460,sackOK,timestamp 120921166 66024306,nop,wscale 0>
    13:54:20.962161 IP 10.113.100.215.8080 > 10.12.1.95.58712: . ack 46 win 5792 <nop,nop,timestamp 120921184 66024324>
    13:54:20.962292 IP 10.113.100.213.46770 > 198.178.120.41.443: S 2111161221:2111161221(0) win 5840 <mss 1460,sackOK,timestamp 120921184 0,nop,wscale 0>
    13:54:21.119706 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 3409908197 win 5840 <nop,nop,timestamp 120921342 3448016399>
    13:54:21.119756 IP 10.113.100.215.8080 > 10.12.1.95.58712: P 1:40(39) ack 46 win 5792 <nop,nop,timestamp 120921342 66024324>
    13:54:21.138521 IP 10.113.100.215.8080 > 10.12.1.95.58712: . ack 181 win 6432 <nop,nop,timestamp 120921361 66024501>
    13:54:21.138583 IP 10.113.100.213.46770 > 198.178.120.41.443: P 0:135(135) ack 1 win 5840 <nop,nop,timestamp 120921361 3448016399>
    13:54:21.306179 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 1449 win 8688 <nop,nop,timestamp 120921528 3448016585>
    13:54:21.306192 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 2897 win 11584 <nop,nop,timestamp 120921528 3448016585>
    13:54:21.306235 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 4309 win 14480 <nop,nop,timestamp 120921528 3448016585>
    13:54:21.306362 IP 10.113.100.215.8080 > 10.12.1.95.58712: . 40:1488(1448) ack 181 win 6432 <nop,nop,timestamp 120921528 66024501>
    13:54:21.306371 IP 10.113.100.215.8080 > 10.12.1.95.58712: . 1488:2936(1448) ack 181 win 6432 <nop,nop,timestamp 120921528 66024501>
    13:54:21.306376 IP 10.113.100.215.8080 > 10.12.1.95.58712: P 2936:4348(1412) ack 181 win 6432 <nop,nop,timestamp 120921528 66024501>
    13:54:21.327187 IP 10.113.100.215.8080 > 10.12.1.95.58712: . ack 379 win 7504 <nop,nop,timestamp 120921549 66024689>
    13:54:21.327245 IP 10.113.100.213.46770 > 198.178.120.41.443: P 135:333(198) ack 4309 win 14480 <nop,nop,timestamp 120921549 3448016585>
    13:54:21.486087 IP 10.113.100.215.8080 > 10.12.1.95.58712: P 4348:4630(282) ack 379 win 7504 <nop,nop,timestamp 120921708 66024689>
    13:54:21.504679 IP 10.113.100.215.8080 > 10.12.1.95.58712: . ack 464 win 7504 <nop,nop,timestamp 120921727 66024867>
    13:54:21.504700 IP 10.113.100.213.46770 > 198.178.120.41.443: P 333:418(85) ack 4591 win 14480 <nop,nop,timestamp 120921727 3448016766>
    13:54:21.523286 IP 10.113.100.215.8080 > 10.12.1.95.58712: . ack 920 win 8576 <nop,nop,timestamp 120921745 66024885>
    13:54:21.523346 IP 10.113.100.213.46770 > 198.178.120.41.443: P 418:874(456) ack 4591 win 14480 <nop,nop,timestamp 120921745 3448016766>
    13:54:21.680774 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 4591 win 14480 <nop,nop,timestamp 120921903 3448016766,nop,nop,sack sack 1 {5161:5198} >
    13:54:21.680783 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 5198 win 17376 <nop,nop,timestamp 120921903 3448016960>
    13:54:21.680882 IP 10.113.100.215.8080 > 10.12.1.95.58712: P 4630:5237(607) ack 920 win 8576 <nop,nop,timestamp 120921903 66024885>
    13:54:21.680900 IP 10.113.100.213.46770 > 198.178.120.41.443: F 874:874(0) ack 5199 win 17376 <nop,nop,timestamp 120921903 3448016960>
    13:54:21.680992 IP 10.113.100.215.8080 > 10.12.1.95.58712: F 5237:5237(0) ack 920 win 8576 <nop,nop,timestamp 120921903 66024885>
    13:54:21.681625 IP 10.113.100.213.46770 > 198.178.120.41.443: . ack 5199 win 17376 <nop,nop,timestamp 120921904 3448016960>
    13:54:21.699664 IP 10.113.100.215.8080 > 10.12.1.95.58712: R 2109577833:2109577833(0) win 0

  • #2
    Have you tried playing with any other settings in the php.ini configuration file?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      Have you tried playing with any other settings in the php.ini configuration file?
      I wouldn't know with which ones. The three that I posted are the only that I found documented in here.
      If it helps, here's my php.ini. It's the default RHEL 6.4, with allow_url_include changed to on.
      Code:
      [root@server ~]# egrep -v ";|^$" /etc/php.ini
      [PHP]
      engine = On
      short_open_tag = Off
      asp_tags = Off
      precision = 14
      y2k_compliance = On
      output_buffering = 4096
      zlib.output_compression = Off
      implicit_flush = Off
      unserialize_callback_func =
      serialize_precision = 100
      allow_call_time_pass_reference = Off
      safe_mode = Off
      safe_mode_gid = Off
      safe_mode_include_dir =
      safe_mode_exec_dir =
      safe_mode_allowed_env_vars = PHP_
      safe_mode_protected_env_vars = LD_LIBRARY_PATH
      disable_functions =
      disable_classes =
      expose_php = On
      max_execution_time = 30
      max_input_time = 60
      memory_limit = 128M
      error_reporting = E_ALL & ~E_DEPRECATED
      display_errors = Off
      display_startup_errors = Off
      log_errors = On
      log_errors_max_len = 1024
      ignore_repeated_errors = Off
      ignore_repeated_source = Off
      report_memleaks = On
      track_errors = Off
      html_errors = Off
      variables_order = "GPCS"
      request_order = "GP"
      register_globals = Off
      register_long_arrays = Off
      register_argc_argv = Off
      auto_globals_jit = On
      post_max_size = 8M
      magic_quotes_gpc = Off
      magic_quotes_runtime = Off
      magic_quotes_sybase = Off
      auto_prepend_file =
      auto_append_file =
      default_mimetype = "text/html"
      doc_root =
      user_dir =
      enable_dl = Off
      file_uploads = On
      upload_max_filesize = 2M
      allow_url_fopen = On
      allow_url_include = On
      default_socket_timeout = 60
      [Date]
      [filter]
      [iconv]
      [intl]
      [sqlite]
      [sqlite3]
      [Pcre]
      [Pdo]
      [Phar]
      [Syslog]
      define_syslog_variables  = Off
      [mail function]
      SMTP = localhost
      smtp_port = 25
      sendmail_path = /usr/sbin/sendmail -t -i
      mail.add_x_header = On
      [SQL]
      sql.safe_mode = Off
      [ODBC]
      odbc.allow_persistent = On
      odbc.check_persistent = On
      odbc.max_persistent = -1
      odbc.max_links = -1
      odbc.defaultlrl = 4096
      odbc.defaultbinmode = 1
      [MySQL]
      mysql.allow_persistent = On
      mysql.max_persistent = -1
      mysql.max_links = -1
      mysql.default_port =
      mysql.default_socket =
      mysql.default_host =
      mysql.default_user =
      mysql.default_password =
      mysql.connect_timeout = 60
      mysql.trace_mode = Off
      [MySQLi]
      mysqli.max_links = -1
      mysqli.default_port = 3306
      mysqli.default_socket =
      mysqli.default_host =
      mysqli.default_user =
      mysqli.default_pw =
      mysqli.reconnect = Off
      [PostgresSQL]
      pgsql.allow_persistent = On
      pgsql.auto_reset_persistent = Off
      pgsql.max_persistent = -1
      pgsql.max_links = -1
      pgsql.ignore_notice = 0
      pgsql.log_notice = 0
      [Sybase-CT]
      sybct.allow_persistent = On
      sybct.max_persistent = -1
      sybct.max_links = -1
      sybct.min_server_severity = 10
      sybct.min_client_severity = 10
      [bcmath]
      bcmath.scale = 0
      [browscap]
      [Session]
      session.save_handler = files
      session.save_path = "/var/lib/php/session"
      session.use_cookies = 1
      session.use_only_cookies = 1
      session.name = PHPSESSID
      session.auto_start = 0
      session.cookie_lifetime = 0
      session.cookie_path = /
      session.cookie_domain =
      session.cookie_httponly =
      session.serialize_handler = php
      session.gc_probability = 1
      session.gc_divisor = 1000
      session.gc_maxlifetime = 1440
      session.bug_compat_42 = Off
      session.bug_compat_warn = Off
      session.referer_check =
      session.entropy_length = 0
      session.entropy_file =
      session.cache_limiter = nocache
      session.cache_expire = 180
      session.use_trans_sid = 0
      session.hash_function = 0
      session.hash_bits_per_character = 5
      url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
      [MSSQL]
      mssql.allow_persistent = On
      mssql.max_persistent = -1
      mssql.max_links = -1
      mssql.min_error_severity = 10
      mssql.min_message_severity = 10
      mssql.compatability_mode = Off
      mssql.secure_connection = Off
      [Assertion]
      [COM]
      [mbstring]
      [gd]
      [exif]
      [Tidy]
      tidy.clean_output = Off
      [soap]
      soap.wsdl_cache_enabled=1
      soap.wsdl_cache_dir="/tmp"
      soap.wsdl_cache_ttl=86400
      [sysvshm]

      Comment


      • #4
        Originally posted by Michael View Post
        Have you tried playing with any other settings in the php.ini configuration file?
        Hi,

        I wouldn't know where to look. The only settings that I saw documented are the three ones from here.
        My php.ini is the default RHEL 6.4 one, with only allow_url_include changed to On

        If it helps, here's the whole file:
        Code:
        [root@server~]# egrep -v ";|^$" /etc/php.ini
        [PHP]
        engine = On
        short_open_tag = Off
        asp_tags = Off
        precision = 14
        y2k_compliance = On
        output_buffering = 4096
        zlib.output_compression = Off
        implicit_flush = Off
        unserialize_callback_func =
        serialize_precision = 100
        allow_call_time_pass_reference = Off
        safe_mode = Off
        safe_mode_gid = Off
        safe_mode_include_dir =
        safe_mode_exec_dir =
        safe_mode_allowed_env_vars = PHP_
        safe_mode_protected_env_vars = LD_LIBRARY_PATH
        disable_functions =
        disable_classes =
        expose_php = On
        max_execution_time = 30
        max_input_time = 60
        memory_limit = 128M
        error_reporting = E_ALL & ~E_DEPRECATED
        display_errors = Off
        display_startup_errors = Off
        log_errors = On
        log_errors_max_len = 1024
        ignore_repeated_errors = Off
        ignore_repeated_source = Off
        report_memleaks = On
        track_errors = Off
        html_errors = Off
        variables_order = "GPCS"
        request_order = "GP"
        register_globals = Off
        register_long_arrays = Off
        register_argc_argv = Off
        auto_globals_jit = On
        post_max_size = 8M
        magic_quotes_gpc = Off
        magic_quotes_runtime = Off
        magic_quotes_sybase = Off
        auto_prepend_file =
        auto_append_file =
        default_mimetype = "text/html"
        doc_root =
        user_dir =
        enable_dl = Off
        file_uploads = On
        upload_max_filesize = 2M
        allow_url_fopen = On
        allow_url_include = On
        default_socket_timeout = 60
        [Date]
        [filter]
        [iconv]
        [intl]
        [sqlite]
        [sqlite3]
        [Pcre]
        [Pdo]
        [Phar]
        [Syslog]
        define_syslog_variables  = Off
        [mail function]
        SMTP = localhost
        smtp_port = 25
        sendmail_path = /usr/sbin/sendmail -t -i
        mail.add_x_header = On
        [SQL]
        sql.safe_mode = Off
        [ODBC]
        odbc.allow_persistent = On
        odbc.check_persistent = On
        odbc.max_persistent = -1
        odbc.max_links = -1
        odbc.defaultlrl = 4096
        odbc.defaultbinmode = 1
        [MySQL]
        mysql.allow_persistent = On
        mysql.max_persistent = -1
        mysql.max_links = -1
        mysql.default_port =
        mysql.default_socket =
        mysql.default_host =
        mysql.default_user =
        mysql.default_password =
        mysql.connect_timeout = 60
        mysql.trace_mode = Off
        [MySQLi]
        mysqli.max_links = -1
        mysqli.default_port = 3306
        mysqli.default_socket =
        mysqli.default_host =
        mysqli.default_user =
        mysqli.default_pw =
        mysqli.reconnect = Off
        [PostgresSQL]
        pgsql.allow_persistent = On
        pgsql.auto_reset_persistent = Off
        pgsql.max_persistent = -1
        pgsql.max_links = -1
        pgsql.ignore_notice = 0
        pgsql.log_notice = 0
        [Sybase-CT]
        sybct.allow_persistent = On
        sybct.max_persistent = -1
        sybct.max_links = -1
        sybct.min_server_severity = 10
        sybct.min_client_severity = 10
        [bcmath]
        bcmath.scale = 0
        [browscap]
        [Session]
        session.save_handler = files
        session.save_path = "/var/lib/php/session"
        session.use_cookies = 1
        session.use_only_cookies = 1
        session.name = PHPSESSID
        session.auto_start = 0
        session.cookie_lifetime = 0
        session.cookie_path = /
        session.cookie_domain =
        session.cookie_httponly =
        session.serialize_handler = php
        session.gc_probability = 1
        session.gc_divisor = 1000
        session.gc_maxlifetime = 1440
        session.bug_compat_42 = Off
        session.bug_compat_warn = Off
        session.referer_check =
        session.entropy_length = 0
        session.entropy_file =
        session.cache_limiter = nocache
        session.cache_expire = 180
        session.use_trans_sid = 0
        session.hash_function = 0
        session.hash_bits_per_character = 5
        url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
        [MSSQL]
        mssql.allow_persistent = On
        mssql.max_persistent = -1
        mssql.max_links = -1
        mssql.min_error_severity = 10
        mssql.min_message_severity = 10
        mssql.compatability_mode = Off
        mssql.secure_connection = Off
        [Assertion]
        [COM]
        [mbstring]
        [gd]
        [exif]
        [Tidy]
        tidy.clean_output = Off
        [soap]
        soap.wsdl_cache_enabled=1
        soap.wsdl_cache_dir="/tmp"
        soap.wsdl_cache_ttl=86400
        [sysvshm]

        Comment


        • #5
          I have been struggling with the same issue. Something must have changed in the way PTS or PHP is connecting to the internet. The older versions worked fine with my proxy but the new version is very flaky. It sometimes work but constantly gives errors like:
          Code:
          [ERROR] Network support is needed to obtain pts/build-apache-1.4.1 data.
          I've tried everything I can think of to no avail. Anyone else have any ideas??

          Comment


          • #6
            I'm behind a proxy which requires authentification, which isn't handled by PTS. I'll try to implement it and publish the diff.
            After working around it, I got some stuff not working with https. So I disabled it with an ENV variable :

            Code:
            export NO_OPENSSL=1
            Maybe it may help you.

            Comment


            • #7
              Adrien,
              Using that env variable seems to have made things better. Thanks for the suggestion!!

              Comment


              • #8
                If disabling https makes things better for you guys, please advise and I will have it automatically disabled when using a proxy. Likewise, any other feedback or patches welcome as I don't have any proxy setups where I can test myself.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  Originally posted by Michael View Post
                  If disabling https makes things better for you guys, please advise and I will have it automatically disabled when using a proxy. Likewise, any other feedback or patches welcome as I don't have any proxy setups where I can test myself.
                  I can also confirm that using
                  Code:
                  export NO_OPENSSL=1
                  fixes my original problem.

                  Thanks Adrien, for this suggestion.

                  Comment


                  • #10
                    Originally posted by smarmie View Post
                    I can also confirm that using
                    Code:
                    export NO_OPENSSL=1
                    fixes my original problem.

                    Thanks Adrien, for this suggestion.
                    Okay, I will put out PTS 4.8.3 that automatically disables the use of HTTPS on HTTP proxies.
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #11
                      Phoronix Test Suite 4.8.3 is now available that should fix the SSL proxy issue: http://www.phoronix-test-suite.com/?k=downloads

                      Let me know if any other issues are encountered.

                      Thanks,
                      Michael
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment


                      • #12
                        No success with 4.8.3

                        Hi, for me this still does not work. I am sitting behind a sometimes quite tricky proxy solution where I do not even have DNS resolution for outside servers.

                        I am using ubuntu 12.04 (fresh install), phoronix deb, have my http_proxy set to something like http://proxy:8080, also https_proxy=http://proxy:8080.

                        I can use wget and apt-get without any problems.

                        I also tried the export NO_OPENSSL=1

                        What EXACTLY do I have to put into the fields when I run the network setup? just "proxy" or "http://proxy" or maybe something different?

                        Is there a chance for a solution?

                        Thanks for your support,
                        Alexander

                        Comment


                        • #13
                          Originally posted by mcsuelli View Post
                          Hi, for me this still does not work. I am sitting behind a sometimes quite tricky proxy solution where I do not even have DNS resolution for outside servers.

                          I am using ubuntu 12.04 (fresh install), phoronix deb, have my http_proxy set to something like http://proxy:8080, also https_proxy=http://proxy:8080.

                          I can use wget and apt-get without any problems.

                          I also tried the export NO_OPENSSL=1

                          What EXACTLY do I have to put into the fields when I run the network setup? just "proxy" or "http://proxy" or maybe something different?

                          Is there a chance for a solution?

                          Thanks for your support,
                          Alexander
                          Try not adding the "http://" to the proxy field. If that still doesn't work otherwise I would suggest tinkering around with the php.ini file on your system as there might be some global proxy settings there.
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #14
                            Still problems...

                            I do also run Ubuntu 12.04 LTS behind proxy and has had terrible problems to reach out to the internet.
                            My version: Phoronix Test Suite v5.0.0 (Plavsk).

                            The only way I have succeded to get Phoronix Test Suite working was to
                            export NO_OPENSSL=1
                            as described above.

                            BR, David

                            Comment


                            • #15
                              Originally posted by dengdal View Post
                              I do also run Ubuntu 12.04 LTS behind proxy and has had terrible problems to reach out to the internet.
                              My version: Phoronix Test Suite v5.0.0 (Plavsk).

                              The only way I have succeded to get Phoronix Test Suite working was to
                              export NO_OPENSSL=1
                              as described above.

                              BR, David
                              Did you configure your proxy settings with the network-setup command or how?
                              Michael Larabel
                              http://www.michaellarabel.com/

                              Comment

                              Working...
                              X