Announcement

Collapse
No announcement yet.

PTS 4.8.2 behind proxy failed to fetch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Phoronix Test Suite 4.8.3 is now available that should fix the SSL proxy issue: http://www.phoronix-test-suite.com/?k=downloads

    Let me know if any other issues are encountered.

    Thanks,
    Michael
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #12
      No success with 4.8.3

      Hi, for me this still does not work. I am sitting behind a sometimes quite tricky proxy solution where I do not even have DNS resolution for outside servers.

      I am using ubuntu 12.04 (fresh install), phoronix deb, have my http_proxy set to something like http://proxy:8080, also https_proxy=http://proxy:8080.

      I can use wget and apt-get without any problems.

      I also tried the export NO_OPENSSL=1

      What EXACTLY do I have to put into the fields when I run the network setup? just "proxy" or "http://proxy" or maybe something different?

      Is there a chance for a solution?

      Thanks for your support,
      Alexander

      Comment


      • #13
        Originally posted by mcsuelli View Post
        Hi, for me this still does not work. I am sitting behind a sometimes quite tricky proxy solution where I do not even have DNS resolution for outside servers.

        I am using ubuntu 12.04 (fresh install), phoronix deb, have my http_proxy set to something like http://proxy:8080, also https_proxy=http://proxy:8080.

        I can use wget and apt-get without any problems.

        I also tried the export NO_OPENSSL=1

        What EXACTLY do I have to put into the fields when I run the network setup? just "proxy" or "http://proxy" or maybe something different?

        Is there a chance for a solution?

        Thanks for your support,
        Alexander
        Try not adding the "http://" to the proxy field. If that still doesn't work otherwise I would suggest tinkering around with the php.ini file on your system as there might be some global proxy settings there.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #14
          Still problems...

          I do also run Ubuntu 12.04 LTS behind proxy and has had terrible problems to reach out to the internet.
          My version: Phoronix Test Suite v5.0.0 (Plavsk).

          The only way I have succeded to get Phoronix Test Suite working was to
          export NO_OPENSSL=1
          as described above.

          BR, David

          Comment


          • #15
            Originally posted by dengdal View Post
            I do also run Ubuntu 12.04 LTS behind proxy and has had terrible problems to reach out to the internet.
            My version: Phoronix Test Suite v5.0.0 (Plavsk).

            The only way I have succeded to get Phoronix Test Suite working was to
            export NO_OPENSSL=1
            as described above.

            BR, David
            Did you configure your proxy settings with the network-setup command or how?
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #16
              When clients do not use HTTPS, it is enough for the proxy operator to setup some iptables rules (in the nat table):

              -A OUTPUT -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 8080

              and the proxy would function seamlessly without the need to configure anything in the clients.

              Comment


              • #17
                With PTS 5.0.1 we will disable the HTTPS OpenBenchmarking.org communication by default.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #18
                  Originally posted by Michael View Post
                  Did you configure your proxy settings with the network-setup command or how?
                  I set proxys in my .bashrc both for http and https, and this works fine for all other applications i have run.
                  I have also tried the network-setup command without success.

                  /David

                  Comment


                  • #19
                    Originally posted by dengdal View Post
                    I set proxys in my .bashrc both for http and https, and this works fine for all other applications i have run.
                    I have also tried the network-setup command without success.

                    /David
                    PTS 5.0.1 has been released and it will disable HTTPS by default - http://www.phoronix.com/scan.php?pag...tem&px=MTY1MjA
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment

                    Working...
                    X