Announcement

Collapse
No announcement yet.

Network Suite not works on Debian Squeeze 6.0.7 [ SOLUTION ]

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Network Suite not works on Debian Squeeze 6.0.7 [ SOLUTION ]

    Hy, today i had a problem with the network-loopback test, this is the error;

    Test 1 of 1
    Estimated Trial Run Count: 3
    Estimated Time To Completion: 13 Minutes
    Started Run 1 @ 17:19:56
    The test exited with a non-zero exit status.
    Started Run 2 @ 17:20:02
    The test exited with a non-zero exit status.
    Started Run 3 @ 17:20:04
    The test exited with a non-zero exit status.

    Test Results:

    Average: 0 Seconds
    This test failed to run properly.

    The following tests failed to properly run:

    - pts/network-loopback-1.0.0: Time To Transfer 10GB Via Loopback



    When i looked at the code of the script running in debug mode ( ~/user/.phoronix-test-suite-/installed-tests/pts/network-loopback-1.0.0/ )


    script "network-loopback" says;

    nc -d -l 9999 > /dev/null &
    dd if=/dev/zero bs=1M count=10000 | nc localhost 9999
    echo $? > ~/test-exit-status


    First error, the parameter "-d" for nc is depreciated see in "manpage" of nc, so below in the new command sintaxe;

    nc -l -p 9999 > /dev/null &

    Second error, in command "nc localhost 9999" put the nc parameter "-q" to prevent "exit 1" status, so the new command;

    dd if=/dev/zero bs=1M count=10000 | nc -q 5 localhost 9999

    Script edited;

    -------------------------------------------------------------------------
    #!/bin/sh

    nc -l -p 9999 > /dev/null &
    dd if=/dev/zero bs=1M count=10000 | nc -q 5 localhost 9999
    echo $? > ~/test-exit-status

    --------------------------------------------------------------------------

    Now the test network should work correctly, I hope this solution helps people with this problem, if somebody else has gone through this and managed to solve otherwise be happy to know, thanks.

    []s
Working...
X