Announcement

Collapse
No announcement yet.

Bug : Unable to run Benchmark on the discrete card in Dual muxed GPu system.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug : Unable to run Benchmark on the discrete card in Dual muxed GPu system.

    Here is a bug report concerning dual gpu ( Muxed) system which make impossible to run the benchmark on the ( supposedly high performance) Discrete cards :

    I suspect that the problem is a bit deeper that only with phoronix since a similar pb occurs with Savage2 (the game claim OpenGL is not available on the discrete card but launch well on the integretated card)...
    If anyone has similar issue or anyexplanations

    What led up to the situation?
    Try to run benchmark after switching to discrete gpu on hybrid graphics system

    What exactly did you do (or not do) that was effective (or
    ineffective)?
    Try to lanch any benchmark
    * What was the outcome of this action?
    return :" Installed: pts/xonotic-1.2.0
    3D acceleration support not available, cannot run pts/xonotic-1.2.0"

    What outcome did you expect instead? To run the test since obviously 3d acceleration is installed :
    server glx version string: 1.4
    client glx version string: 1.4
    GLX version: 1.4
    OpenGL version string: 2.1 Mesa 8.0.5
    OpenGL shading language version string: 1.20
    direct rendering: Yes

    -- System Information:
    Debian Release: 7.0
    APT prefers stable-updates
    APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'testing'), (500, 'stable')
    Architecture: i386 (i686)

    Kernel: Linux 3.9.0-rc6+ (SMP w/2 CPU cores)
    Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
    Shell: /bin/sh linked to /bin/dash

  • #2
    Originally posted by aximab View Post
    Here is a bug report concerning dual gpu ( Muxed) system which make impossible to run the benchmark on the ( supposedly high performance) Discrete cards :

    I suspect that the problem is a bit deeper that only with phoronix since a similar pb occurs with Savage2 (the game claim OpenGL is not available on the discrete card but launch well on the integretated card)...
    If anyone has similar issue or anyexplanations

    What led up to the situation?
    Try to run benchmark after switching to discrete gpu on hybrid graphics system

    What exactly did you do (or not do) that was effective (or
    ineffective)?
    Try to lanch any benchmark
    * What was the outcome of this action?
    return :" Installed: pts/xonotic-1.2.0
    3D acceleration support not available, cannot run pts/xonotic-1.2.0"

    What outcome did you expect instead? To run the test since obviously 3d acceleration is installed :
    server glx version string: 1.4
    client glx version string: 1.4
    GLX version: 1.4
    OpenGL version string: 2.1 Mesa 8.0.5
    OpenGL shading language version string: 1.20
    direct rendering: Yes

    -- System Information:
    Debian Release: 7.0
    APT prefers stable-updates
    APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'testing'), (500, 'stable')
    Architecture: i386 (i686)

    Kernel: Linux 3.9.0-rc6+ (SMP w/2 CPU cores)
    Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
    Shell: /bin/sh linked to /bin/dash
    What is the output of phoronix-test-suite diagnostics? Also glxinfo | grep OpenGL since the OpenGL renderer string isn't shown in your text above.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      The key thing in the following diagnostic is that the the test suite still think my video card isl the intel one even after switch :
      Code:
      ..........                                                                                                                                                                                                           ......                                                                                                                                      
      Variables That Can Be Used As Result Identifiers / File Names:                                                                                                                                  
      VIDEO_RESOLUTION = 1366x768                                                                                                                                                                     
      VIDEO_CARD = Intel Core IGP 1024MB                                                                                                                                                              
      VIDEO_DRIVER = vesa 2.3.1                                                                                                                                                                       
      OPENGL_DRIVER = 2.1 Mesa 8.0.5 Gallium 0.4                                                                                                                                                      
      OPERATING_SYSTEM = Debian 7.0
      PROCESSOR = Intel Pentium P6100 @ 2.00GHz (2 Cores)
      MOTHERBOARD = HP 144A v65.27
      CHIPSET = Intel Core DRAM
      KERNEL_VERSION = 3.6.0-rc7+
      COMPILER = GCC 4.7
      HOSTNAME = debian
      
      Environmental Variables (accessible via test scripts):
      PTS_VERSION = 4.4.0
      PTS_CODENAME = FORSAND
      PTS_DIR = /usr/share/phoronix-test-suite/
      PHP_BIN = php5
      NUM_CPU_CORES = 2
      NUM_CPU_JOBS = 4
      SYS_MEMORY = 4096
      VIDEO_MEMORY = 1024
      VIDEO_WIDTH = 1366
      VIDEO_HEIGHT = 768
      VIDEO_MONITOR_COUNT = 1
      VIDEO_MONITOR_LAYOUT = CENTER
      VIDEO_MONITOR_SIZES = 1366x768
      OPERATING_SYSTEM = debian
      OS_VERSION = 7.0
      OS_ARCH = i686
      OS_TYPE = Linux
      THIS_RUN_TIME = 1366158324
      Code:
      glxinfo | grep OpenGL
      OpenGL vendor string: X.Org
      OpenGL renderer string: Gallium 0.4 on AMD REDWOOD
      OpenGL version string: 2.1 Mesa 8.0.5
      OpenGL shading language version string: 1.20
      OpenGL extensions:

      Comment


      • #4
        Originally posted by aximab View Post
        The key thing in the following diagnostic is that the the test suite still think my video card isl the intel one even after switch :
        Code:
        ..........                                                                                                                                                                                                           ......                                                                                                                                      
        Variables That Can Be Used As Result Identifiers / File Names:                                                                                                                                  
        VIDEO_RESOLUTION = 1366x768                                                                                                                                                                     
        VIDEO_CARD = Intel Core IGP 1024MB                                                                                                                                                              
        VIDEO_DRIVER = vesa 2.3.1                                                                                                                                                                       
        OPENGL_DRIVER = 2.1 Mesa 8.0.5 Gallium 0.4                                                                                                                                                      
        OPERATING_SYSTEM = Debian 7.0
        PROCESSOR = Intel Pentium P6100 @ 2.00GHz (2 Cores)
        MOTHERBOARD = HP 144A v65.27
        CHIPSET = Intel Core DRAM
        KERNEL_VERSION = 3.6.0-rc7+
        COMPILER = GCC 4.7
        HOSTNAME = debian
        
        Environmental Variables (accessible via test scripts):
        PTS_VERSION = 4.4.0
        PTS_CODENAME = FORSAND
        PTS_DIR = /usr/share/phoronix-test-suite/
        PHP_BIN = php5
        NUM_CPU_CORES = 2
        NUM_CPU_JOBS = 4
        SYS_MEMORY = 4096
        VIDEO_MEMORY = 1024
        VIDEO_WIDTH = 1366
        VIDEO_HEIGHT = 768
        VIDEO_MONITOR_COUNT = 1
        VIDEO_MONITOR_LAYOUT = CENTER
        VIDEO_MONITOR_SIZES = 1366x768
        OPERATING_SYSTEM = debian
        OS_VERSION = 7.0
        OS_ARCH = i686
        OS_TYPE = Linux
        THIS_RUN_TIME = 1366158324
        Code:
        glxinfo | grep OpenGL
        OpenGL vendor string: X.Org
        OpenGL renderer string: Gallium 0.4 on AMD REDWOOD
        OpenGL version string: 2.1 Mesa 8.0.5
        OpenGL shading language version string: 1.20
        OpenGL extensions:
        For the time being you can set the SKIP_ALL_TEST_SUPPORT_CHECKS=1 environment variable to try to avoid the problem.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Ok . I Will do that Thx !

          Comment


          • #6
            Well hmm something I don't get here wasn't
            Code:
            phoronix-test-suite user-config-set SKIP_ALL_TEST_SUPPORT_CHECKS=1
            the way to do it ?
            I also randomly add this line in the xml user-config file but it does not work.
            Can you be more specific ?

            Comment


            • #7
              Originally posted by aximab View Post
              Well hmm something I don't get here wasn't
              Code:
              phoronix-test-suite user-config-set SKIP_ALL_TEST_SUPPORT_CHECKS=1
              the way to do it ?
              I also randomly add this line in the xml user-config file but it does not work.
              Can you be more specific ?
              It's an environment variable. So in termainal simply do:

              export SKIP_ALL_TEST_SUPPORT_CHECKS=1

              then after that:

              phoronix-test-suite whatever
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #8
                It still does not work same message
                Any case thanks for your advices

                Comment

                Working...
                X