Announcement

Collapse
No announcement yet.

Bug report : need to install glibc-static on CentOS, for example for pts/fs_mark

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug report : need to install glibc-static on CentOS, for example for pts/fs_mark

    Hi

    Just to let you know, I had to do the following manually before installing some tests :
    "
    yum install glibc-static
    "

    I am running CentOS 6.3, with kernel 3.6.x, and using pts version 4.0.1.

    This was needed at least for pts/fs_mark and pts/sqlite.

    Otherwise I got the following error on linking :
    "
    cc -static -o fs_mark fs_mark.o lib_timing.o
    /usr/bin/ld: cannot find -lc
    collect2: ld returned 1 exit status
    "

    So you might have to add some dependencies for some tests, so phoronix installs them by itself.

    Let me know if you need more details or help on testing

    Regards
    Alf

  • #2
    pts/crafty and pts/scimark needs unzip

    For
    "
    pts/crafty-1.3.0
    pts/scimark2-1.1.1
    "

    I needed to do "yum install unzip", also on CentOS 6.3 and pts 4.0.1

    Comment


    • #3
      Also need to install patch command

      Hi

      I also had to do a "yum install patch".

      The pts/apache-1.4.0 and pts/nginx-1.1.0 silently failed to install without patch. I.e., they were reported as successfully installed, but the exections of the tests failed.

      Here is the excerpt from apache install log "
      make[1]: Leaving directory `/root/.phoronix-test-suite/installed-tests/pts/apache-1.4.0/httpd-2.2.21'
      /root/.phoronix-test-suite/test-profiles/pts/apache-1.4.0/install.sh: line 17: patch: command not found
      "

      Regards
      Alf

      Comment


      • #4
        Similarly, apache will fail unless pcre-devel is installed.

        Comment

        Working...
        X