No announcement yet.

Bug report: N-queens is not using multiple cpu cores

  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug report: N-queens is not using multiple cpu cores

    Please see the Phoronix Test Suite results HERE for a guide showing how I found this bug.

    I am in the process of running updated tests that enable both cores on my Core 2 Duo but keep the 800 Mhz speed limit for use in making benchmarks related to the recent Phoronix article on Cortex A9s vs. a single-core Atom at 1Ghz ( My first run was using my 4-year old notebook with a single core disabled on the CPU and the other core limited to 800 MHz. Next, I re-ran the benchmarks with both cores activated, but both cores also being limited to 800 Mhz. Of course, I have had some big speedups in multi-threaded applications... with the notable exception of n-queens!

    I have made multiple runs of the n-queens benchmarks, and as you can see from the results page, there is basically zero speedup between the "Core_2_Crippled" system with only one core turned on vs. the dual-core setup. Look at the other benchmarks that do use multi-threading and you'll definitely see that multi-threading is working on this machine, just not on the N-queens benchmark.

    Please note: I have confirmed that the binary being executed is the 'qn24b_openmp' binary that is supposed to be multi-threaded through OpenMP. I have run the binary manually and through the standard PTS runs, and it does not use my second CPU core whatsoever. I think there is a bug in PTS that should get fixed. I'm running version 4.0.1 BTW.

  • #2

    No news on the bug, but the first link in my post wasn't going to the right place. Please go here: for the test results.


    • #3
      pts/n-queens-1.1.0 - - ensures the OpenMP flag is passed to the compiler. Thanks.
      Michael Larabel