Announcement

Collapse
No announcement yet.

x264 encoding - poor performance on VM - why?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • x264 encoding - poor performance on VM - why?

    Hi,

    my bachelor thesis is about comparing ESX to KVM. Now I completed a couple of benchmarks with phoronix, but I do not really understand why there is a huge performance issue on video encoding.

    please see attached graph. It shows that the physical machine has about 50 fps, while the virtualized systems on ESX and KVM have only about 13-15.

    What is the reason for that huge gap? Is the video card used for encoding on the physical machine - and on the vms just the cpu?



    any official source for information could help me a lot.

    thanks in advance

    Nico

  • #2
    - are all cores passed to the vms, instead of one?
    - is the actual cpu passed, instead of some lesser one (ie. like Qemu defaults to a p2)?

    Comment


    • #3
      Originally posted by curaga View Post
      - are all cores passed to the vms, instead of one?
      - is the actual cpu passed, instead of some lesser one (ie. like Qemu defaults to a p2)?
      I passed one and two CPUs, but the result is almost the same.

      Following the whole results in FPS:

      Physical 50,14
      ESX KVM
      1vCPU 1VM 15,71 15,27
      1vCPU 2VMs 15,59 15,28
      1vCPU 4VMs 14,27 14,04
      2vCPU 1VM 15,78 23,23
      2vCPU 2VMs 21,53 22,24
      2vCPU 4VMs 14,36 10,585

      Comment

      Working...
      X