Announcement

Collapse
No announcement yet.

PTS 3.0.1 on windows 7 ultimate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PTS 3.0.1 on windows 7 ultimate

    how does one go about invoking pts 3.0.1 on windows 7? i have installed both PHP and IIS. can i invoke it directly from the phoronix-test-suite folder? i ran the windows batch file and said yes to all the questions. here are the errors i get:

    Code:
    PS C:\Users\jimerickson\Downloads\phoronix-test-suite\phoronix-test-suite> .\phoronix-test-suite login
    No log handling enabled - turning on stderr logging
    Cannot find module (IP-MIB): At line 0 in (none)
    Cannot find module (IF-MIB): At line 0 in (none)
    Cannot find module (TCP-MIB): At line 0 in (none)
    Cannot find module (UDP-MIB): At line 0 in (none)
    Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
    Cannot find module (SNMPv2-MIB): At line 0 in (none)
    Cannot find module (SNMPv2-SMI): At line 0 in (none)
    Cannot find module (NOTIFICATION-LOG-MIB): At line 0 in (none)
    Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
    Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
    Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
    Cannot find module (NET-SNMP-AGENT-MIB): At line 0 in (none)
    Cannot find module (DISMAN-EVENT-MIB): At line 0 in (none)
    Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
    Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
    Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)
    Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
    Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
    Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
    Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
    Cannot find module (SNMPv2-TM): At line 0 in (none)
    The filename, directory name, or volume label syntax is incorrect.
    The filename, directory name, or volume label syntax is incorrect.
    The filename, directory name, or volume label syntax is incorrect.
    The filename, directory name, or volume label syntax is incorrect.
    The filename, directory name, or volume label syntax is incorrect.

  • #2
    On windows you don't type ./phoronix-test-suite. It's a batch file, you would just type phoronix-test-suite openbenchmarking-login (not just login either)

    you could type 'phoronix-test-suite.bat openbenchmarking-login' also.

    Comment


    • #3
      thanks skeetre! well i have figured out the problem. i had to compile php with dom. now it carries out commands with just the following error:

      Code:
      The filename, directory name, or volume label syntax is incorrect.
      what am i still doing wrong?

      Comment


      • #4
        I'm not sure without looking at the files directly. I'll test reinstalling 3.01 on windows when I get home from work today and see if I can get it working. I do still want to compare my windows to linux performance. I'll let you know.

        Comment


        • #5
          skeetre
          did you get a chance to look at the files directly? just wondering.

          Comment


          • #6
            Yes. I couldn't find this post to reply though.

            Michael, hopefully you see this too. I narrowed the problem down to this function:

            pts_client::user_hardware_software_reporting();

            in the phoronix-test-suite.php, well, actually the pts_client.php file. I commented it out in the phoronix-test-suite.php to stop getting the error messages.

            If you say no to hardware and software reporting after accepting the user agreement, I don't think you'll get the errors, but I couldn't find where the settings are saved to change it.

            Comment


            • #7
              skeetre
              thanks for your help! settings are stored in ~\.phoronix-test-suite\user-config.xml though changing them did not help with getting rid of the error. neither did commenting out "pts_client::user_hardware_software_reporting( );" in phoronix-test-suite.php. also reinstalling phoronix-test-suite did not help. what am i missing?

              Comment


              • #8
                Wow... Well, I got rid of the error messages for just typing 'phoronix-test-suite.bat' on this machine. But when I try to run an actual benchmark, I get the error message 9 times.

                It works on my other machine though. I'll have to test some stuff on this one again when I get home today. I did some weird stuff installing it, making a link from c:\users\skeetre to my E: drive because I was almost out of free space on C: so that could be part of my problem.

                Are you able to run any of the benchmarks, or do the openbenchmarking-login even with the errors?

                Comment


                • #9
                  skeetre
                  oops. you are right, phoronix-test-suite.bat does not produce the error now. but running a benchmark or openbenchmarking-login produces the error nine times as you mentioned. maybe micheal will see this and help us out.

                  Comment


                  • #10
                    i talked to micheal larabel on #phoronix channel on freenode and he said he has never seen this problem on his end. so i guess we should just be happy it works on our windows machines. let the benchmarking begin.

                    Comment


                    • #11
                      it works on one of mine... but not the other one.

                      Comment


                      • #12
                        I too have exactly the same problem. I will be monitoring this topic for any updates. Thank you for making this awesome testing suite

                        Comment


                        • #13
                          Hello guys, I just stumbled upon this thread and it looks quite interesting. I just downloaded and installed PTS 3.0.1 on my Ubuntu drive, and successfully ran a benchmark (although I couldn't seem to get the gui to work, will try harder later). What I would like to do is to install PTS 3.0.1 on Windows 7 Pro 64bit and compare a whole bunch of benchmarks on Windows and Linux.
                          I downloaded PHP-GTK 2.0.1 for Windows and PTS 3.0.1. But I am unclear what exactly to do next.
                          I read in the main page that the installation of PHP should be at C:\Program Files (x86)\PHP\php. The readme with the archive states that it will create a directory called php-gtk2, so perhaps I have to rename that php? Also that CPU-Z should be installed to C:\Program Files\CPUID\CPU-Z\cpuz.exe. That is already done.
                          However, I read in the thread above something about using Dom as a compiler for PHP? I am not too clear how to proceed with that, or installing the PTS program, and it would be very helpful if you would go through it stepwise so that others could also try this.
                          Thanks in advance for any advice, Tom

                          Comment

                          Working...
                          X