Announcement

Collapse
No announcement yet.

Phoronix Test Suite 2.6 Expands Cross-Platform Benchmarking

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phoronix Test Suite 2.6 Expands Cross-Platform Benchmarking

    Phoronix: Phoronix Test Suite 2.6 Expands Cross-Platform Benchmarking

    With its continuing commitment to provide quarterly updates to its industry-leading automated testing and benchmarking platform, Phoronix Media has announced the immediate availability of Phoronix Test Suite 2.6 (codenamed "Lyngen").

    http://www.phoronix.com/vr.php?view=14960

  • #2
    For some reason the gui doesn't work for me now:

    Code:
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/php_gtk2.so' - /usr/lib/php5/20090626+lfs/php_gtk2.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Fatal error:  Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 24
    I installed the php5-gtk2 deb package I always install and added the extension parameter like always, yet it doesn't want to work this time around.

    Comment


    • #3
      Did you just upgrade to Ubuntu 10.04? If so, then it's because the ABI broke with PHP 5.3 and I (or someone) need to end up building a new PHP5-GTK module for that newer PHP in Ubuntu & co.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Yeah, fresh install of Lucid.

        Comment


        • #5
          Originally posted by Melcar View Post
          For some reason the gui doesn't work for me now:

          Code:
          PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/php_gtk2.so' - /usr/lib/php5/20090626+lfs/php_gtk2.so: cannot open shared object file: No such file or directory in Unknown on line 0
          PHP Fatal error:  Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 24
          I installed the php5-gtk2 deb package I always install and added the extension parameter like always, yet it doesn't want to work this time around.
          I can agree with this. I would like to see you guys drop the dependency for php5-gtk2... it would greatly simplify the installation and porting process.

          Comment


          • #6
            Originally posted by aliendude5300 View Post
            I can agree with this. I would like to see you guys drop the dependency for php5-gtk2... it would greatly simplify the installation and porting process.
            The dependency is optional and only needed if you need the GUI. But it's really the only choice... PHP-Qt is in even worse shape than PHP-GTK and is even more scarce to find DEB/RPMs.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Michael, do you plan at one point to "officially" provide packages for php-gtk on your own? It would be really useful and convenient to have it available from the download page.

              Comment


              • #8
                I have a 32-bit PHP5-GTK Lucid built but won't have the time to do a 64-bit build until probably next week or so, but after that it will be up there like I have had the 64-bit Karmic/Jaunty PHP5-GTK.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment

                Working...
                X