Announcement

Collapse
No announcement yet.

phoronix network-setup doesn't work on any of my systems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix network-setup doesn't work on any of my systems

    First of all, I'm a bit surprised that the Phoronix Test Suite doesn't pick up the proxy information from the exported environment variables http_proxy, ftp_proxy or https_proxy.

    I enter "phoronix-test-suite network-setup" in an interactive shell, respond to the prompts with the IP address (or domain name) and port number of my proxy server, but phoronix-test-suite reports that the proxy failed. Same proxy address and port work fine with apt-get/aptitude.

    I'm using cntlm locally on all my test systems to redirect proxy requests to the appropriate remote proxy server and to handle NTLM authenitcation. So the proxy server domain is localhost and its IP address is 127.0.0.1. The proxy port is an arbitrary previously unused port above 1024.

    Any suggestions on diagnosing why "phoronix-test-suite network-setup" is failing to work? Or suggestions for configuring phoronix-test-suite to use a proxy in the situation I've described above?

    Ken

  • #2
    There might be a bug in 2.2.0. I know it should be fixed in Git master for 2.4.0, but I am trying to remember whether the fix made it in or not. I know a client had reported a problem and I got it resolved right away, but it was around the time of the 2.2.0 release.

    In regards to the proxy environmental variables, its PHP not detecting your system's proxy settings. Though I could add in support for PTS to detect them and to make PTS then override PHP's settings, similar to how I do it now with network-setup.

    Anyhow, the network-setup option just writes the values to the ~/.phoronix-test-suite/user-config.xml. If you just manually add the IP and port to the respective tags in user-config.xml, it should just work, irrelevant of that network-setup bug. But if you do encounter it not working, let me know.

    By the way, thanks for the bug reports.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      There might be a bug in 2.2.0. I know it should be fixed in Git master for 2.4.0, but I am trying to remember whether the fix made it in or not. I know a client had reported a problem and I got it resolved right away, but it was around the time of the 2.2.0 release.

      In regards to the proxy environmental variables, its PHP not detecting your system's proxy settings. Though I could add in support for PTS to detect them and to make PTS then override PHP's settings, similar to how I do it now with network-setup.

      Anyhow, the network-setup option just writes the values to the ~/.phoronix-test-suite/user-config.xml. If you just manually add the IP and port to the respective tags in user-config.xml, it should just work, irrelevant of that network-setup bug. But if you do encounter it not working, let me know.

      By the way, thanks for the bug reports.
      It does appear that PTS 2.2.0 contains a bug verifiable by executing "phoronix-test-suite network-setup" via the command line interface. On the other hand, "phoronix-test-suite gui" works OK for setting the proxy address and port via the GUI. The results for configuration of the network via the GUI are the same as I would have hand edited it as you suggested above.

      I'm pleased to hear that the issue with "phoronix-test-suite network-setup" has probably already been fixed in the git repository for the 2.4.0 release.

      Thanks for your help, Michael!

      Ken

      Comment


      • #4
        Originally posted by fuchsk View Post
        It does appear that PTS 2.2.0 contains a bug verifiable by executing "phoronix-test-suite network-setup" via the command line interface. On the other hand, "phoronix-test-suite gui" works OK for setting the proxy address and port via the GUI. The results for configuration of the network via the GUI are the same as I would have hand edited it as you suggested above.

        I'm pleased to hear that the issue with "phoronix-test-suite network-setup" has probably already been fixed in the git repository for the 2.4.0 release.

        Thanks for your help, Michael!

        Ken
        Yeah, should be fixed in 2.4.

        The GUI is simply interfacing with the user-config.xml file for you, so good to see that the manual approach is working for now.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          phoronix network setup doesnt work on any of my systems

          i cant enter in server..... i log in with my account but only appear server Kain and not Bartz.... what i supposted to do???

          Comment


          • #6
            Did you read the above? Are you using PTS 2.4 branch?
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Originally posted by Michael View Post
              Yeah, should be fixed in 2.4.

              The GUI is simply interfacing with the user-config.xml file for you, so good to see that the manual approach is working for now.
              Isn't working for me. 2.4.1 February 18, 2010 I'm using cntlm as well and posting this message through it... Btw, install.sh did a good job of mentioning php-posix but it missed php-gtk (I'm on Mandriva 2010).

              When running 'phoronix-test-suite network-setup' I get an 18 second delay for each of two calls to file_get_contents() failure and then:

              Code:
              Network Communication Is Disabled.
              
              
              ========================================
              Network Setup
              ========================================
              
              Configure the Phoronix Test Suite to use a HTTP proxy (y/N)? y
              
              Enter IP address / server name of proxy: mybox
              
              Enter TCP port for proxy server: 8079
              
              Testing Proxy Server (mybox:8079)
              
              Proxy Setup Failed.
              + PTS_EXIT_STATUS=0
              + '[' 0 -eq 8 ']'

              Interestingly the "Proxy Setup Failed" message appears immediately after pressing Enter for the port number -- I doubt it is even trying at all.

              Comment


              • #8
                Hi Micheal,

                I am using 2.4.1 and facing problems with proxy setup for phoronix-test-suite... Please help.

                Below are the warning and error messages I get. I am running phoronix on SLES 10.. 64 bit..

                ===============
                linux1:~ # phoronix-test-suite version
                PHP Warning: file_get_contents(http://www.phoronix-test-suite.com/g...os=suselinux): failed to open stream: Connection timed out in /usr/share/phoronix-test-suite/pts-core/library/pts-functions_basic.php on line 134
                PHP Warning: file_get_contents(http://www.phoronix-test-suite.com/PTS): failed to open stream: Connection timed out in /usr/share/phoronix-test-suite/pts-core/library/pts-functions_basic.php on line 134

                Network Communication Is Disabled.


                Phoronix Test Suite v2.4.1 (Lenvik)
                ================




                Thanks,
                Chandra K.

                Comment


                • #9
                  Originally posted by chandra View Post
                  Hi Micheal,

                  I am using 2.4.1 and facing problems with proxy setup for phoronix-test-suite... Please help.

                  Below are the warning and error messages I get. I am running phoronix on SLES 10.. 64 bit..

                  ===============
                  linux1:~ # phoronix-test-suite version
                  PHP Warning: file_get_contents(http://www.phoronix-test-suite.com/global/request-gs-id.php?pts=2.4.1&os=suselinux): failed to open stream: Connection timed out in /usr/share/phoronix-test-suite/pts-core/library/pts-functions_basic.php on line 134
                  PHP Warning: file_get_contents(http://www.phoronix-test-suite.com/PTS): failed to open stream: Connection timed out in /usr/share/phoronix-test-suite/pts-core/library/pts-functions_basic.php on line 134

                  Network Communication Is Disabled.


                  Phoronix Test Suite v2.4.1 (Lenvik)
                  ================




                  Thanks,
                  Chandra K.
                  Does it work if you manually input the information into ~/.phoronix-test-suite/user-config.xml ?
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    I have modified this now to check..

                    <Networking>
                    <NoNetworkCommunication>TRUE</NoNetworkCommunication>
                    <Timeout>20</Timeout>
                    <ProxyAddress>http://xxxx.xxxx.com</ProxyAddress>
                    <ProxyPort>9999</ProxyPort>
                    </Networking>

                    but it does not work still.. am I right??

                    I am not sure what all to be modified in user-config.xml..

                    but is this the fix?/

                    Thanks,
                    Chandra K.

                    Comment


                    • #11
                      Originally posted by chandra View Post
                      I have modified this now to check..

                      <Networking>
                      <NoNetworkCommunication>TRUE</NoNetworkCommunication>
                      <Timeout>20</Timeout>
                      <ProxyAddress>http://xxxx.xxxx.com</ProxyAddress>
                      <ProxyPort>9999</ProxyPort>
                      </Networking>

                      but it does not work still.. am I right??
                      Well does it work or not after you make these chanhes? NoNetworkCommunication should be FALSE and you should just modify the ProxyAddress and ProxyPort. Or if you have the http_proxy environmental variable set it should just work fine for reading from that.
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment


                      • #12
                        Originally posted by Michael View Post
                        Well does it work or not after you make these chanhes? NoNetworkCommunication should be FALSE and you should just modify the ProxyAddress and ProxyPort. Or if you have the http_proxy environmental variable set it should just work fine for reading from that.
                        No it does not work.. I tried both of the above setting only proxy and port... and finally I tried TRUE, proxy and port.. it did not work.. Another point is environment http proxy variable is set.. My browser works fine with the proxy settings...

                        Only phoronix gives the errors..

                        Thanks,
                        Chandra K.

                        Comment


                        • #13
                          Originally posted by chandra View Post
                          No it does not work.. I tried both of the above setting only proxy and port... and finally I tried TRUE, proxy and port.. it did not work.. Another point is environment http proxy variable is set.. My browser works fine with the proxy settings...

                          Only phoronix gives the errors..

                          Thanks,
                          Chandra K.
                          You could try a Git snapshot - http://phorogit.com/index.php?p=phor...e.git&dl=targz - initially with those values still in user-config.xml and if it doesn't work, to just delete them and see if the Git version reads your http proxy var correctly.
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment

                          Working...
                          X