Announcement

Collapse
No announcement yet.

Can't run phoronix on fedora VM

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't run phoronix on fedora VM

    Hi all

    I am a real novice both in linux and phoronix tool so go easy on me.

    I have install phoronix 1.8 on fedora 11 virtual machine through fedora,s rpm. The host of the vm machine is vasta.

    Though the installation is completed with all the dependancies, yet phoronix-test-suite cannot run.

    Please help, what might be the problem.


    Thanks

  • #2
    What does not run about it? What happens when you try running phoronix-test-suite?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      What does not run about it? What happens when you try running phoronix-test-suite?
      It just does not lunch when I try to, nothing happens.

      I tried to check the properties through GUI it read phoronix-test-suite GUI.

      Problem is I donot know where to start diagnosing it if I have to.

      Comment


      • #4
        You need PHP5 GTK to use the GUI. So build that or just use the CLI.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Originally posted by Michael View Post
          You need PHP5 GTK to use the GUI. So build that or just use the CLI.
          Michael,

          the package manager cannot get PHP5 GTK to build, how do I get it,

          Comment


          • #6
            You need to build from source / follow instructions (search Google or these forums as its been documented many times): http://gtk.php.net/
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Originally posted by Michael View Post
              You need to build from source / follow instructions (search Google or these forums as its been documented many times): http://gtk.php.net/
              Ok I will work on that.

              Comment


              • #8
                Hi Mic ,

                still no joy with the phps-cli installation.

                I am trying this command line getting errors please can you check if
                it's the right path if not any advise on this will be brilliant. Again please go easy this is my 2nd week with linux(fedora).

                I did this from my root.

                [root@localhost phoronix-test-suite]# yum install php5-common php5-cliLoaded plugins: refresh-packagekit
                Setting up Install Process
                No package php5-common available.
                No package php5-cli available.
                Nothing to do
                [root@localhost phoronix-test-suite]#

                got this idea from http://www.php.net/manual/en/install.unix.debian.php

                thank a Million

                Comment


                • #9
                  When php5-cli is installed it should be as easy as:

                  tar -xvf phoronix-test-suite-package-whatever-its-named.tar.gz
                  cd phoronix-test-suite/
                  ./phoronix-test-suite benchmark encode-ogg (or whatever test you want)
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    problem is I don't think Php-cli is installed yet just as php5-qtk.

                    This is what I can't get around.

                    Please how will this work in fedora I believe it uses yum instead of cvs.

                    $cvs -d pserver:cvsread@cvs.php.net:/repository login
                    $ cvs -d pserver:cvsread@cvs.php.net:/repository co -r PHP_5_2 php-src
                    Last edited by learn; 12-05-2009, 11:29 PM.

                    Comment


                    • #11
                      type:

                      which php5

                      to see if you have php5 available
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment


                      • #12
                        Originally posted by learn View Post
                        problem is I don't think Php-cli is installed yet just as php5-qtk.

                        This is what I can't get around.

                        Please how will this work in fedora I believe it uses yum instead of cvs.

                        $cvs -d pserver:cvsread@cvs.php.net:/repository login
                        $ cvs -d pserver:cvsread@cvs.php.net:/repository co -r PHP_5_2 php-src
                        When I use Which Php
                        I get /usr/bin/php

                        can I conclude that php cli is install?

                        Comment


                        • #13
                          Yep, just run an aforementioned command to run PTS from the CLI or run phoronix-test-suite system-info or something similar.
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #14
                            Originally posted by Michael View Post
                            Yep, just run an aforementioned command to run PTS from the CLI or run phoronix-test-suite system-info or something similar.
                            I run phoronix-test-suite benchmark encode-ogg and got this


                            libtool: install: warning: relinking `libvorbisfile.la'
                            libtool: install: warning: relinking `libvorbisenc.la'
                            configure: WARNING: libcurl missing
                            configure: WARNING: libao missing
                            configure: WARNING: libFLAC missing
                            configure: WARNING: libOggFLAC missing
                            configure: WARNING: libFLAC headers missing
                            configure: WARNING: libspeex missing
                            configure: WARNING: libspeex headers missing
                            configure: WARNING: FLAC and/or OggFLAC libraries or headers missing, oggenc
                            will NOT be built with FLAC read support.
                            configure: WARNING: Prerequisites for ogg123 not met, ogg123 will be skipped.
                            Please ensure that you have POSIX threads, libao, and (optionally) libcurl
                            libraries and headers present if you would like to build ogg123.
                            oggenc.c: In function ‘parse_options’:
                            oggenc.c:775: warning: comparison with string literal results in unspecified behavior
                            resample.c: In function ‘res_init’:
                            resample.c:177: warning: comparison with string literal results in unspecified behavior
                            /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:56: warning: ‘OV_CALLBACKS_DEFAULT’ defined but not used
                            /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:63: warning: ‘OV_CALLBACKS_NOCLOSE’ defined but not used
                            /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:70: warning: ‘OV_CALLBACKS_STREAMONLY’ defined but not used
                            /root/.phoronix-test-suite/installed-tests/encode-ogg/vorbis/include/vorbis/vorbisfile.h:77: warning: ‘OV_CALLBACKS_STREAMONLY_NOCLOSE’ defined but not used

                            what could have happen, I really was enjoying this

                            At the end I uploaded the results and had a graph with 52.12

                            http://global.phoronix-test-suite.co...046-9398-27526

                            can tell me whats going on Please I desperately needed to understand this tool.
                            thx

                            Comment


                            • #15
                              Those are just code warnings produced when you compile something.... LAME has some warnings and what not, but as you can see, it built.

                              So the Phoronix Test Suite is working.

                              BTW, you probably should upgrade the Phoronix Test Suite, 1.8.1 is rather old.
                              Michael Larabel
                              http://www.michaellarabel.com/

                              Comment

                              Working...
                              X